• UEFI dual bot with win10 Grub doesn't appear


    Hi, I have just installed antergos on my notebook with UEFI. But when I restart grub doesn’t load, it goes directly to win10. For the instalation I created 3 partitions one for root another one for swap and another for the swap. for the EFI(/boot/EFI), I chose the one that was fat32.

    I have never dual booted before so I know nothing about grub or bootloader configuration.

    Looking for an answer on internet I ended on the arch wiki article about a similar model of my ultrabook and it says the following:

    The laptop firmware seems to have a preference to boot Windows even when other bootmanagers are present.
    A solution is to move your bootloader to a recognised location such as /EFI/Boot/bootx64.efi
    It is important to add the efi entry with the label “Windows Boot Manager” and EFI/Boot/Bootx64.efi as path, else Sony firmware does not load it. Add the efi entry for your bootmanager with: efibootmgr -c -g -d /dev/sda -p 1 -w -L “Windows Boot Manager” -l ‘\EFI\Boot\Bootx64.efi’ Verify that your bootloader is in the first position of the boot order with: efibootmgr -v

    But as I said I am new , I don’t know how to move my bootloader, I supose it is in the EFI partition but I don’t know how to Access it. I tried running antergos live with an USB stick and check the efibootmgr -v but grub doesn’t appear there.

    I hope someone know how to solve it.

    Thanks in advance

  • What is the model of your laptop?

  • @Tudor-Plugaru It’s a Sony Vaio pro 13, non touch screen versión

    The article of the arch wiki is from a simiar model I think

  • Have you checked if a new entry is available in the boot device order? For example, on my HP I have to enter every time in bios to select antergos_grub from there to boot into antergos. The HP made the BIOS so that only Windows is default OS that is booted.

  • @Tudor-Plugaru I have just checked and there isn’t an option for that. I can only choose between HDD boot or external device.

  • I have been Reading info about my laprtop and I think the solution of my probmes is to fix the bootloader location.

    for a deabian instalation I found this:

    Go to /target/boot/efi/EFI, there should be three directories:

    Boot/: the original boot loader
    Microsoft/: microsoft chain loader
    debian/: the Grub EFI boot loader
    

    Do the following freshuffling:mv Boot Boot.orig
    mv debian Boot
    cp Boot/grubx64.efi Boot/bootx64.efi

    I suppose I have to do something similar but I don’t know how to do it. /boot/efi/EFI is in the boot/EFI partition, isn’t it? How can I Access that partition to move the bootloader?

    EDIT : I managed changes on the bootloader from the file explorer( I could mount it from terminal) but the computer continue to boot directly into Windows. So now on /EFI/Boot/ there are grubx64.efi and bootx64.efi. I use efibootmgr -v and showed me that the first boot is /EFI/Boot/bootx64.efi, I don’t know what to do now

uefi grub win102 Posts 6Views 1423
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.