• GRUB not showing after succesfull installation of Antergos


    Hi,
    yesterday I installed Antergos using advanced installation. I have two hdds- 320GB + 500GB and Windows 10 in UEFI mode (boot is set to UEFI). I created 3 partitions - root (sda6), /home (sda8) and /boot/efi (sda7) (photos of partition list: here and here ) and in boot priority options in bios I put antergos_grub on top of the list (photo). Unfortunately after multiple restarts i cannot get into GRUB2 to pick OS to boot - it just jumps to Windows Boot Manager. When i press esc in WBM i see this list. When i pick one of two UEFI Shell options i get this or this.
    What should I do now? Should I mount /boot/efi on /sdb2 (I guess it might be related to uefi boot or it’s windows hidden partition)?
    Thanks in advance

    EDIT:
    I read related thread and executed
    bcdedit /set {bootmgr} path \EFI\antergos_grub\grubx64.efi
    but nothing changed

  • Usually people should avoid the EFI nightmare, it brings nothing but troubles. Also, you won’t benefit from it.

    I have no experience in that area, but I can advice you to boot into Win with something like supergrubdisk, and disable UEFI, then install Antergos in legacy BIOS mode. You can make a rescue USB key with supergrub from Antergos live session, the .iso is only 15Mb in size and you write it easily with “dd” command.

    Cheers. 😄

  • from antergos
    sudo pacman -S update-grub

    from antergos or manjaro
    sudo update-grub

    that will fix your grub issues

  • Thanks for your replies! Today I had more time to figure out what had happened and that’s the situation: I managed to get into EFI Shell, found which device I should mount and manually run grub from file. Then I used Lizzi’s commands to add Windows to that grub. Now the problem is that it isn’t loaded automagically, but I think I’ll figure this out.

  • The correct commands to update grub menu for Arch based systems, in this case, Antergos is
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    It an ‘o’. not a zero that you see in the command.

    sudo update-grub is for debian based system of which Antergos/Arch is not. There are fundamental differences between systems like Ubuntu and Arch systems. Use the correct command I supplied.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Dont worry,that’s the command I run after some googling 🙂 Thanks

  • And so is your other operating system in the new grub menu now?

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Yes, but in order to see grub i have to manually mount and start it from efi shell

  • @Modisc fair enugh. I am a newbie to arch. All i can say is that after i booted my arch antergos install i had no grub so i kept trucking and installed manjaro that picked up the antergos kernels. And when i went into antergos i did exactly as i had said and it worked but i see that its not the correct way for arch and im glad i now know. thanks! I have no idea what problems it could cause and im not wishing to tempt fate. Fates not been kind to me of late.

  • Ahhh. 😀
    Another multi-boot user. Awesome!!! I tried Manjaro a few years back. It was one of those distro’s that I had distro hopped with.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • This post is deleted!
installation260 boot249 grub104 Posts 11Views 7217
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.