• Issue with Gnome and GDM

    After the known issues with Lightdm, I decided to move to GDM, at least for the time being.
    Not without issue. Now i can see and choose between users. But after login, i get stuck with the grey GDM default background, until i try to change to a TTY. Trying to change to a TTY starts Gnome in TTY 2, and GDM login screen is permanently in TTY 1. Usually the DM (Lightdm, GDM or any other DM) and the DE were both using TTY 7 (called system console i think). In my case GDM is occupying TTY 1 and Gnome is occupying TTY 2, leaving TTY 3 to TTY 6 free, and TTY 7 with a blank cursor.

    Am I the only one with this issue and does anyone have any idea how to fix this?
    Please help.

  • Same here, but only on a new install. I had gnome 3.16 on the same machine, I upgraded to 3.18 and gdm worked fine… don’t really know why.

    Edit: btw this issue is also discussed at https://bbs.archlinux.org/viewtopic.php?id=203416

  • Same here… at the grey screen I just tap the ESC key and the desktop loads right up. No idea what that means but its a functional workaround for me.

  • GDM is the only active DM?
    If not - eg:
    sudo systemctl disable lightdm.service && sudo systemctl enable gdm && sudo reboot
    This should now work.

  • @garshol I was using GDM because of “the LightDM” bug… Since “yesterday” (4 hours ago -_-) update LightDM looks to be fixed so i changed back to LightDM… Thou i would love to see GDM working properly

  • @quimkaos No issues what so ever found here with gdm and Gnome 3.18.

    Regarding the tty okkupation, it might come from not rebooting the computer, as i have seen this happen when switching desktop managers without rebooting.

    If the issue is resolved, please close this thread.

  • No, the issue is not resolved. If i use GDM (which i prefer) GDM is still using tty1 and shell is using tty2. Plus, with GDM, gnome-shell won’t start, unless I press escape key or change tty.
    Also this has other side effects, like automatic screen lock and automatic screen turn off, behave randomly. And when they work, turn off pc, lock and hibernate disappear.
    to me this is a really strange behaviour and, IMHO, not rebooting is not a solution. But if mods want this topic as resolved, it’s ok.

  • @quimkaos FIle a bugreport over at https://bugzilla.gnome.org/
    I did not find any related bugs created within the last 5 days.

  • I also am suffering from similar issue. Except GDM does not fully launch. It is still attempting to launch on tt1. I’ll investigate further, but just posting quickly with the hopes someone else will respond with a solution. I have yet to look at my logs, but as mentioned earlier, i will be looking into it further in a little while.

  • @SirWeazel Did you have a look at your logs?

  • @garshol
    Sorry, but i got distracted and haven’t had a minute to touch back. This problem might be related to my nvidia driver. I tried reinstalling glib2 because i read somewhere that might be the issue. I also tried reinstalling another package because it setup new config files when reinstalled (but i can’t remember what it was) and it didn’t help either. Then i found out if I just switch to another TTY and

    systemctl stop gdm.service
    systemctl start gdm.service

    Then it would load up fine. After logging in, if i enable automatic logon, then it boots up correctly and logs into the account without issue. This is not a good solution, but works in the meantime. After every update, i disable it to see if the issue is resolved yet.
    My googlefu found the following forum that provides some information. It looks like the problem is known, and maybe a patch is being worked on. I’m just waiting it out to see if it gets fixed with an update.

    I’ve included my logs if someone sees something i might be missing. Note, i don’t have any gdm logs. I think that logging is disabled by default for gdm. Let me know if this helps, or if you want me to help troubleshoot somehow. When i collected my logs, i disabled the autologon feature and booted each time. After booting, i stopped gdm and started gdm. I collected the logs while in gnomeshell. During my troubleshooting, i disabled gdm and thought i would just start it after bootup. That didn’t work. I would still have to stop it and start it again. It wouldn’t startup upon first start. So i renabled the service.
    I had to redit the post because my logs were larger than 1MB i guess?

  • I wanted to follow up to my above post. Another work around that also works for me is to uncomment #WaylandEnable=false in /etc/gdm/custom.conf

    To sum up, for me i found 3 separate possible work arounds that each work for me.

    1. upon boot, just swith to another TTY and stop/start gdm again.
    2. enable automatic login
    3. uncomment waylandenable=false from custom.conf
gnome361 lightdm137 gdm49 Posts 12Views 4480
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.