• Error When Integrating Google Drive with Files


    I’m getting a “volume doesn’t implement mount” error when trying to integrate my Google Drive with Files in Gnome 3.18. I’ve installed gvfs-google and gvfs-goa. Anyone else having this issue with integrating Google Drive?

  • Hi, I’m having the same issue on my Arch linux. Can’t figure out why unfortunately…

  • You might have to select to connect to it (Right Click).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc Right-click -> Mount still gives same error.

  • @bazini2880
    Ok. I’m assuming that everything is correct in the Gnome Online accounts settings. And you have installed all the dependencies for Google Drive for Gnome.

    I think you might even need udisks2
    That dep is for mounting functionality. Check to see if you have that.

    When you select by right-clicking in the left hand side of nautilius file manager, please first try this:

    1. Left click the server for your Google Drive which should show up with your email address;
    2. After left - clicking on that server with your email address on it, it should show up in the right hand pane of your window manager now. (At least it does for me).
    3. Can you try to right click on it and either mount and/or connect to it. (more than once might even be possible).

    Post here your success or failure. I’ll do my best to help you.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi Modisc,
    For my side, gvfs-goa and gvfs-google are installed.
    udisks2 is installed as well.

    In nautilus, left pane :

    • if I simply left click on the gdrive account , dialog “Unable to access “[email protected]” "volume doesn’t implement mount” pops up. No change on the main pane, displaying previous content.
    • if I right click on the account from the left pane, contextual menu with a “Mount” option. (In addition of standard ones such as add bookmark, open in new tab/window, etc). Selecting “mount” gives the same error dialog.
  • @Modisc Checked and I have udisks2. Also getting same result as @Freddy. Grasping at straws here but are you using two step verification as well?

  • @bazini2880 indeed I am using 2 steps verification on my google account. I was having the same intuition.

  • Turning off two step verification had no effect.

  • Nautilus -> Other Locations -> r.mouse button on Google server -> Connect

  • Indeed, 2-step verification does not really enter the equation. It does not with me either.

    Before we progress further to finding a solution, please ensure that inside your Google account, you have Gnome as your connected apps in Sign-in & security> Manage your account access and security settings> Apps connected to your account It (Gnome) should be listed since you integrated it into your Online Accounts where you gave it access to files, mail, chat, etc… by selecting the appropriate selection to either ON or OFF for each service.

    Could you also check and make sure that you have gvfs installed. The latest version is gvfs-1.26.1-3 . You mentioned earlier that you have the other two gvfs related deps.

    A simple command of gvfs-mount -l might tell/show your Google Account. Please check it is listed. It should be. If it isn’t then your missing some other dependency. Mine is shown as an example below ( for privacy issues, I have removed my own personal email address):

    Volume(0): [email protected]
      Type: GProxyVolume (GProxyVolumeMonitorGoa)
      Mount(0): [email protected] -> google-drive://[email protected]/
        Type: GProxyShadowMount (GProxyVolumeMonitorGoa)
    Mount(1): [email protected] -> google-drive://[email protected]/
    

    If unmounted, it will only show Volume(0)
    Could you please do the following and ensure you have all the necessary mount points inside this directory/folder:

    cd /usr/share/gvfs/mounts then do ls

    there should be listed a number of mount point rules. Not all of them are related to Google accounts. Some of them are related to other rules.

    Within the directory: /usr/lib/gvfs/ are gvfs related deps.

    Check to see if you have gvfsd and gvfsd-fuse installed. I am not 100 percent sure, but you might need libgvfsdaemon.so and perhaps gvfsd

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Output of gvfs-mount -l:
    Volume(0): ********@gmail.com
    Type: GProxyVolume (GProxyVolumeMonitorGoa)

    I’m currently running gvfs-1.26.13 and Gnome is integrated into my Google account.

    Contents of /usr/share/gvfs/mount:

    afp-browse.mount cdda.mount dns-sd.mount http.mount sftp.mount
    afp.mount computer.mount ftp.mount localtest.mount trash.mount
    archive.mount dav.mount ftps.mount network.mount
    burn.mount dav+sd.mount google.mount recent.mount

    Contents of /usr/share/gvfs/remote-volume-monitors:
    goa.monitor udisks2.monitor

  • I have “mount not implemented for this volume” issue. I’ve found a workaround (not a solution) after reading this post on archforum
    https://bbs.archlinux.org/viewtopic.php?pid=1570068#p1570068

    Maybe this is a bug. If I click on “other locations”, i can see my google drive account in "Network"
    When I click on it nothing happens.
    But if I click on it with right mouse and pick “Open in new Tab” or “Open in new window” The vfs >is mounted perfectly and works like a charm!

    Just a temporal solution

    I had the same issue with an owncloud account too

  • @XoseM This does the trick for me. Thanks for sharing. What about you @bazini2880 ?

  • Success! Thank you @XoseM. And thank you to @Modisc for all of your help as well.

Posts 15Views 3201
Log in to reply