• GNOME 3.18 won't launch. Only cursor is available and screen is black.

    Since GNOME 3.18.0 I am unable to launch DE (other “ttys” work). Only cursor is available and small white dot is appearing in the left of top corner.
    I am on linux-lts and I am using catalyst drivers from vi0l0 repo (gpu: r9 380).
    Is that just error which came with 3.18.0, incompatibile drivers ? Did anyone notice this ?
    Many thanks for help.

  • @melkir This is not my problem … I can login, but environment is black. I will take a picture.

    EDIT: This my screen after login.

  • I am having the same issue, allthough I am not using antergos (I am an arch user)
    At first I was having this issue with gdm 3.18,. I couldn’t find a solution to it so I switched to LXDM.
    Now I can enter my credentials in LXDM, but when gnome is started I get a black screen with a white dot in the top left corner.
    I am using a Radeon HD 6950 with catalyst driver.

  • I have the same issue. using lightDM i get the VConsole ghosted on the screen but can login but get a cursor with a black screen like yourselves, with GDM i get the black screen straight away. I tried installing an alternate DE’s to find cinnamon with lightdm gives me the same result. for the time being to get my system functional at the very least I have now installed Slim for logon and MATE for desktop. and just added a .xinitrc file to my user

    I am using the LTS kernel and LTS catalyst driver
    Hardware Radeon 6870

    on the plus side I have discovered switching to Slim+Mate has resolve other graphical issues I was having using Gnome which is a shame because I really like Gnome 3 and would rather use it if it worked

  • Hmm, so the only solution is switching to another DE or waiting for fix from gnome devs ?

  • I had a similar issue, after login, i couldn’t use any of the DE icons/interface. The interface was there but it was unusable, thou i could use the keyboard to use the dash (by using the superkey and typing the application i needed). I ended reinstalling the system, formatting my / partition and keeping my /home intact… 20mn solution in a 7 years PC…

  • I find the same issue, for now I just “do” hover the mouse on the blank screen untill I saw “hand icon” as the cursor. After that, just click it, and type my password, then press “enter”.

    That just my temporary solution.

  • I’m having a similar issue if you mean that you are able to login first but I am not having it as bad as you.

    Basically I can login just fine (although the login thing seems a bit buggy and appears to be made in a web browser because I can right click inspect element) but for about 10 or so seconds the screen is black like that until I get in and everything is normal… this is on an SSD and an overclocked i5 2500k as well… (Gtx 560ti if the gpu really matters)

Posts 9Views 3089
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.