• TODO: Macbook EFI installer


    I got something like the above message when I tried installing on my early 2008 Macbook Pro. Where can I follow the progress on this? Would love to use some snappy Arch instead of slow OS X, and Manjaro has display/video driver problems.

  • Hi. Have you checked out this Arch Wiki link on that particular machine here:

    link text

  • Thanks for the link. I have an nVidia card though, and I believe I tried the efistub option.

  • Honestly, then I don’t know. I’d hate to give you advice or directions that might prove faulty to your install on a Mac. Are you wanting to wipe Macintosh off completely and install on it instead Antergos? Or dual-boot?

  • Complete wipe.

  • So I gather that because you already tried efistub, reFind didn’t work for you and the nVidia drivers didn’t co-operate.
    I’m just curious, have you come across this here: link text I think it’s older. Other than that, man. I’m sorry. I really don’t know.

    By the way, that same Macbook link from the Arch Wiki also has an interesting link to a discussion. Your trying to install the kernel with a built in bootloader, is this correct? If so, here is the link from the 1st link to this 2nd link: link text

  • Thanks for trying to help. I’m not sure if rEFInd is the problem. It’s just that Antergos’s bootloader options don’t seem to cover my case and there was actually a todo popup.

  • Hi!

    Could you post the number and specs of the MacBook pro? Without that we are only clutching at straws here. The installation procedure could be a bit different depending of the model number.
    I have 2 MacBooks myself and I know It can be tricky but It can also be easy!

    JW

  • I’m pretty sure it’s a Macbook Pro 4.1 Penryn, early 2008, 15.4 inch, NVIDIA GeForce 8600M GT graphics processor with dual-link DVI support; 256MB of GDDR3 memory on 2.4GHz configuration.

    I can’t find anything about what my lousy memory told me was an infamous graphics glitch, but I just realized I need to reinstall rEFInd.

  • [email protected] X.
    Try inputting this command into your Terminal. It might tell you a bit more to confirm your ideas of what your computer is with respect to your computer. lscpu
    If you do this: sudo cat /sys/devices/virtual/dmi/id/* It will confirm for you what type of computer you have (***Since you mentioned that you ‘were pretty sure’— this is just to confirm for yourself)***. Hope that helps a bit more for you.

  • Hello again!

    When it comes to graphic drivers you cannot use the latest NVIDIA prop.drivers but the older ones are absolutely good enough.
    I did not really understand what is going wrong with your installation?
    Bootloaderproblem?

  • I don’t remember if it was a bootloader problem or a graphics driver problem. Antergos works nicely as a live usb so I’ll try the aforementioned command and reinstall rEFInd after I set up the usb again. Thank you all.

  • This post is deleted!
installation289 uefi37 macbook24 efi16 mac5 Posts 13Views 2366
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.