• Boot freezes at RF Kill


    Hello, I have a 32-bit netbook. I am able to install and get to the bootscreen. Upon entering (in verbose mode), I get stuff loaded until it freezes with a fast-blinking cursor.

    [ OK ] Started Light Display Manager.
    [ OK ] Started Load/Save RF Kill Swich Status of rfkill.[fast-blinking _]

    I have an Openbox install along with a / (8GB) on a “USB: Single Flash reader” /home on a different SSID (8 GB) and swap on another 4 GB SSD. I have 1 GB memory installed on this ASUS EEE PC901.

    Any suggestion? Thanks for your time!

    Best wishes.

  • HI @aarem

    So what you do is look at your journalctl.

    Do sudo journalctl -b and look for timeouts, hangs, and dependency faults. The reason you look for dependency faults is because systemd can at times not be quite as robust as one would hope. Dependencies sometimes lock up and prevent continuation of the boot processes.

    Things like rfkill are or can be, volatile and unpredictable.

    You mention about a USB. You have to sudo umount /dev/sdXX if you want to un-mount it properly or go to your file manager, right-click on that drive, and un-mount the USB as opposed to directly pulling it out of your port (if that is what your doing).

    The reason I mention this about USB drives being properly un-mounted is because you might experience failed deps.

    So basically what happens is that deps are just waiting indefinitely. Hence the hanging (my guess, that is).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    HI @aarem
    Do sudo journalctl -b and look for timeouts, hangs, and dependency faults. The reason you look for dependency faults is because systemd can at times not be quite as robust as one would hope. Dependencies sometimes lock up and prevent continuation of the boot processes.

    Thank you! How do I do this? The system does not actually boot to anytthing so I have nothing to look for.

    Things like rfkill are or can be, volatile and unpredictable.

    True. But this is happening regardless of anything else, after an install. Never has it actually booted onto the login screen.

    You mention about a USB. You have to sudo umount /dev/sdXX if you want to un-mount it properly or go to your file manager, right-click on that drive, and un-mount the USB as opposed to directly pulling it out of your port (if that is what your doing).

    Same question here. Btw, even with the failsafe mode in the grub option, I end up at the same place. Any suggestions on how to get around this?

    The reason I mention this about USB drives being properly un-mounted is because you might experience failed deps.

    So basically what happens is that deps are just waiting indefinitely. Hence the hanging (my guess, that is).

    Thanks again for trying to help!

    Best wishes!

  • @aarem
    HI. Sorry for a bit of a late reply (went out hiking for a day and half).
    Sorry, my bad. I completely misunderstood you. I thought that you still had access to your DE, which sounds like you don’t. Is this correct?
    Are you able to get a hold of a live CD of Antergos? Do you know or are you familiar with chroot ?
    As is looks, it is your option to do so. This way, via the chroot cmd, you will be able to access your Antergos partition via the live ISO and gather the journal boot records from the command I gave earlier in my post above. You can also get boot logs using the live ISO to determine what is most obviously wrong. Again, I suspect it’s related to my explanation above but it’s best to have a look first.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    @aarem
    HI. Sorry for a bit of a late reply (went out hiking for a day and half).
    Sorry, my bad. I completely misunderstood you. I thought that you still had access to your DE, which sounds like you don’t. Is this correct?
    Are you able to get a hold of a live CD of Antergos? Do you know or are you familiar with chroot ?
    As is looks, it is your option to do so. This way, via the chroot cmd, you will be able to access your Antergos partition via the live ISO and gather the journal boot records from the command I gave earlier in my post above. You can also get boot logs using the live ISO to determine what is most obviously wrong. Again, I suspect it’s related to my explanation above but it’s best to have a look first.

    Thanks! Yes, I have the Antergos Live USB. And I am aware of the chroot command. What do I do with it? Many thanks!

  • Hi.
    Again, sorry for the late reply.

    With chroot, your entering your Antergos /dev/sdaXX and gathering the boot records from there.
    You will need to load up your Antergos ISO file. Internet connection is not required unless you wish to roam the net with it and research additional information to this ‘rfkill’ problem.

    Also, I would like to ask you, do you have a dual or multi boot system installed on your computer from which to access files from, from you Antergos partition?

    Steps:
    Open a terminal and input the following commands:
    With this command displayed below, you must determine which /dev/sdaXX your Antergos partition is on.
    sudo fdisk -l

    Once that information has been established, prepare to make a directory for chrooting. Do the following:

    sudo mkdir /mnt/sdaXX
    

    Prepare to chroot and continue with these commands below:

    sudo mount /dev/sdaXX /mnt/sdaXX
    sudo chroot /mnt/sdaXX
    

    Make a directory to store your logs in. Do the following:

    sudo mkdir /tmp/logs
    

    Gather the logs. Do the following:

    journalctl -b -0 > /tmp/journal.log
    journalctl -b -1 > /tmp/journal.log1
    journalctl -b -2 > /tmp/journal.log2
    

    Now you will cd into your /tmp directory and copy the files you just finished creating and have those same files copied to your logs folder which you also created. Do the following:

    cd /mnt/sdaXX/tmp && cp journal** /tmp/logs
    

    Because you placed those logs onto your Antergos partition, and the fact you can’t get into your Antergos partition, instead you can place them into a USB drive instead of your /dev/sdaXX/tmp/logs directory. You can also gather them from a second OS that might be on your system (again, if you have a multi-boot set up that is). Or if you decided to establish internet connection, you can upload them to say, DropBox, for example and then grab them from there afterwards.

    I would suggest that you look through your journal files (it helps to have more than 1 pair of eyes look at things like this at times) as well as post them using a pastebin service.

    Secondly, using the Arch Wiki is an invaluable source of information. It was written by a bunch of people who are very knowledgeable on the Arch systems. It helps to establish a connection to reading the Wiki.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi, I have a problem in that I can not do a chroot? How does one get there?
    Btw, the issue has remained even after reinsalling / and /boot to a SSID.

  • You begin with a live ISO of Antergos to be ale to chroot. There is a way to do it if you have a second operating system installed, but apparently, you shouldn’t do it
    ***. I would advise to do it with a live CD of Antergos instead. ***

    EDIT. What about entering your system using the non - GUI entry. Able to do that instead of chroot?
    EDIT #2: When you say ‘in verbose mode’ are you saying you can get in via tty?

    In case you ever want to educate yourself on chrooting: link text

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • Hi,
    Thanks! When I say verbose mode, I meant the graphical boot verbose with “quiet” removed from the boot parameter.

    I can not get into the graphical log in. But I can with a Ctrl-Alt-F1, however when I log in, I am not able to get the X server started using startx. All in commandline mode.

    Thanks again!

  • Does this not work either xinit -- :1 -nolisten tcp vt$XDG_VTNR after trying to get in?

    Have you considered that you might have a video driver configuration issue?

    First, do this for me:

    script
    lspci | grep -e VGA -e 3D
    Then press CTRL+D.

    You will find a file called typescript in your home folder. Grab a live CD and get that file, a.k.a. ‘typescript’ and post the output of that here. Or insert a USB and use the mv commands to move that typescript file onto that USB.

    It’s really difficult to determine anything about your video drivers just by reading something you have posted that it is a 32 bit machine. We need to see the video drivers because there might be video driver deps that are missing.

    We will go from there.

    EDIT Can you please also post the exact output that you get of you not being able to initiate startx? Write it down if you have to. Pens and paper are still existing.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Does this not work either xinit -- :1 -nolisten tcp vt$XDG_VTNR after trying to get in?

    No, it gives rise to the Xorg.1.log file which is attached.

    Have you considered that you might have a video driver configuration issue?

    This is possible, but the LiveCD works fine without any apparent issue. (Of course, the LiveCD runs Gnome and I am using Openbox).

    First, do this for me:

    script
    lspci | grep -e VGA -e 3D
    Then press CTRL+D.

    You will find a file called typescript in your home folder. Grab a live CD and get that file, a.k.a. ‘typescript’ and post the output of that here. Or insert a USB and use the mv commands to move that typescript file onto that USB.

    Script started on Sun 18 Oct 2015 09:37:07 AM CDT
    [aarem@flippy ~]$ lspci | grep -e VGA -e #3D
    00:02.0 VGA compatible controller: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller (rev 03)
    [aarem@flippy ~]$ exit

    Script done on Sun 18 Oct 2015 09:37:36 AM CDT

    It’s really difficult to determine anything about your video drivers just by reading something you have posted that it is a 32 bit machine. We need to see the video drivers because there might be video driver deps that are missing.

    The Xorg.1.log file is attached:

    [[Xorg.1.log](uploading 100%)    555.330] 
    X.Org X Server 1.17.2
    Release Date: 2015-06-16
    [   555.338] X Protocol Version 11, Revision 0
    [   555.341] Build Operating System: Linux 4.0.4-2-ARCH i686 
    [   555.343] Current Operating System: Linux flippy 4.2.3-1-ARCH #1 SMP PREEMPT Sat Oct 3 19:08:23 CEST 2015 i686
    [   555.344] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=d15d9039-cbd6-47c6-ad59-e04fdcba4c3d rw resume=UUID=76946155-f054-47a6-83b5-9eb4ca1e93a1 quiet
    [   555.352] Build Date: 17 July 2015  05:40:14PM
    [   555.355]  
    [   555.358] Current version of pixman: 0.32.8
    [   555.363] 	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    [   555.364] Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    [   555.375] (==) Log file: "/home/aarem/.local/share/xorg/Xorg.1.log", Time: Sun Oct 18 09:39:23 2015
    [   555.378] (==) Using config directory: "/etc/X11/xorg.conf.d"
    [   555.381] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
    [   555.382] (==) No Layout section.  Using the first Screen section.
    [   555.382] (==) No screen section available. Using defaults.
    [   555.382] (**) |-->Screen "Default Screen Section" (0)
    [   555.382] (**) |   |-->Monitor "<default monitor>"
    [   555.382] (==) No monitor specified for screen "Default Screen Section".
    	Using a default monitor configuration.
    [   555.382] (**) Option "DontZap" "false"
    [   555.382] (==) Automatically adding devices
    [   555.382] (==) Automatically enabling devices
    [   555.382] (==) Automatically adding GPU devices
    [   555.382] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
    [   555.382] 	Entry deleted from font path.
    [   555.382] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
    [   555.382] 	Entry deleted from font path.
    [   555.382] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
    [   555.382] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
    [   555.383] 	Entry deleted from font path.
    [   555.383] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
    [   555.383] (==) FontPath set to:
    	/usr/share/fonts/misc/,
    	/usr/share/fonts/TTF/,
    	/usr/share/fonts/OTF/
    [   555.383] (==) ModulePath set to "/usr/lib/xorg/modules"
    [   555.383] (II) The server relies on udev to provide the list of input devices.
    	If no devices become available, reconfigure udev or disable AutoAddDevices.
    [   555.383] (II) Loader magic: 0x829f6c0
    [   555.383] (II) Module ABI versions:
    [   555.383] 	X.Org ANSI C Emulation: 0.4
    [   555.383] 	X.Org Video Driver: 19.0
    [   555.383] 	X.Org XInput driver : 21.1
    [   555.383] 	X.Org Server Extension : 9.0
    [   555.394] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
    [   555.396] (II) xfree86: Adding drm device (/dev/dri/card0)
    [   555.398] (II) systemd-logind: got fd for /dev/dri/card0 226:0 fd 8 paused 0
    [   555.402] (--) PCI:*(0:0:2:0) 8086:27ae:1043:830f rev 3, Mem @ 0xf7f00000/524288, 0xd0000000/268435456, 0xf7ec0000/262144, I/O @ 0x0000dc80/8
    [   555.402] (--) PCI: (0:0:2:1) 8086:27a6:1043:830f rev 3, Mem @ 0xf7f80000/524288
    [   555.402] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
    [   555.402] (II) LoadModule: "glx"
    [   555.403] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
    [   555.407] (II) Module glx: vendor="X.Org Foundation"
    [   555.407] 	compiled for 1.17.2, module version = 1.0.0
    [   555.407] 	ABI class: X.Org Server Extension, version 9.0
    [   555.407] (==) AIGLX enabled
    [   555.408] (==) Matched intel as autoconfigured driver 0
    [   555.408] (==) Matched intel as autoconfigured driver 1
    [   555.408] (==) Matched modesetting as autoconfigured driver 2
    [   555.408] (==) Matched fbdev as autoconfigured driver 3
    [   555.408] (==) Matched vesa as autoconfigured driver 4
    [   555.408] (==) Assigned the driver to the xf86ConfigLayout
    [   555.408] (II) LoadModule: "intel"
    [   555.408] (WW) Warning, couldn't open module intel
    [   555.408] (II) UnloadModule: "intel"
    [   555.409] (II) Unloading intel
    [   555.409] (EE) Failed to load module "intel" (module does not exist, 0)
    [   555.409] (II) LoadModule: "modesetting"
    [   555.409] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
    [   555.409] (II) Module modesetting: vendor="X.Org Foundation"
    [   555.409] 	compiled for 1.17.2, module version = 1.17.2
    [   555.409] 	Module class: X.Org Video Driver
    [   555.410] 	ABI class: X.Org Video Driver, version 19.0
    [   555.410] (II) LoadModule: "fbdev"
    [   555.410] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
    [   555.410] (II) Module fbdev: vendor="X.Org Foundation"
    [   555.410] 	compiled for 1.17.0, module version = 0.4.4
    [   555.410] 	Module class: X.Org Video Driver
    [   555.410] 	ABI class: X.Org Video Driver, version 19.0
    [   555.410] (II) LoadModule: "vesa"
    [   555.411] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
    [   555.411] (II) Module vesa: vendor="X.Org Foundation"
    [   555.411] 	compiled for 1.17.2, module version = 2.3.4
    [   555.411] 	Module class: X.Org Video Driver
    [   555.411] 	ABI class: X.Org Video Driver, version 19.0
    [   555.411] (II) modesetting: Driver for Modesetting Kernel Drivers: kms
    [   555.411] (II) FBDEV: driver for framebuffer: fbdev
    [   555.411] (II) VESA: driver for VESA chipsets: vesa
    [   555.411] (++) using VT number 1
    
    [   555.411] (--) controlling tty is VT number 1, auto-enabling KeepTty
    [   555.412] xf86EnableIOPorts: failed to set IOPL for I/O (Operation not permitted)
    [   555.412] (II) modeset(0): using drv /dev/dri/card0
    [   555.412] (WW) Falling back to old probe method for fbdev
    [   555.412] (II) Loading sub module "fbdevhw"
    [   555.412] (II) LoadModule: "fbdevhw"
    [   555.412] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
    [   555.412] (II) Module fbdevhw: vendor="X.Org Foundation"
    [   555.412] 	compiled for 1.17.2, module version = 0.0.2
    [   555.412] 	ABI class: X.Org Video Driver, version 19.0
    [   555.412] (WW) Falling back to old probe method for vesa
    [   555.413] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
    [   555.413] (II) modeset(0): Creating default Display subsection in Screen section
    	"Default Screen Section" for depth/fbbpp 24/32
    [   555.413] (==) modeset(0): Depth 24, (==) framebuffer bpp 32
    [   555.413] (==) modeset(0): RGB weight 888
    [   555.413] (==) modeset(0): Default visual is TrueColor
    [   555.413] (II) Loading sub module "glamoregl"
    [   555.413] (II) LoadModule: "glamoregl"
    [   555.413] (II) Loading /usr/lib/xorg/modules/libglamoregl.so
    [   555.441] (II) Module glamoregl: vendor="X.Org Foundation"
    [   555.441] 	compiled for 1.17.2, module version = 1.0.0
    [   555.441] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [   555.441] (II) glamor: OpenGL accelerated X.org driver based.
    [   555.473] (II) glamor: EGL version 1.4 (DRI2):
    [   555.482] (II) modeset(0): glamor initialized
    [   555.482] (II) Loading sub module "dri2"
    [   555.482] (II) LoadModule: "dri2"
    [   555.482] (II) Module "dri2" already built-in
    [   555.482] (II) modeset(0): Output LVDS-0 has no monitor section
    [   555.500] (II) modeset(0): Output VGA-0 has no monitor section
    [   555.500] (II) modeset(0): EDID for output LVDS-0
    [   555.501] (II) modeset(0): Manufacturer: AUO  Model: 1020  Serial#: 0
    [   555.501] (II) modeset(0): Year: 2008  Week: 1
    [   555.501] (II) modeset(0): EDID Version: 1.3
    [   555.501] (II) modeset(0): Digital Display Input
    [   555.501] (II) modeset(0): Max Image Size [cm]: horiz.: 19  vert.: 11
    [   555.501] (II) modeset(0): Gamma: 2.20
    [   555.501] (II) modeset(0): No DPMS capabilities specified
    [   555.501] (II) modeset(0): Supported color encodings: RGB 4:4:4 YCrCb 4:4:4 
    [   555.501] (II) modeset(0): First detailed timing is preferred mode
    [   555.501] (II) modeset(0): redX: 0.573 redY: 0.339   greenX: 0.330 greenY: 0.596
    [   555.501] (II) modeset(0): blueX: 0.142 blueY: 0.103   whiteX: 0.310 whiteY: 0.330
    [   555.501] (II) modeset(0): Manufacturer's mask: 0
    [   555.501] (II) modeset(0): Supported detailed timing:
    [   555.501] (II) modeset(0): clock: 50.4 MHz   Image Size:  195 x 113 mm
    [   555.502] (II) modeset(0): h_active: 1024  h_sync: 1048  h_sync_end 1184 h_blank_end 1344 h_border: 0
    [   555.502] (II) modeset(0): v_active: 600  v_sync: 600  v_sync_end 619 v_blanking: 625 v_border: 0
    [   555.502] (II) modeset(0): Unknown vendor-specific block f
    [   555.502] (II) modeset(0):  AUO
    [   555.502] (II) modeset(0):  A089SW01 V0
    [   555.502] (II) modeset(0): EDID (in hex):
    [   555.502] (II) modeset(0): 	00ffffffffffff0006af201000000000
    [   555.502] (II) modeset(0): 	0112010380130b780afa569256549824
    [   555.502] (II) modeset(0): 	1a4f5400000001010101010101010101
    [   555.502] (II) modeset(0): 	010101010101b0130040415819201888
    [   555.502] (II) modeset(0): 	0301c371000000180000000f00000000
    [   555.502] (II) modeset(0): 	00000000000000000020000000fe0041
    [   555.502] (II) modeset(0): 	554f0a202020202020202020000000fe
    [   555.502] (II) modeset(0): 	004130383953573031205630200a0019
    [   555.503] (II) modeset(0): Printing probed modes for output LVDS-0
    [   555.503] (II) modeset(0): Modeline "1024x600"x60.0   50.40  1024 1048 1184 1344  600 600 619 625 -hsync -vsync (37.5 kHz eP)
    [   555.503] (II) modeset(0): Modeline "800x600"x120.0   81.00  800 832 928 1080  600 600 602 625 doublescan +hsync +vsync (75.0 kHz d)
    [   555.504] (II) modeset(0): Modeline "800x600"x60.3   40.00  800 840 968 1056  600 601 605 628 +hsync +vsync (37.9 kHz d)
    [   555.504] (II) modeset(0): Modeline "800x600"x56.2   36.00  800 824 896 1024  600 601 603 625 +hsync +vsync (35.2 kHz d)
    [   555.504] (II) modeset(0): Modeline "700x525"x120.0   61.00  700 744 820 940  525 526 532 541 doublescan +hsync +vsync (64.9 kHz d)
    [   555.504] (II) modeset(0): Modeline "640x512"x120.0   54.00  640 664 720 844  512 512 514 533 doublescan +hsync +vsync (64.0 kHz d)
    [   555.504] (II) modeset(0): Modeline "640x480"x120.0   54.00  640 688 744 900  480 480 482 500 doublescan +hsync +vsync (60.0 kHz d)
    [   555.504] (II) modeset(0): Modeline "640x480"x59.9   25.18  640 656 752 800  480 490 492 525 -hsync -vsync (31.5 kHz d)
    [   555.504] (II) modeset(0): Modeline "512x384"x120.0   32.50  512 524 592 672  384 385 388 403 doublescan -hsync -vsync (48.4 kHz d)
    [   555.504] (II) modeset(0): Modeline "400x300"x120.6   20.00  400 420 484 528  300 300 302 314 doublescan +hsync +vsync (37.9 kHz d)
    [   555.504] (II) modeset(0): Modeline "400x300"x112.7   18.00  400 412 448 512  300 300 301 312 doublescan +hsync +vsync (35.2 kHz d)
    [   555.504] (II) modeset(0): Modeline "320x240"x120.1   12.59  320 328 376 400  240 245 246 262 doublescan -hsync -vsync (31.5 kHz d)
    [   555.520] (II) modeset(0): EDID for output VGA-0
    [   555.520] (II) modeset(0): Output LVDS-0 connected
    [   555.520] (II) modeset(0): Output VGA-0 disconnected
    [   555.520] (II) modeset(0): Using exact sizes for initial modes
    [   555.520] (II) modeset(0): Output LVDS-0 using initial mode 1024x600
    [   555.520] (II) modeset(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated.
    [   555.520] (==) modeset(0): DPI set to (96, 96)
    [   555.520] (II) Loading sub module "fb"
    [   555.520] (II) LoadModule: "fb"
    [   555.521] (II) Loading /usr/lib/xorg/modules/libfb.so
    [   555.523] (II) Module fb: vendor="X.Org Foundation"
    [   555.523] 	compiled for 1.17.2, module version = 1.0.0
    [   555.523] 	ABI class: X.Org ANSI C Emulation, version 0.4
    [   555.523] (II) UnloadModule: "fbdev"
    [   555.523] (II) Unloading fbdev
    [   555.523] (II) UnloadSubModule: "fbdevhw"
    [   555.523] (II) Unloading fbdevhw
    [   555.523] (II) UnloadModule: "vesa"
    [   555.524] (II) Unloading vesa
    [   555.524] (==) Depth 24 pixmap format is 32 bpp
    [   555.525] (WW) glamor requires at least 128 instructions (64 reported)
    [   555.525] (EE) modeset(0): Failed to initialize glamor at ScreenInit() time.
    [   555.525] (EE) 
    Fatal server error:
    [   555.525] (EE) AddScreen/ScreenInit failed for driver 0
    [   555.525] (EE) 
    [   555.525] (EE) 
    Please consult the The X.Org Foundation support 
    	 at http://wiki.x.org
     for help. 
    [   555.525] (EE) Please also check the log file at "/home/aarem/.local/share/xorg/Xorg.1.log" for additional information.
    [   555.526] (EE) 
    [   555.539] (EE) Server terminated with error (1). Closing log file.
    

    Thank you for helping!

  • Hi @aarem

    I am not an Xorg expert, but I might wonder perhaps that Xorg was trying to load up the drivers and it did not find the Intel drivers
    From your log file:

    [   555.408] (WW) Warning, couldn't open module intel
    [   555.408] (II) UnloadModule: "intel"
    [   555.409] (II) Unloading intel
    [   555.409] (EE) Failed to load module "intel" (module does not exist, 0)
    [   555.409] (II) LoadModule: "modesetting"
    

    What is interesting from your log file is where it states: (module does not exist, 0)
    A couple of questions, did you at some point install other graphics drivers, such as from Nvidia for example? If you did, you will have to remove those first.
    Then do: pacman -S xf86-video-nouveau <----(You probably may not need, but just in case)
    Then install the appropriate Intel graphics drivers too: link text
    I am hoping that this will work for you. I did find a good link for reading that may have some application to you. Actually, I’m putting it in my own bookmarks. link text Read and consider this first before trying.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    What is interesting from your log file is where it states: (module does not exist, 0)
    A couple of questions, did you at some point install other graphics drivers, such as from Nvidia for example? If you did, you will have to remove those first.

    No Ijust did a plain install and got what I posted.

    Then do: pacman -S xf86-video-nouveau <----(You probably may not need, but just in case)
    Then install the appropriate Intel graphics drivers too: link text
    I am hoping that this will work for you. I did find a good link for reading that may have some application to you. Actually, I’m putting it in my own bookmarks. link text Read and consider this first before trying.

    OK, will read and see: what I still don’t get is that if drivers are indeed missing, then why this comes up with the LiveCD (before installation).

  • HI.
    @aarem
    Beats me that your able to still get in via Live USB. As I say, I"m no Xorg expert. There is most obviously something that I don’t understand.
    EDIT: Kernel option nomodeset ? Just curious if that would help.

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • @Modisc said:

    Hi @aarem

    I am not an Xorg expert, but I might wonder perhaps that Xorg was trying to load up the drivers and it did not find the Intel drivers
    From your log file:

    [   555.408] (WW) Warning, couldn't open module intel
    [   555.408] (II) UnloadModule: "intel"
    [   555.409] (II) Unloading intel
    [   555.409] (EE) Failed to load module "intel" (module does not exist, 0)
    [   555.409] (II) LoadModule: "modesetting"
    

    What is interesting from your log file is where it states: (module does not exist, 0)
    A couple of questions, did you at some point install other graphics drivers, such as from Nvidia for example? If you did, you will have to remove those first.
    Then do: pacman -S xf86-video-nouveau ** Then install the appropriate Intel graphics drivers too: link text
    I am hoping that this will work for you. I did find a good link for reading that may have some application to you. Actually, I’m putting it in my own bookmarks. link text Read and consider this first before trying.

    In the end, pacman -Syu xf86-video-intel appears to have done the trick. Thanks again for the pointers. This is my first experience with Arch/AntergOS and I like it quite a bit!

  • @aarem
    Awesome. Glad to have helped you out and have the issue fixed. Welcome to Antergos :)

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

boot155 rfkill1 Posts 16Views 1773
Log in to reply