• [Solved!]Antergos will not boot after moving system to new hdd. (on MacBook pro 8,1)

    Now I have tried to fix this problem for about 5 hours and I realize that I may need a hint or two!
    I have moved “Antmac” system from an external hdd to the internal hdd and used the absolutely great live-antergos system to chroot and try to reinstall grub. The problem is that grub won-t install. My head is spinning from this and a bad day at work but I just have one question.
    I do not want to reinstall the system but wondering if I could just use the live-installer to just install gummi-boat and otherwise leave my system intact. Is that possible and how?
    My complements to the new live-system/installer. Works great on MacBook pro!!


  • Hi,

    What commands are you running to install grub? What is the output?

  • you have a mac? why not choose clover or chameleon for your boot loader?

  • Hi!
    I this MacBook I have 2 disks. Nr1 is SSD 250 g and Nr2 is 1 tb hdd. First I made 2 partitions from Nr 2 (one for Antergos) then I made a mac specific "fusion-drive with the second partition on Nr 2 and the whole Nr 1. Then I copied my “AntMac” system from external hdd to partition on Nr 2.
    The setup:
    NR 1
    sda1 efi-partition FAT32 200 mb
    sda2 part of fusion-drive 238 gb
    sda3 Boot OSX hfs+ 128 mb

    NR 2
    sdb1 efi-partition FAT32 200 mb
    sdb2 part of fusion-drive 699 gb
    sdb3 recovery-HD hfs+ 620 mb
    sdb4 Antergos system ext4 225 gb (copied from external drive)
    sdb5 swap 7 gb
    sdb6 efi-partition ext2 100 mb

    I have used grub-install --recheck /dev/sda (and tried with sdb too, same result)
    gives: grub-install error: cannot find EFI directory.
    And I have tried different combinations in mounting sda1 /mnt/boot , sbd1 etc.
    gives the same result!

    Lizzi: I thought chameleon and clover was for “hackintosh”!? On my other MacBook I have rEFInd and Gummiboat, but it´s a 3 year newer model and there I installed on internal SSD (dualbooting) right away.

    I must have done something totally wrong but what?

  • sdb6 is an efi partition but it is listed as ext2 it must be fat32

  • chameleon and clover can boot more than hackintosh as far as i know but the real issue here is your sdb6 partition must be fat32

  • @Lizzi said:

    chameleon and clover can boot more than hackintosh as far as i know but the real issue here is your sdb6 partition must be fat32

    FAT32 and 256 MB

  • Ok!

    I am clutching at straws here so I just made sdb6 to look like the external drive that the system came from. sda1 and sdb1 are both FAT32. They are both 200 mb. Do they really have to be 250 mb?
    Maybe I did something wrong with the copy-process. I cp the whole partition with “/*” to sdb4. Before that I created sdb4 primary with ext4. I didn´t think of any flags! Could that be the problem?

  • Hi again!

    Have been checking the copy process but everything is in place. Can´t see any problem. There was no error messages.

    I still have my “old” “antmac” system on the external hdd and I no trouble booting that! Works great as it did before. It is uncomfortable to have it on external though.
    It could be refind.conf on the mac side. Will check up on that!
    Clover, Chameleon or Gummiboat?

    Antergos Live is really great!!

  • @womp what are you using to copy the partitions? gparted is what i would recommend. after making sdb6 into fat32 you will have to go into /etc/fstab as root with an editor and edit fstab to reflect the correct uuid for the new fat32 and to correct the fstab lising from ext2 to fat32

  • you can also get the uuid of the all partitions from gparted by right clicking on each partition and selecting info from the menu. Make sure all the uuids match up correctly as well as the partition format types.

  • also if you are up to it, it might not hurt to use gparted to assign a new uuid to each partition you copied over from the external usb drive so that if you ever plug in that drive while using the antmac on the internal drive that they will never be in conflict

  • I used cp /dev/sdc7/* to copy. Was that a bad idea?
    GParted seems to be a really “heavy” tool. I will try to follow your intelligent advice! Change filesystem on sdb6 first. And then get all new UUIDs.
    Then I should be able to reinstall grub right? Or should you recommend Clover, Chameleon or Gummiboat?

  • @womp said

    Then I should be able to reinstall grub right? Or should you recommend Clover, Chameleon or Gummiboat?

    grub always !

  • grub is always a great first choice but if it wont work even after all that’s been recommended then perhaps look at other options.

  • Now I have new UUIDs and fstab changed (on new “antmac” root partition sdb4) sdb6 is in FAT32. grub-install --recheck /dev/sdb gives the same result. “cannot find EFI directory”.
    What to do now?

  • show me the contents of fstab

    also sudo update-grub

  • the new fat 32 needs to be mounted in fstab as /boot/efi

  • Great you are still there!
    Here is /mnt/etc/fstab


    UUID=8019244a-7499-4a11-9b77-f1eca2d8a8ca / ext4 $


    UUID=6471-B09C /boot ext2 $


    UUID=463813cd-f91f-467d-bd8c-d3748e78dccf none swap $

    Now I see that I forgot to change sdb6 filesystem in fstab! Now it is changed!
    sudo update-grub gives “command not found”.
    I have to go to bed now. Its very late here up north!
    I will continue tomorrow. I do not give up.
    Thank you very much for your support so far!!

  • your fstab should look something like this


Posts 43Views 11111
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.