• english keyboard locale on boot when i'm tryin to decrypt the system


    I just installed my first real antergos installation.

    I did partitioning setup by hand everything btrfs and encryptet. After installation on first boot i get promptet to enter my password for encryption which is good. But i cannot enter it since the keyboard layout seems to be english and i have characters not even available there.

    So ist there a possibility to load my keyboard locale before the encryption promt - that would be perfect.

  • @fjsdiolk

    You should add the keymap hook to your /etc/mkinitcpio.conf
    https://wiki.archlinux.org/index.php/Mkinitcpio

    Oh, and remember to check that the value in /etc/vconsole.conf is correct!

  • Sorry for intrusion. Seems like Antergos includes keyboard and keymap hooks by default. So there should be no need to add them.

    I’d try to exclude them from autodetect hook range of action instead. By placing them both before it. Like this:

    HOOKS="base udev keyboard keymap autodetect modconf block resume filesystems fsck"
    

    Excluding keyboard from autodetect usually solves mystical issues with various keyboards and their configs in Arch.

    Obviously, as @karasu suggests, check that /etc/vconsole.conf is correct. It should be set to uk for the English (UK) keyboard. Keymap hook uses it.

    Excluding keyboard and keymap from autodetect will make initramfs some bytes bigger. But the chances are that the keyboard will work as expected.

    After modifying the hooks list, remember to regenerate initrams with

    sudo mkinitcpio -p linux
    

    Good luck.

  • thank you very much for your answers.

    I’m almost fealing a bit bad i couldnt wait and just reinstalled with a password that only includes us available charaters…

    but just to note. - if your in that situation you cannot lookup or change anything. since you cannot boot at all - you would have to boot a life system mount your encryptet volumes and then try to change things… i guess…

    and something in adition i’ve learned. ( i think) - it is grub which has that problem and as far as my very limited understanding goes. - grub does not lie on / or /boot because thats all encryptet so you would not be able to run it at startup… - i actually have no clue why it’s working at all - is grub writing itself in the mbr??

    anyway - thank you…

  • @fjsdiolk said:

    …but just to note. - if your in that situation you cannot lookup or change anything. since you cannot boot at all…

    If the computer doesn’t boot at all, then it might be a problem. Which is easily cured by installing and using Grub Legacy (Grub 1). But it requires an external boot media (LiveCD, LiveDVD, LiveUSB) that boots with Grub 1 (Grub Legacy).

    Linux doesn’t require any graphical interface. Works perfectly without it. The very simple question is: “Do you see Grub’s menu when the computer is powered on?”.

    If Yes, then it will work. We’ll adjust keyboard settings as needed.

    If No, then we’re in trouble. Grub 1 (better) or Grub 2 (worse) is needed to boot a computer. Once booted, we’ll adjust everything from bash. It’s very easy. Don’t be scared. Will follow this thread.

locale6 keyboard layout5 luks14 encryption11 boot176 Posts 5Views 1002
Log in to reply