• Dual Boot Windows 10 and Antergos - Grub problem


    Hi,

    I have a small question here. I want to install Windows 10 and Antergos on a notebook. Previously I had Win7 and Ubuntu with Grub. I wanted to change Ubuntu to Antergos and I wiped the Ubuntu partition and did realize too late that I killed Grub with it. So I decided to make a fresh start and set up everything new. I now try to have Win10 and Antergos.

    I already installed Win10 on a partition and can boot into it. My partition layout looks like this:
    \dev\sda1 ntfs SYSTEM /boot/efi 300MB boot
    \dev\sda2 ntfs Windows10 156GB
    \dev\sda3 extended
    —\dev\sda7 ext4 Antergos / 78GB
    —\dev\sda6 swap 4GB
    —\dev\sda5 fat32 HP_TOOLS 2GB

    (HP_TOOLS is necessary for some diagnostic bios functions)
    Now I tried to run the Antergos Installation. But I can’t get the Installer to recognize my \boot\efi. As I already found out is that grub needs a fat32 boot partition to even be installed so I asked myself how could I create a sane boot partition that works. I also found out that SYSTEM must be the right boot partition that also windows uses because I had to disable fastboot to even mount sda1.

    So my question in the end of the day is: How do I make a working SYSTEM partition without loosing the bootfiles in it(as this sounds really bad, maybe I’m completely wrong) and will the Antergos Installer then have the option to install grub like in this tutorial(http://itsfoss.com/dual-boot-antergos-windows-uefi/)?

    Greetings SkryptX

  • why cant you just create a separate /boot/efi for antergos to use and let windows 10 use its own?

  • @SkryptX said:

    So my question in the end of the day is: How do I make a working SYSTEM partition without loosing the bootfiles in it

    Hi, you need to choose the Advanced Install Mode (where you will configure the partitions manually). You should set your existing EFI partition to be mounted as /boot/efi but DO NOT format it (don’t select the format checkbox). Then configure your mount point for root (/) and swap. Choose Grub as the bootloader and ensure it is installed to the same drive that holds your EFI partition.

    Let us know if you have any trouble with it. Cheers!

  • @Lizzi Is this even considered a solution? I have read so many times that you shouldn’t have more than one boot partition on the same harddrive… :/

    @lots.0.logs said:

    Hi, you need to choose the Advanced Install Mode (where you will configure the partitions manually). You should set your existing EFI partition to be mounted as /boot/efi but DO NOT format it (don’t select the format checkbox). Then configure your mount point for root (/) and swap. Choose Grub as the bootloader and ensure it is installed to the same drive that holds your EFI partition.

    This is exactely my problem. I did it like you said and also like it’s shown in the tutoriallink. But even if I select /boot/efi on SYSTEM It doesn’t show up as green box below and therefore can’t select Grub or something. The root / and the swap show up but /boot/efi does not show up. My assumption is that it’s either that SYSTEM is corrupted somehow or it shouldn’t be NTFS.

  • Are you certain that you have UEFI boot? The EFI partition cannot be anything other than FAT. The partition labeled System is not an EFI partition.

  • I’m not sure about anything. And as far as I can tell the SYSTEM didn’t change before and after the reinstalling. And I already had a working Grub. It could be that I accidentaly deleted the existing EFI partition from the last Grub.

    So what could be SYSTEM then if it’s not an EFI partition? And how did it get the bootflag and gets used by windows. But I suppose it really isn’t because the NTFS doesn’t make sense at all. :/

    How could I check if I have UEFI or not? And as I probably don’t have it, how can I change that? And it wouldn’t matter if I had to reinstall Windows again.

    I probably made a really big mess :S Next time I ask before I do something like that >.<

  • When you get to the Advanced Install screen, do you see a red block for /boot/efi, or does it just say /boot, or neither of those?

  • It does not show neither of those two. Only root is there by default and if I select swap swap appears too. Neither /boot nor /boot/efi appears by default. But if I remember correctly when I select /boot for SYSTEM the green boot-box also appears.

Posts 8Views 3715
Log in to reply