• upgrade- issue /office-issue.


    Hi,

    as i upgraded, Antergos do not upgrade libreoffice-fresh-de 5.0.2-1
    conflict: all files to upgrade exists in filesystem
    (I upgraded libreoffice-fresh 5.0.2-1 to 5.0.2-2 before.)
    Maybe i already have fresh-de 5.0.2-1 and pacman says: oh yes upgrade it to 5.0.2-1 !

    This is not so hard anyway.
    But if i start libreoffice i get only frozen startimage.
    Remove and reinstall libreoffice don’t work, cause:
    As i looked into pamac-manager, packet-source “antergos” and “extra” do not load,
    only “core” “community” and “local” are loading.

    I did pacman -Syy, nothing change.

    Something’s going wrong. I run antergos plasma 5

    edit:
    I installed octopi, removed libreoffice-fresh and pacman-manager/pamac 's working again.
    Install libreoffice-still for testing/whats happen: office/still don’t load, too (frozen start-image)
    strange.

  • update: with pacman is allright so far,
    but Libre office (fresh) 5.0.2-2 is broken,
    no one use it?

  • i am using libreoffice 5.0.2-2 but its the main one. all the other languages are 5.0.2-1. i dont see a de 5.0.2-2 in the repo. Anywat have you tried to run libreoffice from the terminal and copy the output to pastebin and post it here?

    which libre office program are you trying to use? the writer? type lowriter in a terminal and report what happens then…

  • When I enter:
    lowriter
    the system returns:
    javaldx: Could not find a Java Runtime Environment! Warning: failed to read path from javaldx

    Whereas the path to javaldx is:
    ./usr/lib/libreoffice/program/javaldx

    And LO *seems * to work fine, though I don’t know what action within LO would test the runtime environment (does this comment flagrantly display my ignorance )

    A little bug?

    death takes no vacations, makes no innovations nor exceptions

  • You just need to install java

  • yaourt -S jre7

    that should take care of that…

  • or if you prefer

    yaourt -S jre8-openjdk

  • OMG,
    sorry to bother you with such a low-grade piece of noobology …
    thanks for deigning to bend so low to help …

    embarrassed, but not daunted…
    TT

    edit: when i looked for the package using pacman or packer it didn’t show up, so I assume it is from AUR, right?
    But when I tried trizen -S jre7, it was silent
    yaourt -S jre7
    returned, in fire-alert-RED!
    ( Unsupported package: Potentially dangerous ! )

    At which I aborted.
    Is there some issue with runtime?
    Do the linux purists like to have a radioactive glove on when they touch it?

    EDIT:
    Then I tried:
    yaourt -S jre8-openjdk
    and it is piping down the tube as we speak, with a reassuring “woosh”

    tx again …

    death takes no vacations, makes no innovations nor exceptions

  • @tex its ok… Im glad to help wherever i can

    theres plenty i dont know

  • hi Lizzi,

    jre8-openjdk + Libreoffice-still 4.4.5-4

    lowriter/terminal ->

    terminate called after throwing an instance of ‘com::sun::star::uno::RuntimeException’

  • try

    yaourt -S jre7-openjdk

  • everything from AUR comes with that warning. Its pretty standard…

  • hm,

    jre7-openjdk is in extra, not in aur?!

  • thats ok. it just means it wont need to be built from scratch

  • just uninstall jre8-openjdk also first

  • ok, but jre7 gives no better result. libre dont load. same output in terminal.

  • you have installed liber office 4.4 from repo? did you uninstall libre office 5 first?

  • lets do this slow from the beginning. uninstall all libre office and all java then pick one of each to install after you reboot

    always remember to reboot after installing and/o removing software that is troublesome

  • hi lizzi,

    sure i uninstall all.
    Depence what you do with your system you have to reboot, of cause.
    I think the problem is lying somewhere else.
    good night : )

  • Same problem here. Changed GTK+ theme from Numix to default (Adwaita) and LibreOffice is working again

Posts 25Views 2349
Log in to reply