• Antergos Openbox Setup


    Ok So I have the MATE DE version of Antergos but wanted to ditch it and use Openbox. So I install Openbox and various programs with it like oblogout, menu, etc. Install Antergos-openbox-setup and run in terminal to install to my user. Boot into Openbox and Applications doesnt show anything. Only gives me error of --> invalid output from pipe menu /usr/bin/openbox-menu lxde-applications.menu and when I try to use an application that needs authentication, it doesnt even ask for password just automatically says AUTHENTICATION failed; I did have lxsession installed for pamac… Can anyone help? I’ve tried searching to find an answer, no help from IRC at all. I am sure it is a simple fix or adjustment that can be made.

    Also, tintwizard.py failes to execute when I try to run Tint Wizard. Says no such files or directory.

  • Last I checked the install.sh file for the openbox setup is made for the installation. You would have to move everything manually from the repo to obtain the same look.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Everything LOOKED the same as if it were out of the box from installation. The issue is the configuration files somewhere along the line does not allow Openbox to show APPLICATIONS or receive the appropriate authentication to install files from package manager or whatever other application may need authentication.

  • https://drive.google.com/open?id=0B0G59dAu-O3BQ1FxZ0ItZGRuc2s

    see if that helps? it’s my config directory saved to drive

  • Try changing your /.config/openbox/menu.xml to

    <?xml version="1.0" encoding="UTF-8"?>
    
    <openbox_menu xmlns="http://openbox.org/3.4/menu">
    <menu id="root-menu" label="Openbox 3" execute="obmenu-generator">
      <separator label="System" />
     <separator />
      <item label="Log Out">
    <action name="Exit">
      <prompt>yes</prompt>
    </action>
      </item>
    </menu>
    </openbox_menu>

    Cheers! I don't know what I'm talking about!

  • Am about to try both workarounds and get back to you within the hour. Thanks

    UPDATE: @Fedorai-Zomakaja No Luck. Failed to execute command for pipe menu “obmenu-generator” Failed to execute child process “obmenu-generator” (No Such file or directory) LOL I didnt have it installed…SOOOOOO going to generate a menu and then try it LOL @Lizzi I havent moved your config folder yet but I will try after I actually install obmenu-generator lol

  • after you do you’ll need to go into the ~/.config/openbox/pipemenus and set the two files there to run as executables. right click --> properties --> permissions --> check box for allow this file to run as a program. also you’ll need to reboot.

  • @Fedorai-Zomakaja WORKED LIKE A CHARM. Now I have another question. How can I edit the menu? I try to click obmenu-generator --> Menu Config but then it says Failed to execute child process “geany” (No such file or directory)…How can I change that to use Pluma because I dont want to use geany…also how can I change the terminal to use Mate Terminal instead of xterm…?? && Would you happen to know how to setup the snap windows ?

    UPDATE: Have to edit schema.pl and config.pl under .config -> obmenu-generator

  • obmenu is a gui menu editor i believe

  • I understand I can configure it but it wont let me use Pluma or another program. It keeps trying to open Geany so how exactly do I configure it…go to menu xml file again ?

    UPDATE: No I have to edit the obmenu-generator config somewhere else. the Regular menu xml under config openbox just lists exactly what @Fedorai-Zomakaja had posted

  • my menu looks nothing like that they had posted

  • use the file manager and go to the directory, right click on the file choose properties and then opens with and select the program you want.

  • That’s because obmenu-generator creates the menu and the menu XML file is pointed to the location of the obmenu generated menu . Instead of having the menu XML filled up with stuff. :-) I’m going to do more when I get home but with obmenu-generator it does take care of the authentication issue as well with pamac even though I mostly use terminal, I HATE having any part of my OS not working :)

  • I guess im not really understanding your issue with obmenu. Best wishes to you. I installed openbox from the onset and im not having these issues is all i can say.

  • @subst1tut3 To set up snapping windows:

    • Open /.config/openbox/rc.xml
    • before the </keyboard> tag paste the following

    Text to paste

    Note, you must use the keyboard shortcuts to snap the windows. Dragging wont work.

    Cheers! I don't know what I'm talking about!

  • @Fedorai-Zomakaja THANK YOU :)

    @Lizzi It wasnt directly with obmenu. My issue was with obmenu-generator, I figured it out though, thanks anyway

  • @subst1tut3 You’re welcome. I went through the same thing a couple weeks ago.

    Make sure to mark your post as solved if you didnt already

    Cheers! I don't know what I'm talking about!

Posts 17Views 4121
Log in to reply