• Wretched NVIDIA everytime!


    So I know this topic is over done on every distro known to man, but this is one hurdle I never seem to be able to make when it comes to anything Arch.

    First off I should say I am doing all of this through Virt Manager as a virtual machine, with Ubuntu Gnome as the host in case that makes a difference
    I have a GTX 660 so from what I am understanding I need to install nvidia, nvidia-utils, and nvidia-libgl (as well as 32libgl but I have been skipping that for sake of just getting it going)

    Here are the steps I have taken

    sudo pacman -S nvidia
    sudo pacman -S nvidia-utils
    sudo pacman -S nvidia-libgl (I get conflict issue and tell it to replace mesa-libgl)
    sudo nvidia-xconfig

    everything seems to install fine and run ok. I reboot and get the dreaded black screen with blinking cursor
    I can’t seem to find clear instructions as to what I am missing, and most of the posts are discussing older or laptop cards that I’m not using

    Am I missing an important step that I’m not seeing in the wiki? Is this because I am running it through a virtual machine?

    I tried Arch a while back and loved it, until I wanted to use NVIDIA drivers and I could never get it to work. When I heard about Antergos I was giddy at the idea of a nice clean Arch distro! Please help and thank you!

  • @tonytheleg said:

    Am I missing an important step that I’m not seeing in the wiki? Is this because I am running it through a virtual machine?

    No. You are not experiencing this issue based soley on Antergos being run through a virtual machine. This is from my experience in having Nvidia installed with the required bumblebeed app based on a persistant system being run on the physical machine. I had exactly the same issue you are facing with black screen and blinking cursor post reboot. I looked far and wide throughout the net and was not able to resolve my issue in spite of my laptop having optimum build characteristics for installing and using Nvidia. Made a post here in this forum. Issue was never actually resolved post required reboot. Sorry, as I can’t really offer specific guidelines in assitance other than to answer your question on whether your issue is due to Nvidia being on virtual machine or not (which I’ve already answered in support of statement made above).

    Download " antergos-wallpapers-extra " and enjoy community sponsored wallpapers.

    Use the "Linux Beginner Search Engine"

    https://cse.google.com/cse/home?cx=017607476515012185699:b_owgx6xyi0

  • I also had problems after installing nvidia libgl and found that arch wiki for nvidia drivers suggests to update cpu microcode
    It’s actually quite easy if you have only one distribution installed.
    https://wiki.archlinux.org/index.php/Microcode

    It helped for my primary distribution, yet i don’t know how to make grub configure the second one correctly. But, hey, at least you may have the first one working properly.

  • Based on your description, there should be no need to load Nvidia drivers. Your Antergos install is virtual correct? The video drivers will therefore be used for the virtual video adapter, not your physical video adapter in your machine. Antergos will never see your physical video card unless you are doing hardware pass-through and have multiple video cards.

  • Sorry for the delay, I didn’t see an email showing I had responses and forgot to check back.

    In reference to the microcode set up, both of the computers I am trying to do this on are AMD machines, and according to the wiki is part of the base system so it should already be set.

    I’ve tried tackling this a few different ways, but the issue seems to always occur after installing nvidia-libgl and replacing mesa

    bmeister, the only reason I am doing this through virtual is because I wanted to test it out and get the process set so that I can install it on physical hardware. Its just so much easier to clone and delete if things fail than to constantly keeping trying to undo and only dig myself deeper OR keep re-installing. I tried doing the same steps on the physical computer and get the same outcome as I did on the virtual machine on both a laptop and a desktop (the laptop was slightly different as I used the 340.xx version)

    The ultimate goal is two things: I would like an Arch Based desktop that I can install Steam on and play games, and I am also setting up a laptop for my wife to play Minecraft on, and Antergos looks and feels great. Its especially incredible on the laptop if I use xfce instead, and the AUR makes minecraft and mods installation so easy.

    I’ll keep trying but if anybody has suggestions I’m all ears. As much as I love Fedora, I do miss Arch sometimes.

    EDIT: I take that back, just tried again, installed nvidia then nvidia-libgl and rebooted and I could get in. The issue must be stemming from when i run nvidia-xconfig which makes sense because I’m not using nvidia drivers until then. Don’t know if that helps.

  • I believe when I installed the Nvidia drivers I used:
    sudo pacman -R nouveau-dri && sudo pacman -S nvidia nvidia-utils nvidia-libgl
    Since I removed nouveau I didn’t need the nvidia-xconfig. I do however use nvidia-xconfig on Debian systems.
    Something else to be aware of is when you install Antergos, you have the option to install Steam and Playonlinux. This will automatically enable the 32bit repositories which you will need for Steam. If you install steam this way then all you need to do is install the additional Nvidia 32bit libraries. Should look something like this:
    sudo pacman -R xf86-video-nouveau && sudo pacman -S nvidia nvidia-utils nvidia-libgl lib32-nvidia-libgl lib32-nvidia-utils
    You may get a file conflict warning about another 32bit library (cant remeber whic one it was) but select to use the new Nvidia files and overwrite the old file. When I install Antergos on a new machine, I always use nomodeset. Seems to make the installation of Nvidia drivers more reliable, at least for me. One other thing, Cinnamon desktop works well for gaming, I have had some issues in the past with Gnome and Playonlinux with fullscreen games.

Posts 6Views 1217
Log in to reply