• Like 0

    HP LaserJet 1018 not printing [Solved]


    Latest Antergos installation was a smooth as could be.
    Really a lovely distro! :)

    Dislike to talk about this ongoing issue (happened with previous Antergos and Manjaro ones too);

    HP Laserjet 1018 won’t print.
    Have everything configured in print settings that give it permissions.
    Why does this happen with Arch based distros and not Ubuntu ones is beyond me.

  • Like 0

    python-pyqt4 and python-gobject installed?

    ran sudo hp-setup -u?

  • Like 0

    HP printer is already installed by Antergos.
    Have tried to install the three similar looking hplip drives from suggested dropdown menu, which includes the HP manager. What else could there be to install?

  • Like 0

    python-pyqt4 and python-gobject are they installed?

  • Like 0

    yaourt -S python-pyqt4 python-gobject

    sudo hp-setup -u

  • Like 0

    Okay, going through re-installation right now.
    Did try your first code and got this:
    error: HPLIP is not installed properly or is installed without graphical support. Please reinstall HPLIP
    warning: Qt/PyQt 4 initialization failed.
    error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.
    Now tried yaourt-S etc. and it told me to >requires binary plug-in etc. run hp-plugin.

  • Like 0

    Lizzi,

    I don’t know what to say!!!
    After a second attempt, following your precious instructions, the printer is up and running!
    Wunderfull!!

    Thank you so much!!! I can’t believe it!! :+1:

  • Like 0

    Now, if only i can get French Multilingual keyboard in (as selected for installation)…

  • Like 0

    I’m glad to hear it worked. I keep having to look it up myself when i do a new install as its so infrequent i forget.

  • Like 0

    Also, did you add your user to the group lp?

    sudo useradd -g username groupname

    and then reboot?

  • Like 0

    Should i have tried that before going on with your previous tip?

  • Like 0

    @danielson no, just if you still have trouble with it.

  • Like 0

    its a hold over tip from my time when i used linux mint debian edition exclusively

  • Like 1

    For the record…

    Just re-installed Antergos and this time it required “pyqt5” instead of 4.

    yaourt -S python-pyqt5 python-gobject

    sudo hp-setup -u

printer18 hplaserjet2 Posts 14Views 1724
Log in to reply