• Backslash & Pipe Key missing on UK keyboard


    On my UK keyboard I have a backslash key which is between left shift and z on the keyboard however all the UK keyboard maps on gnome show an extended shift key which runs to the z key and therefore my key is missing. How can I get the correct keyboard mapping? I had no issues in Ubuntu so a bit confused. Can anybody help.

    Thanks

  • @Eamonn-Doyle If you’re missing the two characters in graphical applications, make sure that the English (UK) keyboard layout is added to Input Sources and is the first in the list in Gnome’s Regional & Language settings:

    antergos-gnome-region-&-languages-2.png

    If you’re missing the two characters in terminal applications, make sure that the virtual console is set correctly to uk value, like this:

    $ cat /etc/vconsole.conf
    KEYMAP=uk
    $ 
    

    It could be incorrectly set to gb, or some other value. Edit the file as root and set it to uk . The virtual console setting applies not to Gnome only, but to any other Antergos DE as well.

    I’m writing this using English (UK) keyboard, both backsplash \ and pipe | chars are correctly entered by the key found between the left shift and z keys, on the left of the keyboard.

uk keyboard2 Posts 2Views 765
Log in to reply