• Failure during install: remove_lvm() missing 1 required positional argument: 'device'


    Greetings,

    Cnchi 0.12.22 seems to be failing to install within Virutalbox. Default partitioning options were chosen during install.

    <see screenshot below>
    -g

    antergos.png

  • I am seeing the same error installing to an SSD drive using the whole drive as the default option. If I do the manual partitioning method to install then I don’t see this error but it fails later with another error “Can’t convert ‘bool’ object to str implicitly”. I have a second drive with all my data in an lvm partition. I hope it is not trying to remove that!

  • I have the same issue, not in Virutalbox though.
    remove_lvm().png

  • Not only within VirtualBox. I am seeing the same error installing to a HDD drive using Cnchi 0.12.22 and the whole drive as the default option.

    What’s so curious about this is, that it worked once without problems.
    I did one installation, but then decided to redo it, because I wanted it fresh without gui.

    Now I get the issue decribed above, having tried both, the live iso and the minimal iso.

    Antergos with an XFCE, Core2Duo CPU E8200 and 3GB RAM in a Lenovo A57 box from 2009, nVidia GeForce GT 710 1GB, SSD 120GB

  • This pull request fixes the issue.

    https://github.com/Antergos/Cnchi/pull/435/files

    You can manually patch the file yourself within the gui installer or wait for a new installer to be released.

    sudo vi /usr/share/cnchi/cnchi/installation/auto_partition.py

    -g

  • Thank you ☺

    Antergos with an XFCE, Core2Duo CPU E8200 and 3GB RAM in a Lenovo A57 box from 2009, nVidia GeForce GT 710 1GB, SSD 120GB

Posts 7Views 1545
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.