• SOLVED: Can't convert 'bool' object to str implicitly


    Trying to do a new install and I am getting this error:

    Can’t convert ‘bool’ object to str implicitly

    Using Cnchi 0.12.22 version

    ==> Generating module dependencies
    ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
    ==> Image generation successful
    2015-09-26 08:55:46 [DEBUG] install.py(1141) configure_system(): Running Cnchi post-install script
    2015-09-26 08:55:46 [ERROR] process.py(106) run(): Can’t convert ‘bool’ object to str implicitly
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): Traceback (most recent call last):
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/share/cnchi/cnchi/installation/process.py”, line 89, in run
    self.install_screen.run_install(pkg.packages, down.metalinks)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/share/cnchi/cnchi/installation/advanced.py”, line 2219, in run_install
    self.installation.start()
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/share/cnchi/cnchi/misc/misc.py”, line 175, in helper
    return func(*args, **kwargs)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/share/cnchi/cnchi/installation/install.py”, line 283, in start
    self.configure_system()
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/share/cnchi/cnchi/installation/install.py”, line 1154, in configure_system
    subprocess.check_call(cmd, timeout=300)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/lib/python3.4/subprocess.py”, line 556, in check_call
    retcode = call(*popenargs, **kwargs)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/lib/python3.4/subprocess.py”, line 537, in call
    with Popen(*popenargs, **kwargs) as p:
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/lib/python3.4/subprocess.py”, line 859, in init
    restore_signals, start_new_session)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): File “/usr/lib/python3.4/subprocess.py”, line 1395, in _execute_child
    restore_signals, start_new_session, preexec_fn)
    2015-09-26 08:55:46 [ERROR] process.py(110) run(): TypeError: Can’t convert ‘bool’ object to str implicitly

  • I can confirm this exact same issue, yesterday i made an installation in my laptop, cnchi updated itself to 0.12.15 an everything went fine, but today this morning when i wanted to install in my desktop (note that i use the same installation media which i wrote with dd and worked at first in my laptop) the installer updated itself to 0.12.22 and showed this error after downloading and installing the packages, right in “configuring system” or something like that.

  • Same issue here today with 0.12.22 . Installation aborted at the end while installing grub. I think cnchi is buggy…again. :disappointed: Due to a lack of time Manjaro now does the job.

  • Happened the same to me today… What should we do? wait for the next version of cnchi?

  • And my windows boot doesnt work know, it says “Missing operating system”, can’t repair it with my the linux install cd, it’s strange because Ubuntu doesnt give any problems.

  • Hey everyone,

    Just wanted to add that I too am experiencing this problem. I tried installing Antergos about 3 hours ago and got the same problem with Cnchi 0.12.22.

    I used the same live USB earlier this week on my laptop and it worked fine, so it’s not an issue with the image. I’m betting when I installed Antergos before it wasn’t on Cnchi 0.12.22.

    @AlejandroC90, Windows not booting is probably a Grub issue. I can’t remember if the Antergos live USB has an option to “boot from hard disk”. If so, try that and it should boot into Windows.

    Also, here’s a link to the issue posted on the Cnchi GitHub: https://github.com/Antergos/Cnchi/issues/436

  • Same here, but here’s a little workaround:

    @yellowsnow4free said:

    One option might be to install Antergos offline. That way Cnchi won’t update to 0.12.22. I want to say my live USB starts at 0.12.12.

    That won’t work, because cnchi checks for connections.

    With a little trick it will work:

    1. don’t beconnected to the internet
    2. Open cnchi 0.12.12
    3. connect to the internets with all of its beautiful cat pictures
    4. right after cnchi passed the check (power, memory and connection) unplug/disconnect.
    5. go on through the installation process, at some point a message will appear that you are indeed running the latest version of cnchi, despite running 0.12.12
    6. installation will get stuck after partitioning when cnchi tries to install your OS. at this point, exit cnchi (NOT your user session!)
    7. restart cnchi. it won’t check for updates again
    8. install && enjoy

    EDIT: I typed this while cnchi installed packages, but the installation process went through all the way using this little dirty trick.

  • Hi,

    Cnchi 0.12.24 should fix this.

    Thanks for reporting this!

  • Just a minor “hack” if anyone have the issues, before the repos update…

    git clone https://github.com/Antergos/Cnchi /tmp/cnchi
    /tmp/cnchi/run

    Thanks for the great work! :+1:

  • Temporary work around until next version of cnchi is released. I got it installed by downgrading the cnchi package to version 0.12.12. It is still in the pacman cache so you can downgrand and run cnchi again to do an install.

    cd /var/cache/pacman/pkg/

    pacman -U <file_name_of_the_package>

  • I found after trying to mount my lvm2 partition that the install deleted my lvm2 partition that was not even on the same disk that I installed to! Why would the installer do that? This is a major bug. Any idea how I can get my lvm2 partition back? I had backed up all my data to this partion before I started the Antergos install. Man, what a messed up distro this is.

  • @HJess @MikeMorrell

    sudo pacman -S git
    sudo rm -rf /usr/share/cnchi
    git clone https://github.com/Antergos/cnchi --depth=1
    cd cnchi
    ./run
    

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • This should be fixed in Cnchi 0.12.24 which I pushed into the main repo about an hour ago. Please let us know if that’s not the case. Thanks!

  • Tried installing Antergos last night and Cnchi 0.12.24 fixed the issue; thanks for the prompt fix everyone! :)

  • So I managed to recover my lost lvm partition. Yea. Got lucky there. Next time I will unplug my extra data drive before trying an install of a new distro. Live an learn.

  • @MikeMorrell

    I’m really sorry. The bug that affected you has been fixed. We did our tests either with only one drive or with more but without lvm on them.

    Our apologies.

  • @yellowsnow4free There’s something that I don’t understand, well let me try to explain myself.
    I installed Windows on my mSata SSD and then tried to install Antergos, I got a error meanwhile installing grub, I posted it here: http://forum.antergos.com/topic/2926/antergos-stuck-at-installation
    after this, windows boot was gone.
    so, I decided to try to install Ubuntu, Ubuntu installed normally (grub on mSata) and then, when I tried to boot, nothing was booting, and I lost the windows boot, So I thought, it has to be the mSata, can’t install grub there.
    I decided to retry the Antergos install and put the grub in the normal disk (not the mSata), that time, I had this problem (cant convert bool object to…) with seems to be solved.
    After this, my windows boot was totally gone, I don’t know why that happened (I was installing the grub in another disk!), and I couldn’t recover the windows boot, I had to reinstall totally, not even the fixmbr or fixboot commands in the windows installation ISO worked to me.

    And now, I had to install Ubuntu, and installed the grub on the normal disk (not the mSata), it works normally, I just have to switch the boot disk.
    mSata disk is first, so… It boots windows normally if I don’t select from what disk boot from
    If I’m going to use Ubuntu, simply change the boot priority to the normal disk, Ubuntu is installed on the mSata disk.
    I only have the grub on the normal disk.

    Why something like that would happen, even I’m installing the grub in the normal disk, the mSata boot of windows was gone.

    Thank you for reading, sorry if there’s grammatical mistakes, my English is not that good.

Posts 17Views 3877
Log in to reply