• \[SOLVED\]Conflict between bluez and bluez4


    [[email protected] ~]$ sudo pacman -Syu  
    [sudo] password for i-sty:   
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    multilib is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
    :: bluez and bluez4 are in conflict. Remove bluez4? [y/N] N  
    error: unresolvable package conflicts detected  
    error: failed to prepare transaction (conflicting dependencies)  
    :: bluez and bluez4 are in conflict  
    [[email protected] ~]$   
    
    

    I installed bluez4 and blueman yesterday, and I can’t upgrade my system now.

  • [[email protected] ~]$ sudo pacman -Syu  
    [sudo] password for i-sty:   
    :: Synchronizing package databases...  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    multilib is up to date  
    :: Starting full system upgrade...  
    resolving dependencies...  
    looking for inter-conflicts...  
    :: bluez and bluez4 are in conflict. Remove bluez4? [y/N] N  
    error: unresolvable package conflicts detected  
    error: failed to prepare transaction (conflicting dependencies)  
    :: bluez and bluez4 are in conflict  
    [[email protected] ~]$   
    
    

    I installed bluez4 and blueman yesterday, and I can’t upgrade my system now.

  • Supposedly, bluez4 is deprecated, its description is: “[b:12hu97h6]Deprecated[/b:12hu97h6] daemon and tools for the Bluetooth protocol stack”. But maybe, some package you have installed have it explicitly as a dependency and that’s the reason for the conflict?

    Also, maybe is worth trying to remove bluez4 and installing bluez…

  • Thank you your reply

    Please see the lasts reply in this topic: [http://forum.antergos.com/viewtopic.php?f=6&t=1213][0]">viewtopic.php?f=6&t=1213
    I installed bluez4, because the bluetooth didn’t worked.

    What do I do now?

    [0]: <a href=

  • My fault, that post was at the bottom of the “list of threads I still haven’t read”

    Well, about your problem, In Arch’s wiki we have a note in the [Bluetooth[/url:3cydj8jy] entry:

    Note: As of 2013-11-02, blueman no longer depends on the older bluez4, it uses bluez (v5)

    And the last update of the blueman package is from two days ago.]0

  • No problem!
    Thank you, the useful reply.

    Yes, now it’s working.
    I can’t send files.

Posts 6Views 1100
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.