• Boot hangs


    hi,
    I tried to install antergos twice but always hangs on boot.
    I made a bootable pen with unetbootin and installed xfce and gnome version with graphical installer.
    usb boot is fine I can use the live system.
    when installer is ready, boot always hangs on here after grub:

    my notebook is an HP 6910p with Intel c2d and ati x2300 video card.

    thanks for any help.
    red

  • hi,
    I tried to install antergos twice but always hangs on boot.
    I made a bootable pen with unetbootin and installed xfce and gnome version with graphical installer.
    usb boot is fine I can use the live system.
    when installer is ready, boot always hangs on here after grub:

    my notebook is an HP 6910p with Intel c2d and ati x2300 video card.

    thanks for any help.
    red

  • Those messages are because your network card hasn’t been activated yet but I don’t think it is the cause. There are many things that go on simultaneously in the background during boot so the best way to figure out the cause would be by reviewing the journal. Add the number “1” to the end of your kernel command line in grub. This should bring you to the command line where you will be able to access the journal. The most recent boot’s journal won’t be of any use so use the following commands to grab the 2nd and 3rd to last boots’ journal:

    journalctl -b -1
    journalctl -b -2

    You won’t have an internet connection at this stage so if you could just look for any errors and post them here. It’s best to start at the end of the file and go backwards because there is a lot of output in the beginning that won’t be relevant.

    Regards,

  • thanks for the quick reply.

    could you help me analize results?
    i.imgur.com/6tvurQM.jpg
    i.imgur.com/VPqVvlq.jpg

  • a tried a new install with cli installer and now it stops at " reached target graphical interface ".
    i read that thread and i tried with the latest installer (antergos-2013.10.26-x86_64.iso) but i can’t boot into live sytem with this.

    whats next?

  • hi [b:3so5c1vy]lots.0.logs[/b:3so5c1vy],

    i can boot into live installer (antergos-2013.10.26-x86_64.iso) with your instructions:

    When boot screen appears add “systemd.unit=multi-user.target” onto the boot options (just start typing and it will show up) You will be given two options, select option 1 by pressing enter. Now log in as root (there is no password). From there you can “rm /etc/X11/xorg.conf.d/20-intel.conf” and then “systemctl isolate graphical.target” You should now be looking at the gnome desktop!

    but when i start graphical installer i get this message:

    File “/usr/share/cnchi/src/pacman/pac.py”, line 116, in do_refresh
    db.update(force=False)
    alpm.error: unable to update database, pm_errno 0 (unexpected error)
    : do_refresh in /usr/share/cnchi/src/pacman/pac.py:111

    when i try

    su -c 'pacman -Sy'
    

    the antergos mirror related files are missing.

    any idea?

  • Sorry for just now getting back to you. I have not reviewed your journal yet but I will do that shortly. It seems either the mirror it is pulling from is out of sync or the database is corrupted. Here are a few steps to try. If you are successful with first one, no need to move to the next. I will update after I read your journal files.

    Obtain root via su command (there is no password)

    1. pacman -Syy
    2. rm -R /var/lib/pacman/sync && mkdir /var/lib/pacman/sync && pacman-Syy

    EDIT: nothing useful on those pics

    journalctl -b -0
    journalctl -b -1

  • ok, just one question, i would like to understand what im doing.

    when i boot in the live system and run ‘journalctl’ commands, you can read from these the reasons of unsuccessful boot?
    or i dont understand something.

  • @“redbiro”:1lyhog04 said:

    ok, just one question, i would like to understand what im doing.

    when i boot in the live system and run ‘journalctl’ commands, you can read from these the reasons of unsuccessful boot?
    or i dont understand something.

    The journal is the system’s log. It will contain any errors that may be causing the problem you are having. The journalctl command will be your best friend

  • do i have to make a clean install and then boot into live system?
    or just boot into live?

    because i had to use my notebook and installed xubuntu last night.

    sorry for the noob questions.

  • It seems we are having problems with our mirrors because there have been multiple reports of the antergos.db errors over the past 48 hours. It’s probably best to wait until we get it sorted so you don’t waste any time. However, if you get bored what you need to do is boot into the live cd like you did previously and then remove all the database files with the commands I posted yesterday. Then finally try to install again

    Regards,

  • installed the 08.20 version again, everything was ok.
    first boot has failed as usual (first post).
    started live session.
    tried to run journalctl commands.

      
    [[email protected] antergos]\# journalctl -b -0  
    journalctl: invalid option -- '0'  
    [[email protected] antergos]\# journalctl -b -1  
    journalctl: invalid option -- '1'  
    
    
  • i tried to install 11.03 iso.
    install is ok but doesn’t boot as the 08.20 version.
    should I give up?

  • and finally this is my

    journalctl -b -0
    

    log

    [url:f84g4s2l]http://pastebin.com/raw.php?i=uUEJGmaz[/url:f84g4s2l]

  • journalctl -b -1
    doesn’t work in live session.
    when im booting from hdd i can take a photo of the >journalctl -b -0
    ’s end.

    [img:mvmosauv]http://i.imgur.com/iqCscSfl.jpg[/img:mvmosauv]

  • Its good that you did get the system installed because that means it isn’t deleting your logs after every boot anymore. So here is what you do. First boot normally and let it hang. Then reboot but this time press “e” when grub comes up and add the number “3” to the end of the kernel command line (should be after the word “quiet”). That will bring you to the command line where you will need to log in and then grab the last few journals. You can save them to a file using > symbol…

    journalctl -b -1 > ~/journal.last
    journalctl -b -2 > ~/journal.2last
    journalctl -b -3 > ~/journal.3last

    I suspect this issue is related to your graphics card but I cannot be sure until I see those. I tell you what, go ahead and grab /var/log/Xorg.0.log & Xorg.0.log.old as well. Better to minimize the back and forth so we can get you up and running again right?

    Regards,

  • Okay, your journal and X logs confirm its a problem with your graphics hardware. Use the same steps from my previous post (about journals) and get to the command line. Create a xorg conf file like this: “sudo nano /etc/X11/xorg.conf.d/20-ati.conf” and input this text:

    Section "Module"  
    Disable "glx"  
    EndSection
    

    Use “ctrl+O” to save and then “ctrl+X” to exit. Now try to switch over to normal mode by running “sudo systemctl isolate graphical.target”

    The file you created will disable hardware acceleration meaning you won’t see desktop effects such as transparency and shadowing. Users have been reporting that the open source ATI driver has not been up to par lately when compared to the catalyst driver made by ATI. It might be a good idea for you to switch to using the catalyst driver to see if you have the same problems or not. You can get more information on it here: [https://wiki.archlinux.org/index.php/AMD_Catalyst][0]">[https://wiki.archlinux.org/index.php/AMD_Catalyst][1]

    Please let me know if you were at least able to boot successfully!

    Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/AMD_Catalyst

  • hi,
    i’ve made the ati.conf file but no luck.
    boot hangs as always.

    new journals, after the ati.conf file:
    [url:10nvjg4r]http://pastebin.com/raw.php?i=h93LBENn[/url:10nvjg4r]
    [url:10nvjg4r]http://pastebin.com/raw.php?i=8ZmViJG0[/url:10nvjg4r]

    thanks,
    red

  • Perhaps you could try installing the git mesa drivers from this repo:

      
    [mesa-git]  
    \# mesa git builds for testing and multilib-testing   
    Server = http://pkgbuild.com/~lcarlier/$repo/$arch  
    
    

    @“lots.0.logs”:2tyg1ciw said:

    Users have been reporting that the open source ATI driver has not been up to par lately when compared to the catalyst driver made by ATI. It might be a good idea for you to switch to using the catalyst driver to see if you have the same problems or not. You can get more information on it here: [https://wiki.archlinux.org/index.php/AMD_Catalyst][0]">[https://wiki.archlinux.org/index.php/AMD_Catalyst][1][/quote:2tyg1ciw]

    This is very weird as I’ve had the exact opposite experience, the performance with the mesa drivers keeps going up every few months. Keep in mind he’s using a legacy card x2300. The drivers for legacy cards (like mine) are the old 12.6 that haven’t had any meaningful updates, just some tweaks and version bumps. Not to mention he’d have to downgrade Xorg to 12.4 as well. Still worth a shot even if the git drivers don’t work.

    His Xorg.0.log says that no modules exist? What the heck?

      
    > [ 13.041] (II) LoadModule: "ati"  
    > [ 13.054] (WW) Warning, couldn't open module ati  
    > [ 13.054] (II) UnloadModule: "ati"  
    > [ 13.054] (II) Unloading ati  
    > [ 13.054] (EE) Failed to load module "ati" (module does not exist, 0)  
    > [ 13.054] (II) LoadModule: "vesa"  
    > [ 13.054] (WW) Warning, couldn't open module vesa  
    > [ 13.054] (II) UnloadModule: "vesa"  
    > [ 13.054] (II) Unloading vesa  
    > [ 13.054] (EE) Failed to load module "vesa" (module does not exist, 0)  
    > [ 13.054] (II) LoadModule: "modesetting"  
    > [ 13.055] (WW) Warning, couldn't open module modesetting  
    > [ 13.055] (II) UnloadModule: "modesetting"  
    > [ 13.055] (II) Unloading modesetting  
    > [ 13.055] (EE) Failed to load module "modesetting" (module does not exist, 0)  
    > [ 13.055] (II) LoadModule: "fbdev"  
    > [ 13.055] (WW) Warning, couldn't open module fbdev  
    > [ 13.055] (II) UnloadModule: "fbdev"  
    > [ 13.055] (II) Unloading fbdev  
    > [ 13.055] (EE) Failed to load module "fbdev" (module does not exist, 0)  
    > [ 13.055] (EE) No drivers available.  
    > 
    

    : <a href=
    [1]: https://wiki.archlinux.org/index.php/AMD_Catalyst

Posts 25Views 3231
Log in to reply