• Booting stops after last updates (systemd)-computer completely irresponsive


    Hi there!
    As described in the topic title, after installing the last updates, it is impossiible to boot Antergos. Loading starts up giving me this
    starting version 224
    Antergos : recovering journal
    Antergos: clean 365847/48,90624 files, 6076571/19540824 blocks
    {1- kum.disabled by bios

    so far so good as it always showed this and then it stops to a blinking cursor. No other activity present. Even HD stops. The computer becomes totally irresponsive, I cannot even get to a tty1 screen, so I can only force shutdown it.
    I tried fallback to, but I got the same result.
    My last updates were these…
    core/lib/systemd 225-1 -> 226-1
    core systemd 225-1 -> 226-1
    core systemd-sysvconf at 225-1 -> 226-1
    FYI, on shutttng down after updating, I got a screenful of logs before shutting down. It never does so on shutitng down. Unfortunately, I did not see what they were
    *I got the same updates to another machine with no issues at all.
    Any ideas and help much appreciated!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Add the following to the kernel boot command after the word quiet (press e when grub appears):

    systemd.unit=multi-user.target
    

    Post any messages that are shown. If you get a login prompt you should try and grab the logs if you can.

  • I also have this issue. I haven’t dived into it too much, but i used the above command and the arch roll back machine to roll back a day or 2 and still suffer from the same issue. I really thought that rolling back a day would have fixed it. I will also be posting my logs in a couple hours once i get some time to start troubleshooting.

    It actually happened with the updates from last night (9/19) but by 9/20 @ 8AM eastern is when it broke.

  • @developers , not quite sureif I followed your instructions properly. I added the line you gave me and then I pressed F10 to boot. I was directed to a tty1 screen, logged in, gave my psw and when prompted, the comand reboot.
    It gave me an instant ....did not watch something, but it was too fast to catch or shot.
    Then, I was met with the same issue…
    Any more suggestions?
    @SirWeazel , I hope you get luckier than me in posting your own loggs.

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch Why did you reboot after logging in? After logging in you can access your journal log and well as xsession and lightdm log :confused:

  • After some troubleshooting i’m still at a loss and i’m not sure what i’m missing. After messing around i reverted and installed all recent updates. Rebooted and let the system fail to boot. Then performed a nongraphical reboot and collected my logs to a usb stick for upload.

    @anarch I hope your troubles are related and when figured out it will also help you. This is my only antergos system.

    Note: i am not using lightdm but using GDM and it looks like GDM doesn’t collect logs by defualt and i need to enable this. If the provide logs don’t work, i will enable it and also collect those. I might just do it and post those later.

    EDIT: i removed my attached logs.

  • OK. I got my problem fixed. Not sure the technical details, but it looks like gnome thought there were pending updates needing applied when there were not any (i have gnome software installed also). What i had to do:

    1. Follow lotsoflogs instructions to boot to a non graphical enviroment by adding systemd.unit=multi-user.target after quiet in grub
    2. This takes you to TT1 terminal. Log in with your info.
    3. I then started x witht he following command startx
    4. I then started gdm (i don’t know what you are using, so this might vary and you will have to change accordingly)
      systemctl start gdm.service
      and it prompted me for my user password before starting
    5. After typing password, everything started correctly.

    After logging into my gnome desktop, i noticed that my shutdown/restart dialog box had a check next to install pending updates. Unchecking this box allowed me to reboot successfully and with it checked would cause the boot problem to come back. Pacman and yaourt both reported my system was up to date. BUT gnome software reported 2 updates. I opened gnome software and there is a refresh button on the left. After a refresh the “install pending updates” message in my shutdown/restrart box disappeared.

    @anarch
    I hope your problem is the same as mine and this helps. Sorry if i hijacked your thread. I’m not sure what proper etiquette is but i felt like we have the same issue. If your not using gdm, you would start lightdm.service or whatever display manager you are using.

  • @SirWeazel said:
    . Sorry if i hijacked your thread.

    Be my guest! I feel completely hopeless myself:smile: I followed your directions…

    1. I addied systemd.unit=multi-user.target after quiet in grub.
    2. No luck with the startx command, so I went on to
    3. systemctl start lightdm.service
      and here I am back in Antergos again. BUT I did not see any checks in my shutdown/restart dialogue box, nor any pending updates in the gnome software (it reports me that updates are managed automatically). I cannot see any refresh button on its left, either.
      I tried rebooting and in the box I saw the msg “installing updates and shutdown” PLUS “there are more users connected-my username-console” (translated from greek). I let it shutdown automatically (60 secs) but on rebooting, the same issue…:sweat:

    @lots-0-logs , sorry to bother you, I tried systemctl default to enter into default mode and got this back
    Policy kit daemon disconnected from bus. We are no longer a registered authentication agent. Warning! D-bus connection terminated. Failed to wait for response
    Is this of any help? I viewed my log but it was tens of thousands of lines (did not even know how to exit the screen) :blush:
    I also attempted to export my system’s journal using these commands:
    su journalctl -b -0 > /tmp/journal journalctl -b -1 > /tmp/journal.last journalctl -b -2 > /tmp/journal.2last exit
    but what is the su password?
    Thanks for your patience in advance!!!

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    type su then hit enter. It will ask for your password. In laymens terms, your terminal is elevated and now root and has full access to everything. So be careful what you do. Then when finished using the commands you need you can type exit and it take you back to your normal user privileges in the terminal and typing exit a second time will close your terminal session. But at least you are able to get to a graphical user interface which sounds like it might be easier for you to navigate. I’m confused about “updates are managed automatically” Not sure where or why you would be seeing that. And i had to install gnome software, my default install didn’t include it when i first set up my pc. So i need to be careful and only use one manager because i basically have 3 package managers (gnome software, pacman, or the gui version of pacman, yaourt).

    not sure, but instead of using su to elevate your privileges i think you could just type sudo and the command you want to run.

    Good luck, i’ll try and watch what you report back. I’m sure lotsoflogs is way more knowledgeable then myself and hopefully can help you out.

  • @SirWeazel , to tell you the truth, I strongly suspect gnome-software! I haven t installed it in my other machine which works flawlessly!! I don t remember it having behaved like this before. It used to have a button to check for updates. Now it is gone! You can also check for updates from the SystemSettings > System > Details. That is where I tried to check for updates and told you I was reported that updates are managed automatically! I don t remember this behavour before.
    Anyway, I uninstalled gnome-software to see what will happen. Now, from the System Settings, I don t get the message of automatically managed updates, but it looks for updates. Nevertheless, this didn t fix anything. I ii keep monitoring and searching.
    Thanks for the advice and instructions. I ii look into them lateron, when I find myself some time.
    ***Another wonder (and maybe a suspect?). My other machine starts with version 225. This one starts with version 224…

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • @anarch
    Mine is currently starting with 224. Maybe some mirrors are still updating?
    Gnome software also showed an app called gnome updater, but i don’t have this installed. I also attached a screenshot of my gnome software. In the top left corner of the screenshot is the button to refresh. I also included a screenshot of my shutdown dialoge box. Before when i was having the boot issue there was a box there that said apply pending updates.

    Attached screenshots below
    gnomesoftandshutdown.tar

  • Uninstalling gnome-software seems to have resolved the issue. Antergos is booting & working flawlessly as it always has. Thanks for your precious help.
    *I`m checking it as “solved”. :thumbsup:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • gnome strikes again
    :grin:

  • Don`t be naughty! Pacman, pamac, gnome updater, all of them running in one system…the fault is mine!:smile:
    If I had to blame Gnome for something, is why its updater turned into auto-updater. But still, maybe I gave permission to that, had I been careless :punch: or something …:innocent:

    1.Antergos Linux KDE plasma / Gnome 2.Ubuntu 17.10 64bit Unity
    Intel Core2 Duo CPU P8400 2.26GHz‖ RAM 3908 MiB ‖ Dell Inc. 0F328M - Dell Inc. Latitude E6500
    Intel Mobile 4 Series Chipset Integrated Graphics [8086:2a42] {i915

  • Glad you got it fixed. I did see a way to enable auto updates by editing a file or using dconf. I couldn’t find a gui option, but depending on how old your system is maybe it was a setting that carried over from somewhere.

Posts 15Views 4341
Log in to reply