• cnchi and gummiboot/systemd-boot (how do i run cnchi-dev 0.13.x?)


    so, as of issue 402 it seems like cnchi and gummiboot/systemd-boot should work together once again. however, in the 0913 install iso live environment i have cnchi 0.12 and can’t for the life of me figure out how to run the latest dev version 0.13.x.

    /usr/bin/cnchi-dev fails with a package conflict between cnchi and cnchi-dev when invoked alone, and displays version 0.9 when invoked with ‘cnchi-dev development’, which i saw elsewhere in these forums. manually removing and reinstalling cnchi-dev from the repos leaves me with the same cnchi-dev 0.9 and cnchi 0.12. i don’t see any development branches in the git repository either, and the version on master is still 0.12. any ideas? i can post logs if you need them.

  • …the. hours. …I have. spent. trying to figure this out…

    so. frustrating.

    haha i swear I’ve tried every possible way known to man to get cnchi-dev to run on the live iso’s. only logical deduction I’ve come down to is that the Antergos team must be practicing wicked sorcery or some form of the “dark-arts” in & around their repo.
    tumblr_leuwnhw7ei1qg39ewo1_500.gif

  • so i take this to mean that you couldn’t find any way at all to access cnchi-dev? the version number in the repositories is even 0.13.40…

  • Hi,

    Have you tried, from the livecd:

    sudo pacman -R cnchi
    sudo pacman -S cnchi-dev
    
  • yes I’ve definitely tried my best at removing cnchi (as well as all it’s remains), I most often use:

    sudo pacman -Rcns cnchi

    ps. how do you use the “code” formatting here? i know w/ BBcode its [code][/code]

    and then when trying to activate cnchi-dev… it just redownloads regular cnchi again

  • @QuantumQweef

    You have to use three backticks (I now, it’s a bit strange… but it’s how markdown works).

    You have a cheat sheet here : https://github.com/adam-p/markdown-here/wiki/Markdown-Cheatsheet

    About your problem:
    LiveCD starts with Cnchi 0.12.1
    When you activate net connection (icon in the topright) then Cnchi tries to update itself. I say tries because I must admit that sometimes it can’t, and stays 0.12.1 We’ve not been able to find out why is this happening, yet.

    Anyways, now it’s when you have to close cnchi and open a terminal and simply run:

    sudo pacman -Syy
    sudo pacman -R cnchi
    sudo pacman -S cnchi-dev --force
    sudo -E cnchi -dv
    

    Cnchi 0.13.55 (at the moment of writing this) should appear.

    Tell me if it doesn’t work for you.

    Cheers!

Posts 6Views 1293
Log in to reply