• Screen tearing after install (gnome desktop), but no tearing on live-cd


    Hi!

    This is giving me a serious headache, I’m having trouble with tearing in almost every distro i try, only one I can use without getting tearing is Linux Mint Cinnamon 17.1. Any distro with kde, xfce or gnome (works sometimes) i get tearing. Would love to run xfce but that’s just out of the question.

    Anyway, downloaded the latest antergos a few days ago and ran the live-cd, and it works without any tearing. But after installation, guess what, tearing.
    Also the font hinting was perfect on live-cd, but not after installation. But that part was easy to fix.
    Installed Antergos with Gnome desktop and LTS kernel.

    Any suggestions on what the problem could be? Should be able to fix this since the live-cd works great.

    // tbt

  • Hi,

    Hmm…I think in this case its the LTS kernel. There are no other differences between the live cd and what you get when you install GNOME. Try installing the default kernel to confirm.

    sudo pacman -S linux
    sudo grub-mkconfig -o /boot/grub/grub.cfg
    
  • If you computer has an Integrated Intel video it’s probably because you are running with Acceleration of sna, the default method.

    As root edit
    /etc/X11/xorg.conf.d/20-intel.conf
    and you should see:

    Section "Device"
    Identifier "Intel Graphics"
    Driver "intel"
    Option “AccelMethod” "sna"
    Option “TearFree” "true"
    EndSection

    Change the sna to uxa and see if that fixes it.

  • @herbie I make almost the same ,but a little more simple : if I have “mkdir /etc/X11/xorg.conf.d/” , I put " echo -e ‘Section “Device”\n Identifier “Intel Graphics”\n Driver “Intel”\n Option “AccelMethod” “sna”\n Option “TearFree” “true”\nEndSection’ | sudo tee /etc/X11/xorg.conf.d/20-intel.conf" and reboot .

  • Just a side note; You don’t have to reboot. Just logout and log back in.

Posts 5Views 1616
Log in to reply