• Gnome-shell starts eating up to 50% cpu


    I have noticed a while ago that after some time everything starts not working smoothly, for example, moving windows does not happen instantly, when i watch something in vlc it looks choppy, and so on. Then i discovered that for no apparent reason gnome-shell uses about 50% of my cpy, never more, but enough to make my whole system choppy, i have searched and did not find anyone having the same problem, and i have no reason what is causing it. This is a fresh install of antergos, installed 2 days ago, i was dual booting it with windows, then windows decided to die, and I now went and installed antergos on my main HDD. Also i have noticed that relogging fixes this problem for some time, but when i try to log out, it says that it will happen in 60 sec and gives me an option to log out now, which when i press the button just shuts down all of my programs, and waits for 60 sec. I dont know if this is related, just putting it there.
    My specs are:
    Processor: Intel Core 2 Duo
    RAM: 8GB
    Graphics: AMD Radeon R7 200 series (catalyst)

    Please help, i have no idea what to do, but i do not want to relog every time this starts happening, and i really like using gnome on antergos…
    Thanks in advance!!!

  • Hi,

    So its gnome-shell process that keeps at 50% ? Have you deactivated all gnome extensions? Also, could be a graphics driver related problem, but to tell you the truth, it’s just guessing without more info.

    When you experience the issue, grab the logs as explained here.


  • I currently have 3 extensions active (besides the ones that come with antergos) Drop down terminal, maximus 2, and Skype integration. I will attach log files as soon as the problem shows up again, it usually happens overnight. I did disable the extensions at one point, it still happened so i dont think they are the problem.

    Thankyou for your reply.

  • Greetings,

    After 2 days with no problem it popped up, i gathered all the logs and zipped them, but could not upload them because they are 8.1MB, so i have uploaded it on mega file upload : http://www.megafileupload.com/dxUi/logs.tar
    I hope you can find what the problem is, and why it is showing up

    Thanks in advance!

  • From @knightfall :

    Just by looking at your logs you can tell that “maximus two” extension really throws out lots of errors.

    It’s also a known problem reported at https://github.com/wilfm/GnomeExtensionMaximusTwo/issues/32 where some users talk about 20%, other 95%, and others 100% CPU usage,

    Apparently downgrading to version 2 solves the problem:

  • Many thanks karasu, i have decided to simply remove maximus two.
    I like how friendly you guys are, and how quick you answer, this is one of the reasons i went from manjaro to antergos, keep up the good work!

  • Greetings again,

    The problem still persists, i have removed maximus two from gnome extensions…
    I have once again made the logs.tar
    Link: http://www.megafileupload.com/lWlM/logs.tar
    Thanks in advance!

  • I guess it’s a graphics driver related issue. As far I can see, the only relevant error (apart from MotherBase generating lots of st_widget_get_theme_node errors) is AIGLX failing to load the proprietary Radeon driver:

    “(EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory]”

    You could try reinstalling the driver (https://wiki.archlinux.org/index.php/AMD_Catalyst#Installing_the_driver), or try adapting this solution for Ubuntu: http://askubuntu.com/questions/465243/how-to-use-fglrx-proprietary-driver-for-dual-ati-radeon-hd-5670-crossfirex-in-ub (I don’t have a Radeon card so I can’t help you here.)

  • I have solved the fglrx_dri.so problem with theese 2 lines

    mkdir -p /usr/X11R6/lib64/modules/dri

    ln -s /usr/lib/xorg/modules/dri/fglrx_dri.so /usr/X11R6/lib64/modules/dri/fglrx_dri.so

    from: https://wiki.archlinux.org/index.php/AMD_Catalyst#Troubleshooting
    Hopefully that solves the problem, the system has been working since this morning after i applied this (and rebooted) with no problems,

    Thanks for your, yet again fast responce, keep up the good work!

gnome-shell15 high cpy usage1 Posts 9Views 2740
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.