• \[SOLVED\] System (yet again) broken after update on netbook


    Not sure if this is the right place to post but here goes:

    I have an old intel classmate PC that I got for trading with a nokia N80 phone a long time ago. It has a 1.6GHz atom and 945GM (I think). I wanted arch on it because it’s bleeding edge and should, in theory, offer better performance. So the system runs quite [i:uhxdwj2s]really[/i:uhxdwj2s] well on this, plus using XFCE is a breeze - I can actually watch youtube videos at 480p perfectly fine - but I like to use gnome anway

    However sometimes after updating the system breaks - like right now…
    The system now hangs at “Reached target Graphical Interface”. I use sna acceleration, mesa-git, kernel-ck and a few more parameters in grub file, but to try and fix this I already went back to uxa, normal mesa and i’m using a clean grub file with normal kernel to no avail.

    There are also two messages that keep popping up:

      
    [ 218.395289] sd 2:0:0:0: [sdb] Asking for cache data failed  
    [ 269.595927] sd 2:0:0:0: [sdb] Assuming drive cache: write through  
    
    

    Any ideas what might have broken this yet again? This isn’t the first time and while everything works 100% on my desktop my netbook always suffers

    So besides this problem I also wanted to ask if anyone thinks I should install a different distro? I very much want to use wayland as fast as possible and going to something like for example puppy linux means I’ll probably be a year behind updates not to mention it’s ugly as sin lol

  • Not sure if this is the right place to post but here goes:

    I have an old intel classmate PC that I got for trading with a nokia N80 phone a long time ago. It has a 1.6GHz atom and 945GM (I think). I wanted arch on it because it’s bleeding edge and should, in theory, offer better performance. So the system runs quite [i:uhxdwj2s]really[/i:uhxdwj2s] well on this, plus using XFCE is a breeze - I can actually watch youtube videos at 480p perfectly fine - but I like to use gnome anway

    However sometimes after updating the system breaks - like right now…
    The system now hangs at “Reached target Graphical Interface”. I use sna acceleration, mesa-git, kernel-ck and a few more parameters in grub file, but to try and fix this I already went back to uxa, normal mesa and i’m using a clean grub file with normal kernel to no avail.

    There are also two messages that keep popping up:

      
    [ 218.395289] sd 2:0:0:0: [sdb] Asking for cache data failed  
    [ 269.595927] sd 2:0:0:0: [sdb] Assuming drive cache: write through  
    
    

    Any ideas what might have broken this yet again? This isn’t the first time and while everything works 100% on my desktop my netbook always suffers

    So besides this problem I also wanted to ask if anyone thinks I should install a different distro? I very much want to use wayland as fast as possible and going to something like for example puppy linux means I’ll probably be a year behind updates not to mention it’s ugly as sin lol

  • Hi there,

    The log messages are are common on drives connected via usb and can be ignored. There have been a lot of reports of boot problems lately that are related to GDM. Are you using GDM as your login manager? If so I’d advise to install either lightdm or lxdm. With a rolling release distro there is always a chance of breakage although I have found that it doesn’t happen very often. That goes for more mainstream systems which intel atom based is not

    To install lightdm:

    Boot with “systemd.unit=multi-user.target” added to kernel command line.
    pacman -S lightdm lightdm-gtk3-greeter
    systemctl disable gdm && systemctl enable lightdm
    systemctl isolate graphical.target

  • @“lots.0.logs”:251ywggr said:

    Hi there,

    The log messages are are common on drives connected via usb and can be ignored[/quote:251ywggr]

    But I have nothing connected through USB.

    Regarding the lightdm: It still fails to start. Sometimes it shows [FAILED] other times it Starts, Stops, Starts, Stops over and over again until it gives up.

      
    > systemctl status lightdm.service  
    >   
    > lightdm.service - Light Display Manager  
    > Loaded: loaded (/usr/lib/systemd/lightdm.service: enabled)  
    > Active: failed (Result: start-limit) since Qui 2013.10.31 14:41:57 WET; 5min ago  
    > Docs: man:lightdm(1)  
    > Process: 274 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)  
    > Main PID: 274 (code=exited, status=1/FAILURE)  
    > CGroup: /system.slice/lightdm.service  
    > 
    
  • After trying this on my system, I found that the dev version of lightdm is the one that is fully functional. Sorry I didn’t check first. The two packages are lightdm-devel and lightdm-gtk3-greeter-devel. Please keep me updated!

    Regards,

  • Can’t build lightdm-devel

      
    Checking wether the C compiler works... no  
    configure: error: in \`/tmp/yaourt-tmp-antonio/aur-lightdm-devel/src/lightdm-1.9.0' :  
    configure: error: C compiler cannot create executables  
    
    
  • You will need to ensure you have the base-devel group installed. It contains all the packages required for compiling other packages. You can install it with “pacman -S base-devel”

    Regards,

  • I do. It seems I can’t build anything, always same error. What the hell…

  • Something in your gcc package must be corrupted. Try this first: “pacman -Sf gcc”

  • I found out what it was. I had made some changes to makepkg.conf before like I did on my desktop following the arch wiki. Apparently it doesn’t like the changes or perhaps I mistyped something. lightdm is building now

    EDIT: Just installed lightdm devel and greeter devel, enabled them with “systemctl enable lightdm”… still doesn’t work

  • @“Vidar”:s6qe3fyb said:

    I found out what it was. I had made some changes to makepkg.conf before like I did on my desktop following the arch wiki. Apparently it doesn’t like the changes or perhaps I mistyped something. lightdm is building now

    EDIT: Just installed lightdm devel and greeter devel, enabled them with “systemctl enable lightdm”… still doesn’t work[/quote:s6qe3fyb]

    Did you edit /etc/lightdm/lightdm.conf to:
    [code:s6qe3fyb]greeter-session=your-greeter-here[/code:s6qe3fyb]

    the themes are stored in /usr/share/xgreeters so you can find the greeter name there.

    gmail: [email protected]
    irc: [email protected]

  • No need to edit - already set to lightdm-gtk-greeter

  • Make sure the name is correct, check the file name of the theme in /usr/share/xgreeters

    gmail: [email protected]
    irc: [email protected]

  • I just uploaded an Antergos theme for lightdm to the AUR. If you would like to use it the name is “lightdm-webkit-theme-antergos”

    As was mentioned you will need to update these two files:

    /etc/lightdm/lightdm.conf

      
    greeter-session=lightdm-webkit-greeter  
    user-session=your-session (gnome,cinnamon,xfce...)
    

    /etc/lightdm/lightdm-webkit-greeter.conf

    webkit-theme=antergos (or just "webkit" for default)
    

    Cheers!

  • I see you replied while I was typing the last one lol. If you coud grab what’s saved in /var/log/lightdm That would be helpful.

  • Lol. Awesome i’m going to try your greeter now.

    gmail: [email protected]
    irc: [email protected]

  • @“detrimental”:28p0erx0 said:

    Lol. Awesome i’m going to try your greeter now.[/quote:28p0erx0]
    Let me know what you think

  • @“lots.0.logs”:20zmz4ho said:

    @“detrimental”:20zmz4ho said:

    Lol. Awesome i’m going to try your greeter now.[/quote:20zmz4ho]
    Let me know what you think

    Very nice. Just got it installed and rebooted. I’m going to use it. Also did antergos start using a graphical boot?

    gmail: [email protected]
    irc: [email protected]

  • You mean like plymouth? No we decided against it because boot time in Arch has been improved to almost nothing. The boot graphic would go by so fast that if you blinked you would miss it

  • Well now I have a pretty greeter haha.

    I found the culprit - it was 20-intel.conf, the bastard!! I remember trying to change acceleration methods between uxa and sna to see the difference and when i changed it back to sna i forgot one quotation mark

      
    Option "AccelMethod" sna"  
    
    

    Like so. I found out that sna is enabled by default even on ancient hardware because I thought it was still using uxa, so I removed that .conf file and everything’s fine now.

    In my defense… the keyboard on this netbook is REALLY bad so…

Posts 23Views 4765
Log in to reply