• Yaourt: No space left on device


    My HDD: 107 GB — 49 GB free (54.3% full)
    Yaourt Output when I try to install something: http://hastebin.com/lutihaguna.coffee
    I try reading the wiki: https://wiki.archlinux.org/index.php/Yaourt#Yaourt_freezing_up_or_unable_to_continue_due_to_no_space_left_on_device
    But I didn’t see the “TMPDIR variable” to change it.

  • You need to change the folder the application is building in. Default is “/tmp” This folder is stored usually in ram or swap. You can change this directory to somewhere else, maybe /home/$USER/tmp or something and instead of using ram/swap use your harddrive. You can change it in yaourts config.

    /etc/yaourtrc
    
    #TMPDIR="/tmp"
    
    TMPDIR="/home/$USER/tmp"
    
  • @detrimental
    Thanks it worked.

  • @MathCubes Awesome, your welcome! Will you please mark your post [solved].

  • @detrimental How Do I do that? I don’t see a edit button.

  • @MathCubes bottom left of the original post under your avatar there is a sprocket thing usually associated with settings on computers, click that and edit is in there.

  • Am having the same issue , i tried to edit the file but i can seem to have it saved, it prompt saying i dont have permission, please help

  • @kellyhose201 Try running it with sudo.

    sudo YourTextEditorOfChoiceHere /etc/yaourtrc
    
  • @detrimental said in Yaourt: No space left on device:

    build

    You can also do it in PAMAN gui, that is where you search software and do the updates, and do this:

    • press the three bars next to search, to open preferences
    • preferences
    • AUR
    • build directory

    Now choose another directory other than the tmp. Choose Downloads or any other, that has loads of free space.

error311 yaourt31 Posts 9Views 20202
Locked
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.