• Computer will not lock


    I am somewhat new to the Linux scene and recently installed the GNOME version of Antergos (moving over from Ubuntu 15.04). Everything works fine, apart from the fact that the computer will not lock. Been looking around for a solution on the forums and somewhere is suggested to use ‘dm-tool lock’ in the terminal, but I am just given a blank, white screen with a cursor at really low resolution. I have exhausted my limited knowledge and now I am stuck.

    I will be highly grateful if this could be fixed!

    Edit: I removed ‘gnome-shell-extension-status-menu-buttons 0.2-1’ and installed ‘gnome-shell-extension-lockscreen-lightdm 1.0-4’ and now I can lock the computer, but I would still prefer to use the status menu if it can be fixed.

    Edit 2: Problem is now solved; I used the method here as well as a few other things:

    • ‘sudo pacman -Rcns lightdm’
    • ‘sudo pacman -S gdm’
    • ‘sudo systemctl -f enable gdm’
    • ‘sudo pacman -S light-locker’
    • ‘sudo pacman -S light-locker-settings’
    • restart computer
  • Well if you are willing to do a bit of work I have one solution.
    Install i3lock
    then
    create an
    .i3lock folder
    and put a ‘png’ image in there
    then
    rename it

    lock_screen.png

    then
    open(as root) with your text editor /usr/bin/xflock4
    and paste in this code

    i3lock -i /home/yourusername/.i3/lock_screen.png

    then
    go to Settings>keyboard>Application shortcuts
    and add
    xflock4
    I used the shortcut key as Super+L

    That’s it.
    When you want to go back to your desktop key in your user password.
    A circle will appear saying Verifying
    Hope this helps.

  • @herbie said:

    open(as root) with your text editor /usr/bin/xflock4

    Got up to this point, was displayed with an empty file. Checked if it actually exists - and it doesn’t.

    @herbie said:

    I used the shortcut key as Super+L

    Already has a lock shortcut with the same key combination, but nothing happens when triggered. Tried typing ‘xflock4’ in the terminal to see if will run and got the output ‘command not found’.

    Edit: Never mind, I just created a new file and it works. Would prefer to get the gnome extension working, but I will continue to use this until there is a fix. Thanks!

  • Glad to hear you got it working but that is really bizarre that xflock4 didn’t exist.
    So what ‘lock’ are you using? I’m curious, and no, my name isn’t George… lol

  • Meant to say, My ‘real’ name isn’t George. But I digress…

  • @herbie said:

    Glad to hear you got it working but that is really bizarre that xflock4 didn’t exist.
    So what ‘lock’ are you using? I’m curious, and no, my name isn’t George… lol

    Was using the ‘lightdm-webkit2-greeter’ as the lock, which also currently displays when booting up the system. When I was first trying the distro out on a virtual machine it had the same problem (screen turning completely white) , but I was able to press in the middle of the screen to get the greeter to appear.

Posts 6Views 1101
Log in to reply