• "Error: failed to commit transaction (conflicting files)"


    When updating my system I get this, Really new to pacman, so any help would be awesome. Everyone goes fine until the end and this happens.

    nvidia-libgl: /usr/lib/libEGL.so exists in filesystem
    nvidia-libgl: /usr/lib/libEGL.so.1 exists in filesystem
    nvidia-libgl: /usr/lib/libEGL.so.352.41 exists in filesystem
    nvidia-libgl: /usr/lib/libGL.so exists in filesystem
    nvidia-libgl: /usr/lib/libGL.so.1 exists in filesystem
    nvidia-libgl: /usr/lib/libGL.so.352.41 exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv1_CM.so exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv1_CM.so.1 exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv1_CM.so.352.41 exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv2.so exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv2.so.2 exists in filesystem
    nvidia-libgl: /usr/lib/libGLESv2.so.352.41 exists in filesystem
    nvidia-libgl: /usr/lib/xorg/modules/extensions/libglx.so exists in filesystem
    nvidia-libgl: /usr/lib/xorg/modules/extensions/libglx.so.1 exists in filesystem
    nvidia-libgl: /usr/lib/xorg/modules/extensions/libglx.so.352.41 exists in filesystem
    nvidia-libgl: /usr/share/licenses/nvidia-libgl exists in filesystem
    Errors occurred, no packages were upgraded.
    
  • How did you install the nvidia driver ? With pacman ?

    It’s complaining that there are already some files in your system that come with the nvidia-libgl package.

  • I downloaded nvidia through youart, was that not smart of me to do?

  • No, that’s ok. Just try --force:
    sudo pacman -S nvidia-libgl --force

    Cheers!

  • Don’t mean to necro this but I have a similar problem and the above solution didn’t work. Problem is the same even after solution was applied:

    error: failed to commit transaction (conflicting files)
    /usr/share/applications/ exists in both 'cmake' and 'firefox-beta'
    /usr/share/applications exists in both 'firefox-beta' and 'geoclue2'
    /usr/share/applications exists in both 'firefox-beta' and 'libreoffice-fresh'
    firefox-beta: /usr/share/applications exists in filesystem
    Errors occurred, no packages were upgraded.
    

    Thoughts?

  • Hi,

    Sorry nobody has answered this yet.

    It seems that firefox-beta has some conflicting files… try this out:

    sudo pacman -Rnsc firefox-beta
    sudo pacman -Syu
    

    At this point, your system should be up to date.

    Now try installing firefox-beta again (if you need it):

    yaourt -S firefox-beta
    

    It could be that firefox-beta package is out of date and that last command could fail, I haven’t tried it. If it does not work you can install the “stable” version:

    sudo pacman -S firefox
    

    Cheers!

  • Attempted above and the error remained. I switched to the stable version of firefox (forgot that was even there.) It kept all my addons, bookmarks, etc. so I will stick with the stable version. Thanks!

nvidia118 pacman87 Posts 7Views 8335
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.