• Disco duro /dev/sda3 no llega al login.


    Hola, acabo de reiniciar antergos y tomo en el grub Arch, cual lo tengo en sda3 y no llega al login
    fdisk.png
    IMG_20150912_114623.jpg
    IMG_20150912_114552.jpg
    Además intento entrar a una tty y al querer loguearme vuelve a la pantalla de las fotos…
    Bueno, ya me dirán
    Gracias como siempre !

  • @judd
    Has hecho algun cambio? Alguna actualización? Quitado/cambiado un disco o sus particiones?

    Prueba a arrancar con el target de rescate. Para hacerlo, debes presionar la ‘e’ cuando te salga el menú del grub y añadir tú mismo systemd.unit=rescue.target a la línea del kernel.

    Una vez hayas podido arrancar, debes mirar el log de arranque:

    sudo su
    journalctl -b -1
    

    Saludos!

  • @karasu !

    @judd
    Has hecho algun cambio? Alguna actualización? Quitado/cambiado un disco o sus particiones?
    jaja como si me estarias viendo ehh!!

    Si, encontre un disco duro externo samsung de 250 GB, que mi hijo usaba para la xbox 360 y me dije…ya te lo imaginas jajja :smile: :satisfied:
    Luego lo saque, hice un os-prober y un grub-mkconfig -o /boot/grub/grub.cfg y volvi a antergos con gnome (un genio:wink: )jaja

    Bueno

    Luego del systemd.unit=rescue.target tira esto:
    IMG_20150912_142239.jpg

  • El “Error getting authority” te lo da después de poner el password de root?

    Añadiste una entrada para ese disco duro en /etc/fstab? Si es así debes quitarla.

  • El “Error getting authority” te lo da después de poner el password de root?
    SI
    Añadiste una entrada para ese disco duro en /etc/fstab? Si es así debes quitarla.
    NO, esto ahi en el /etc/fstab
    IMG_20150912_173645.jpg

    justo entraba para poner esta otra foto
    IMG_20150912_172450.jpg
    por que ahora al menos tira un promp #

  • Hola,

    No entiendo bien qué ha pasado, pero tienes el /etc/fstab vacío! Para generar uno nuevo:

    sudo su
    pacman -S arch-install-scripts
    genfstab -U / > /etc/fstab
    
  • Tampoco se puede hacer nada, todo es de solo lectura
    captura FSTAB.png
    IMG_20150913_101354.jpg
    no deja instalar nada, todo esta bloqueado hice el sudo su como se ve en la foto con root, cual no se debe hacer, pero bueno, ya no me daba nada en los comandos anteriores…

    Además ya pase todo lo que tenia importante, montando sda3 a esta que escribo sda4, entonces no ahi drama.

    Reinstalar ?

  • Hola,

    Para poder editar, debes arrancar con la livecd, abrir una terminal y montar la partición de root (/). Si la partición de root es la sda3, entonces:

    sudo mount /dev/sda3 /mnt
    cd /mnt/etc
    nano fstab
    

    Y podrás editar el fstab

    P.D. También lo puedes hacer desde otro linux que tengas instalado.

  • Hola,
    Lo hice desde donde estoy escribiendo, y no me funciono, entonces desde un usb de antergos si (tal ves no se hacerlo bien…) y ahora reiniciando me tira el sda3 esto:
    IMG_20150913_144014.jpg

    Y la culpa fue mía ya que el man-db lo elimine y ahí en la foto lo dice.
    Tambien hice esto:
    man-db.png

    Ahora bien, abre el fstab, pero no se que poner dentro de él, ya que está vacio como antes :anguished:

  • Seria algo como esto, sacado de la wiki y segun recuerdo de mi sda3:
    /etc/fstab

    <file system> <dir> <type> <options> <dump> <pass>
    /dev/sda3 / ext4 defaults,noatime 0 1

  • Recién mire mi /etc/fstab y me ecuentro con esto:
    fstab sda3 y sda4.png

    o sea, tengo fstab en sda3, pero son dos de sda3, saco el del medio ? cual el tercero es más parecido al primero que es sda4 que estoy ahora ?

    Identificación de los sistemas de archivos:
    LABEL.png
    sda3 ext4 Arch(faltaria ponerlo?)

    No se, tu me dirás…

  • Hola,

    Evidentemente no deberías tener dos líneas para el sda3.

    El sistema raíz dónde está? En sda4 o en sda3 ? Según el fstab lo tienes en sda4 (la primera línea). Deberías cambiar esta primera línea del fstab si en realidad el sistema raiz está en sda3.

    Sinceramente, es muy raro que el fstab se cambie “por si solo”… algo habrás tocado :grinning:

  • @karasu said:

    Hola,

    Evidentemente no deberías tener dos líneas para el sda3.

    El sistema raíz dónde está? En sda4 o en sda3 ? Según el fstab lo tienes en sda4 (la primera línea). Deberías cambiar esta primera línea del fstab si en realidad el sistema raiz está en sda3.

    Sinceramente, es muy raro que el fstab se cambie “por si solo”… algo habrás tocado :grinning:

    Hola karasu !

    Claro que toque si, es que haciendo lo del fstab para sda3, casi rompo el sda4 de donde escribo, gracias a que queda grabado el comando por consola en las teclas de paginacion o de arriba y abajo, puede volver a sda4, en fin creo que es por esa rezón qu el fstab quedo así…

    El sistema raiz / esta en cada sistema, o sea / para sda3 y / para sda4, no ahi otra cosa, que esta mal montado todo si, pero bueno es lo que ahi…:satisfied:

  • Estuve leyendo en la wiki, pero no se que cambiar, tú me dices la primera linea, pero es el sda4, cual escribo ahora que anda perfecto, y de tocar las otras dos lineas del sda3, que anda mal y no me deja entrar y se tranca.
    FSTABBBBBBBBBBBB.png

  • hola, elimine la linea del medio y no se rompio nada, además agregue LABEL=Arch y que do asi:
    fstabbbbbbbbbbbbbbbb.png

  • Asi esta el fstab en sda3 ahora:
    IMG_20150914_174227.jpg
    y asi queda la linea de comandos arrancando desde el grub, sin systemd.unit=rescue.target
    IMG_20150914_180724.jpg
    Ya no se más como seguir o que hacer…

    Sigo trasteando …

    Ahora borre la linea de sda3 del fstab de sda4, donde estoy ahora, porque al inicio de antergos (sda4) me tiraba antes del login, que habia duplicado el fstab y algo como fstab/f …asi que decidí borrarlo, luego entro a sda3 con systemd.unit=rescue.target y me fijo si ahi fstab, que no este vacio y si esta con
    https://i.imgur.com/t2WNhXk.jpg
    asi que bueno, no se como seguir o que carajo hacer…:grin:

  • Hola,

    Perdona, pero no me aclaro.

    Qué tienes en /dev/sda3? Y en /dev/sda4?

  • Hola karasu
    Perdona, pero no me aclaro.

    Qué tienes en /dev/sda3? Y en /dev/sda4?

    Si te refieres a los fstab de sda3 y sda4 estos, estan así:
    En /dev/sda3 Arch (este sistema es el que NO PUEDO ENTRAR) este /etc/fstab
    IMG_20150914_174227.jpg

    En /dev/sda4 antergos Gnome (cual estoy escribiendo y no tiene problemas) este /etc/fstab fstab00000000000.png

  • @judd

    OK, ahora si! :grimacing:

    En el fstab de /dev/sda3 (arch) tienes un error. El cuarto parámetro debe ser “defaults” y no “default”

  • @karasu said:

    @judd

    OK, ahora si! :grimacing:

    En el fstab de /dev/sda3 (arch) tienes un error. El cuarto parámetro debe ser “defaults” y no “default”

    Ok, ahora pruebo !

Posts 23Views 5698
Log in to reply