• Natural (inverted) scroll not working on trackpad


    Hello everyone.

    Like the title says, natural scroll is not working on my Toshiba Kira trackpad. Oddly enough, it was working out of the box on the live system. After I finished the installation, it was gone. I am using GNOME.

    I read some guide on Arch wiki how to set it up, and I edited /etc/X11/xorg.conf.d/50-synaptics.conf, set VertScrollDelta and HorizScrollDelta to have negative values. Rebooted, no good. Values did make the impact on scroll speed, but not on direction.

    I looked up in dconf for org > gnome > settings-daemon > peripherals > touchpad, to check natural-scroll, and there is no touchpad under peripherals.

    I looked up gconf for /desktop/gnome/peripherals/touchpad/, but yet again, there is no touchpad key.

    Finally, I used synclient to set those values and see if it will work. It was working. But synclient sets it up only for a current session, so when I rebooted, those settings are lost. Note, I have the exact same settings in 50-synaptics.conf.

    Any idea how to make this permanent?

    Thanks.

  • have you tried going to "system settings -> mouse & trackpad > and check “natural scroll” option ? I dont know if nowdays natural scrolling is set on live-usb.iso’s gnome preferences by default, but sure it was not when I first installed antergos (long ago).

    after reading your post I’ve looked my X11 files and I got no such file (just a 50-synaptics.conf.pacsave file from former configs), so I guess it’s not needed now.

  • There are no “Trackpad” settings, only “Mouse”. :) So there is no natural scroll option.

    Anyhow, I solved it the other way. Looks like Gnome settings were overriding the synaptics driver settings, and Gnome probably didn’t recognize my touchpad so it regarded it as mouse device, hence lack of options.

    I there is a config in org > gnome > settings-daemon > peripherals > mouse, I unchecked active, and Gnome was no longer in control of my touchpad. Synaptics driver kicked in, and all settings from 50-synaptics.conf were working (which also included switching 2 finger tap with 3 finger tap). I had to make some adjustments in the file, but everything is working fine now.

mouse41 synaptics3 scroll3 touchpad31 Posts 3Views 1617
Log in to reply