• Can't Adjust Backlight though keyboard or the DE.


    I Can’t Adjust my Backlight on my Dell Studio 1558 Laptop though the keyboard controls or the control in my Desktop Environment(Gnome). I have tried http://askubuntu.com/a/401311/48372 but it doesn’t work. The only thing that

    sudo su
    "echo 200 > /sys/class/backlight/intel_backlight/brightness"

    In the terminal. It would be quite nice if someone could help me with it.

    Here is my /etc/default/grub http://hastebin.com/orawisalud.vala

  • Try adding this to your GRUB_CMDLINE_LINUX_DEFAULT line:
    acpi_osi=Linux acpi_backlight=vendor

    Remember to rebuild your grub.cfg afterwards (before rebooting):
    sudo grub-mkconfig -o /boot/grub/grub.cfg

    Cheers!

  • @karasu http://hastebin.com/iroqisavaj.vala
    Didn’t work, Did I did it right?

  • GRUB_CMDLINE_LINUX="video.use_native_backlight=1"
    I took that out and it still didn’t work.

  • Yes, you did it right. I’m afraid I have no more options… sorry.

  • Try adding the following to /boot/grub/grub.cfg (after “quiet splash”) to disable the dell module:

    acpi_osi=!* acpi_osi=“dell_laptop”

    If that doesn’t work, try this to enable the module:

    acpi_osi=“dell_laptop” acpi_osi=!*

Posts 6Views 1193
Log in to reply