• Wireless issue


    Hello, since I connected an external AWUSO36H Alfa network card, the networks I’ve been connected with it doesn’t appear on my pc built in PCI network card. I think thats what caused it because it works good if I boot as Live-CD . The AWUSO36H works with realtek drivers so I haven’t changed anything, just connected it.
    Now the PCI card doesn’t show those networks, I changed the network ESSID just to try but doesn’t work, seems like it won’t connect to any MAC adress that I used on the external alfa card.

  • Hi,

    I am not sure yet I will be fully able to help you but let me ask a few questions to be sure I understood your issue.

    • Do you have only one WIFI card on your computer ?
    • Do you see other networks ?
    • Please confirm there is no issue when you use Antergos Live USB but only after installing Antergos. In that case, what is the Desktop Environment you installed ?
  • I have the one which is built into the pc, but I also used an external USB card.
    I do see other networks, I just don’t see those which I’ve been connecting to using the external card, which are 2. I recently changed router settings and stuff, but it seems to be fully working on Live USB as I mention, so the only thing that comes to my mind is that using the external card caused some type of conflict with the PC built in card. I connected back the external card and removed all the network profiles cause that’s what I thought was causing the problem, that didn’t solved it so I thought maybe theres some file which contains the name of that network and assigned it to the external card interface so I changed them, but that didn’t fixed it.
    Im using GNOME, I reinstalled and wifi worked good until I connect the external card to it, I need to have both interfaces working, I don’t mind if I have to edit/remove a file or do something every time I switch, I also don’t mind reinstalling (I already did it) or installing another DE if that’s a solution.
    I have tried with other distros and for some reason OpenSUSE didn’t detect them while Ubuntu and Antergos Live USB and clean installation did.
    The network uses wpa2 encryption and PSK auth, other networks with those same settings show on the network list.

    Thanks for your time, I hope you have any idea on what to do cause I don’t.

  • @ViZe-Hack Hi

    I asked about the DE because the live USB is on Gnome and I thought you might have changed it after installing.

    So, on Gnome Live USB it works and on Gnome hard installation it doesn’t… That’s weird but maybe the developers know whether there is something different in the packages or setup.

    What is strange as well is that you see some networks but not all…

    Could you please confirm my understanding of your issue.

    Your built-in card works both on Live USB and hard installation. When you connect your external WIFI dongle, you can’t connect anymore to the network except when you are on Live USB.

    Then, how to you do on Live USB to activate the external dongle and deactivate the built-in card ?

    I know I don’t provide any solution here. I am trying to help troubleshooting.

  • The external WIFI dongle works good on Live USB and HD as well. I don’t need to deactivate the built-in card, it recognizes both.
    After HD installing the buil-in one works good, but if I connect the dongle (without deactivating the built-in one) and use it in “X” network, then even if I disconnect the dongle, “X” doesn’t appear on the network list.
    I suspect that not deactivating the one that’s not in use cause this issue, I guess I could try that, im not sure how to do it though, ¿I just comment the line of the network interface in network.rules?
    Im gonna try it, but I think there should be a way to have two interfaces connecting to the same network without conflicitng.

  • @ViZe-Hack Hi

    Could you post the result of the following command ifconfig without the external wifi dongle and then with it ? Could you try the same set of command on Live USB as well ?
    It is to check whether there is something on the hardware side.

    What you can try as well is to remove the connection of your “X” network on your built-in card by going to Network settings, open your “X” network preference and then in the Reset menu, click on the Forget button. Then, connect your external dongle and check whether the “X” network is visible.

  • Is the card in your computer always trying to connect before the USB one? if so you could just disable that one using ifconfig?

    sudo ifconfig wlan0 down

    wlan0 being the wireless interface you are trying to disable.

    gmail: [email protected]
    irc: [email protected]

wireless25 Posts 7Views 2008
Log in to reply