• Antergos base + plasma


    hi,

    i did new install “antergos base”. then i did sudo pacman -S plasma.
    What are the next steps to be able to log into antergos plasma?

    • Install sddm package (if it’s not installed already)
    • Enable sddm in systemd
      systemctl enable sddm.service
    • Reboot and choose Plasma in display manager menu

    Alternatively, you can load plasma without a display manager

    • append exec startkde to your ~/.xinitrc file
    • Reboot, login into the tty and write startx and press enter.

    Archlinux x64

    AMD A4-3305M Processor
    6GB RAM
    1GB+512MB Hybrid AMD GPU

  • thanx.
    I tried “systemctl enable sddm” before. It ends with a blinking curser with no posibilities of interaktion.
    I will trie again with systemctl enable sddm.service

  • I will trie again with systemctl enable sddm.service

    You’ll get the same result.
    If you don’t have any desktop manager installed (no gdm, no lightdm, …) you only need to:

    sudo systemctl enable sddm
    sudo systemctl start sddm
    

    Cheers!

  • hm, only with
    sudo systemctl enable sddm
    sudo systemctl start sddm

    I get the same result, again.

    Probably there’s still missing something. This is what i did:
    -install antergos base with cnchi
    -reboot into antergos base
    -install plasma
    -sudo systemctl enable sddm
    -sudo systemctl start sddm

    Or: How to append exec startkde to my ~/.xinitrc file with command-line?

  • @atergo

    I install plasma from base myself, here are my steps for a working system. The base does not include xorg, you have to download that yourself.

    First xorg and sound.

     sudo pacman -Syy pulseaudio pulseaudio-alsa xf86-input-synaptics xf86-video-fbdev xf86-video-vesa xorg-apps xorg-fonts xorg-server xorg-server-utils xorg-xinit xorg-xkill mesa mesa-vdpau
    

    Now Plasma and some essentials.

    sudo pacman -S plasma konsole kate dolphin ark screenfetch reflector gwenview sddm-kcm firefox flashplugin
    

    Now lets turn it on.

    sudo systemctl enable NetworkManager
    sudo systemctl enable sddm
    sudo systemctl enable bluetooth.service (If you have bluetooth)
    

    Now reboot. Sddm should now start.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • yep. works. thanx a lot.

    (had to fix little mistakes in your xorg line)

  • @atergo

    Sorry bout that, it’s been fixed. :+1: .

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

Posts 8Views 1614
Log in to reply