• Font changes color


    The color of the font will change, for example as I type this, it went from black to white. Or as I scroll a webpage, in the terminal, update window etc. Highlighting the text if it can be selected, tends to bring it back. font.png Here are the SystemD logs logs.tar. My gpu is nvidia 750Ti. I tried to install some other fonts, not sure how well it worked. Had errors about installing 32bit libraries on a 64bit system, even though I commented out the multilib part of the conf file. Windows fonts showed conflict errors with other fonts, which I didn’t know how to fix.

  • Hi,

    Does the issue occur when using the Numix Frost themes (Gtk, Window, and Cinnamon)?

  • Both default Cinnamon and default Gnome3 installed. And it happens in both.

  • Okay but that’s not really what I asked you. We’re always happy to help when we can but in order for us to do that its important for you to do your part by providing the information we request :wink:

  • According to themes Numix Frost is used for window borders, controls, and desktop. Does that answer all the questions you asked. If not can you give me a hint for where else to look?

  • Are you using the default nouveau driver? Then this is the problem. Try installing the proprietary nVidia driver. The package is just called “nvidia”.

  • Thanks the rendering is fixed.
    I presume the opencl are the non-proprietary drivers.
    Before
    nvidia.png

    So all the nvidia packages from extra are made by nvidia. Is it safe to remove all the community ones. Is bumblebee worth installing.

    after2.png

  • @tadcan said:

    …Is bumblebee worth installing.

    If this is a question, then this article could help you to make a decision.

  • @just
    Thanks, that is very helpful, since I planned to run steam games, esp, that this example about how to unlock multilib with a new example that includes SigLevel,
    [multilib]
    SigLevel = PackageOptional
    Include = /etc/pacman.d/mirrorlist

  • When I did an update, I got this warning, can someone explain what it means. After close is pressed the update install continues. Is that the right approach?

    lib32-nvidia-libgl: local (355.11-1) is newer than multilib (352.41-1)
    lib32-nvidia-utils: local (355.11-1) is newer than multilib (352.41-1)

  • Did you enable the testing repositories in /etc/pacman.conf? (You should not do that). If that doesnt explain it then its most likely just an out of syn mirror. You can refresh your mirrorlist by first installing reflector and then running this command:

    sudo reflector -l 50 -f 20 --save /etc/pacman.d/mirrorlist
    

    and then finally, run this just to be safe:

    sudo pacman -Syyu
    

    Cheers!

  • @lots-0-logs

    This is the testing lines in the conf file?
    #[community-testing]
    #SigLevel = PackageRequired
    #Include = /etc/pacman.d/mirrorlist

    I installed and ran the refelector package, Hopefully I wont get that warning again.

  • From the screenshot you posted it looks like you have both the nvidia and xf86-video-nouveau packages installed. xf86-video-nouveau is the open source driver which I’ve found to be unusably buggy on a GeForce GTX 750 card, so this can probably be safely uninstalled to avoid confusion:

    pacman -Rns xf86-video-nouveau
  • I presume the opencl are the non-proprietary drivers.

    I forgot to add that the opencl stuff has nothing to do with the non-proprietary drivers. OpenCL is a set of libraries / API for doing GPU computing.

  • @pgoetz Thanks for your help. So the openCL packages are for making games, boinc (distributed computing) etc? Just wondering if they should be removed.
    The warnings are still popping up when during an update. There was a dialog box which came up about resetting the mirrorlist. Ran the command again. Would it help to post the pacman.conf.
    lib32-nvidia-libgl: local (355.11-1) is newer than multilib (352.41-1)
    lib32-nvidia-utils: local (355.11-1) is newer than multilib (352.41-1)

  • GPU computing is for distributed and/or high speed floating point operations (i.e. math, scientific computing). If you’re not doing this stuff, you can safely remove the opencl packages. In fact, I’m not sure how/why these got installed on your system in the first place. Nothing seems to depend on them.

  • Removed nvidia-Its and opencl-nvidia since they weren’t dependencies for other programs. I installed some random packages as my first attempts to solve the original font issue.

fontrendering5 Posts 17Views 1929
Log in to reply