• Can't adjust screen brightness


    First of all. Thanks for Antergos, it is superb! No other distro has been this fast (tried Manjaro Openbox and it had lots of problems :confused: ) and because of the openbox I can modify it to look just the way I like! I have a few minor thinks that bug me but the big picture looks really good.

    Anyway, this is not a minor thing. I have an ASUS n56dp laptop that has Radeon dual graphics with Radeon HD 7640G and Radeon HD 7730M. I just recently installed Antergos with Openbox. The problem is I can’t adjust the screen brightness in any way. With Mint installed I could adjust the brightness.

    In /sys/class/backlight/ I have only radeon_bl0 folder, I can change the brightness value with echo “250 > /sys/class/backlight/acpi_video0/brightness”, but that won’t change the brightness of the screen. Trying to use xbacklight gives “No outputs have backlight property”.
    I don’t know what to do next. Maybe installing the catalyst drivers could help? But I would not like to do that.

  • echo “250 > /sys/class/backlight/acpi_video0/brightness”

    This is wrong. Please, try this (without ticks):

    sudo su
    echo 250 > /sys/class/backlight/acpi_video0/brightness
    

    I do not know for sure that the sudo su is needed in this case, but better safe than sorry.

    Cheers!

  • Oh yeah. Sorry I mispelled that (copy-pasted from somewhere), it has also “acpi_video0” but I’m usin “radeon_bl0”.

    But yeah, sudo su doesn’t help. Same result.

  • Hi,

    Sorry I’m at work now so I can’t check this out. Have you readed this?

    https://wiki.archlinux.org/index.php/Backlight

    Maybe some acpi kernel parameter helps.

    Cheers!

  • I’ve read it. And if I’m understanding correctly I’ve tried everything from that page. I added “video.use_native_backlight=0” as the last line in GRUB config -> reboot -> no change.
    Tried the “tee /sys/class/backlight/radeon_bl0/brightness <<< 5” command, no difference.
    But one thing I was uncertain about was the “modprobe asus-nb-wmi” command. How should I use it? I entered the command to the terminal and after that tried echo, tee and xbacklight. But nothing happened.

  • I’ve read it. And if I’m understanding correctly I’ve tried everything from that page. I added “video.use_native_backlight=0” as the last line in GRUB config -> reboot -> no change.

    Before rebooting remember to issue a grub-mkconfig -o /boot/grub/grub.cfg as root.

    But one thing I was uncertain about was the “modprobe asus-nb-wmi” command.

    If you run it as root it will load the asus-nb-wmi module. It seems that is for Fn keys, so I don’t know if it will help or not…

    Cheers!

  • Before rebooting remember to issue a grub-mkconfig -o /boot/grub/grub.cfg as root.

    Thanks, forgot that. When I try to update with the command it says /etc/default/grub: line 54: video.use_native_backlight=0: command not found
    EDIT: clarification

  • @peruna

    What you want to add is a kernel parameter, so you have to add it to the kernel command line.

    In /etc/default/grub search for the GRUB_CMDLINE_LINUX_DEFAULT line and add video.use_native_backlight=0 to the end (inside the ticks).

    For instance, mine looks like this:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    So I should change it to:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video.use_native_backlight=0"

    Cheers!

  • Thanks that worked! Now I can change the brightness with the fn+f5/f6 buttons, even though it is really slow. It might be slow because the maximum screen brightness value seems to be 255 (accoring to that backlight wiki page usually the maximum value is 15).
    I don’t know what commands those keybindings produce since it is not precent in the rc.xml file. Echo, tee and xbacklight commands still won’t change a thing.

  • @peruna

    Now I can change the brightness with the fn+f5/f6 buttons, even though it is really slow

    Well, at least it’s better than before. If I understand you well, this doesn’t work either?
    xbacklight -dec 50

    I’m sorry I can’t be of more help.

    Cheers!

  • Well, at least it’s better than before. If I understand you well, this doesn’t work either?
    xbacklight -dec 50

    Yup, that doesn’t work either. But now I can control the screen brightness pretty easily, it’s more than enough. Thanks a lot!

brightness10 asus10 laptop25 screen16 radeon10 Posts 11Views 3336
Log in to reply