• Gnome 3: Logoff opens an unusable console instead of login manager


    Hello everybody,
    my system is Antergos 64-bit with Gnome 3 as the user interface and full system encryption.
    When I logout my user via GUI (or console) I expect to come back to my login manager, which I changed due to suspend issues from gdm to lightdm. But instead I come back to the console which you see at the startup of your system, with a bad resotion, where you have to enter the full-disk-encryption-passphase, but I can’t enter things there.

    My question is: How do I change to logout behaviour so that my systems brings me back to my lightdm screen instead of going back to this unusable console?

    Thanks for reading and greetings,
    flennic

  • @Flennic

    Check that you have lightdm enabled:
    sudo systemctl enable lightdm

    You can check the logs, too. They’re in /var/log, check for the lightdm log to see if anything wrong is happening.

  • Hello karasu,

    thanks for your help (also in my other posts). I looked into the logs and the first thing I see is that all of them are several days old, which looks like lightdm is not running properly. I did “sudo systemctl disable gdm” and “sudo systemctl enable lightdm” but that doesn’t change the date of any log file. Even after reboot.

    The log file shows:

    [[email protected] lightdm]# cat lightdm.log
    [+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
    [+0.00s] DEBUG: Starting Light Display Manager 1.14.0, UID=0 PID=456
    [+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
    [+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
    [+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
    [+0.00s] DEBUG: Registered seat module xlocal
    [+0.00s] DEBUG: Registered seat module xremote
    [+0.00s] DEBUG: Registered seat module unity
    [+0.05s] DEBUG: Monitoring logind for seats
    [+0.05s] DEBUG: New seat added from logind: seat0
    [+0.05s] DEBUG: Loading properties from config section SeatDefaults
    [+0.05s] DEBUG: Seat seat0: Starting
    [+0.05s] DEBUG: Seat seat0: Creating user session
    [+0.09s] DEBUG: Loading users from org.freedesktop.Accounts
    [+0.09s] DEBUG: User /org/freedesktop/Accounts/User1000 added
    [+0.09s] DEBUG: Seat seat0: Creating display server of type x
    [+0.09s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
    [+0.09s] DEBUG: Using VT 7
    [+0.09s] DEBUG: Seat seat0: Starting local X display on VT 7
    [+0.09s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
    [+0.09s] DEBUG: DisplayServer x-0: Writing X server authority to /run/lightdm/root/:0
    [+0.09s] DEBUG: DisplayServer x-0: Launching X Server
    [+0.09s] DEBUG: Launching process 482: /usr/sbin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
    [+0.09s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
    [+0.09s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
    [+0.09s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
    [+1.37s] DEBUG: Got signal 10 from process 482
    [+1.37s] DEBUG: DisplayServer x-0: Got signal from X server :0
    [+1.37s] DEBUG: DisplayServer x-0: Connecting to XServer :0
    [+1.37s] DEBUG: Seat seat0: Display server ready, starting session authentication
    [+1.37s] DEBUG: Session pid=507: Started with service 'lightdm-autologin', username 'flennic'
    [+1.40s] DEBUG: Session pid=507: Authentication complete with return value 0: Success
    [+1.40s] DEBUG: Seat seat0: Session authenticated, running command
    [+1.40s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
    [+1.40s] DEBUG: Session pid=507: Running command /etc/lightdm/Xsession gnome-session
    [+1.40s] DEBUG: Creating shared data directory /var/lib/lightdm-data/flennic
    [+1.40s] DEBUG: Session pid=507: Logging to .xsession-errors
    [+1.46s] DEBUG: Activating VT 7
    [+1.46s] DEBUG: Activating login1 session c1
    [+1.46s] DEBUG: Seat seat0 changes active session to c1
    [+1.46s] DEBUG: Session c1 is already active
    [+362.69s] DEBUG: Session pid=507: Terminated with signal 1
    [+362.69s] DEBUG: Seat seat0: Session stopped
    [+362.69s] DEBUG: Seat seat0: Stopping display server, no sessions require it
    [+362.69s] DEBUG: Sending signal 15 to process 482
    

    Coulnd’t find something to wrap the log in, so i just pasted it here. Hope that’s okay.

    There are some hints in there:

    * [+1.46s] DEBUG: Session c1 is already active
    * [+0.09s] DEBUG: Could not run plymouth --ping: Failed to execute child process "plymouth" (No such file or directory)
    

    Any further ideas?

    And another question: Is “sudo systemctl enable xxx” permanent (after reboot)? I guess: yes?

  • I see is that all of them are several days old, which looks like lightdm is not running properly

    Can you open a terminal and run ps ax ? It’s just to check that lightdm is running.

    Coulnd’t find something to wrap the log in, so i just pasted it here. Hope that’s okay.

    Next time wrap it with three back ticks (three for start, three for end). I’ve already done it for you.

    And another question: Is “sudo systemctl enable xxx” permanent (after reboot)? I guess: yes?

    Yes.

    About the log, it seems to me that lightdm detects that your session has finished but then it closes itself ¿? I’m sorry but I don’t know what’s wrong.

    Check if you have a .xsession-errors file, maybe X is throwing an error there.

    Cheers!

  • Hello karasaru,

    [[email protected] lightdm]# ps ax | grep lightdm
     2508 pts/0    S+     0:00 grep lightdm
    

    Here is the Xorg.0.log file. I couldn’t find any useful information.

    Xorg.0.log.pdf

    Still thanks a lot for your help. Maybe we or someone else can track the error!

    Cheers,
    flennic

  • @Flennic

    So lightdm is not running! Are you running Gdm?

  • Hi karasu,

    if lightdm is not running, how do I start it permanently? “sudo systemctl enable lightdm” doesn’t seem to do the job here, or am I wrong?

    Greetings
    flennic

  • Yes, that’s right. Check that there’s no other DM installed, though.

    sudo systemctl disable gdm
    sudo systemctl stop gdm
    sudo pacman -Rs gdm
    sudo pacman -S lightdm lightdm-webkit-theme-antergos
    sudo systemctl enable lightdm
    sudo systemctl start lightdm
    
  • Hi karasu,

    now I know a bit more. First I mixed things up: I want to use gdm NOT lightdm due to the fact that with lightdm suspend and lock screen do not work (no idea why). Sorry that I did mix that up. So after I did what you said, I reentered all the commands but I switched lightdm with gdm. I couldn’t uninstall lightdm but I were able to disable it. So now I am using gdm and everyhting works.

    What I did before was disable password login for gdm, because I already have full disk encryption so it wasn’t necasarry in my eyes. I read through the Archwiki again and there is said:

    https://wiki.archlinux.org/index.php/GDM#Automatic_login

    Passwordless login
    
    If you want to bypass the password prompt in GDM then simply add the following line on the first line of /etc/pam.d/gdm-password:
    
    auth sufficient pam_succeed_if.so user ingroup nopasswdlogin
    
    Then, add the group nopasswdlogin to your system. See Groups for group descriptions and group management commands.
    
    Now, add your user to the nopasswdlogin group and you will only have to click on your username to login.
    Warning:
    
        Do not do this for a root account.
        You won't be able to change your session type at login with GDM anymore. If you want to change your default session type, you will first need to remove your user from the nopasswdlogin group.
    

    Read the warning: I can’t change the session type. I have no idea what the session type is, but I guess (didnd’t test it again) this prevented my pc from switching the user (session type?) or seeing the gdm screen. Thats the only reason I can think off.

    So for now I have to reenter my password at the login once I start the pc, but therefore the bug is gone. I don’t know if “the bug” comes back when I enable passwordless login. For now I’ll let the system rest.

    Another question: Any idea, why suspend does not work with lightdm but with gdm? After I advice my pc to suspend with lightdm I just see a blank console with a “_” blinking and py pc doesn’t respond anymore.

    karasu, thanks for all your time, I really appreciate your work and thanks for this great Operating System, I love it!

    Greetings
    flennic

lightdm89 logoff1 gdm33 logout3 gnome215 Posts 9Views 1871
Log in to reply