• Audio muted by default, and can't get 4.1 sound working

    So I’ve just installed Antergos with Gnome 3, and one of the first issues I noticed was that there was no sound. Even when setting the sound to max nothing would come out. No volume blips, no audio from YouTube videos, nothing. Oddly though, if I mute and unmute using Function+F7 (my laptop’s mute toggle) I can hear the unmute sound, and if anything else is making noise I can hear it too for the short duration of the unmute sound. (If this is confusing I can upload a video)

    This was bizarre to me as I had the correct audio device selected, and it even gave me options to change it from 2.0 to 2.1 or 4.0 (although I have a 4.1 setup, but that comes later). I searched around and found this post (dude has the same laptop as me) and SHIFT+FN+F7 does indeed unmute and audio works fine… until I restart.

    While this is a minor inconvenience, I’d like to know if there’s any way to have the laptop be unmuted by default.

    My second issue is that I don’t have the option to use my full 4.1 setup. I just get this. Is there any way to set up 4.1 audio?

  • @axb993 Have you tried to play with alsamixer in terminal?

  • Just opened it, I have nowhere near as many options as you:

    It looks like that whether or not I’ve done the FN+SHIFT+F7 thing.

  • @axb993 You have to hit the F6 key, to select the sound card you want to work with.

  • Hi,

    You should also check pavucontrol if you haven’t.

  • @karasu Just tried that, but when I haven’t applied SHIFT+FN+F7 nothing there enables sound, and nothing in that menu is different regardless of whether or not I’ve applied the fix. Seems like a dead end :/

    @just OK, hitting F6 in AlsaMixer brings up a menu with 4 options:

    (default) (which is highlighted)
    0 HDA Intel HDMI (I’m not using HDMI out but I looked there anyway, there are 3 “S/PDIF” options that are set to 00 and that I can’t change)
    1 HDA Intel PCH (This one look infinitely more promising than the othersalsamixer2.png, however none of the options there change when I toggle SHIFT+FN+F7. It does, however, realize that I have a Realtek card, and it responds to changes in system volume)
    enter device name… (I have no idea what to do with this one and I’m too scared to experiment with it, I’ve already killed Antergos before :/)

    Does anything there look out of order?

  • If you still have no sound after reboot, you could try this solution.

    It may happen, that kernel doesn’t use the correct sound card by default. For example, it could use HDMI instead of HDA Intel PCH. It is possible to “force” kernel to use the correct sound card, which is HDA Intel PCH.

    1. Run in terminal the command

      aplay -l
    2. It will generate an output similar to this


    3. Take a note about the card and the device numbers, which correspond to HDA Intel PCH. In this example they are:

      • card 1
      • device 0
    4. Add to kernel’s boot line one more parameter:


      Here, the values that follow the = sign, are your card and device numbers.

    5. The whole boot line may look like (I’m using grub 1, just want to give you a general idea on how the boot line may look)

      title antenext
      kernel (hd0,14)/boot/vmlinuz-linux showopts root=/dev/sda15 ro resume=/dev/sda3 quiet splash snd-hda-intel.index=1,0
      initrd (hd0,14)/boot/initramfs-linux.img

      If you use grub 2, remember to regenerate the grub.cfg after adding this parameter. The command that does it was posted in the forum by @karasu at least one thousand times. It starts with grub-mkconfig ... . If you search the forum, you should easily find it.

    It may or may not work. At least, you could give it a try.

  • Hmm, it looks like I have 2 “HDA Intel PCH” listings:


    Is that normal?

    Also, how do I change the kernel’s boot line? I know I’m using grub 2, can I use Grub Customizer for that? And if so, does Grub Customizer regenerate grub.cfg?

    Sorry if these are stupid questions, I’m very new to this :/

  • @axb993 said:

    Hmm, it looks like I have 2 “HDA Intel PCH” listings:

    Is that normal?

    I don’t know. Never had a box with double HDA Intel PCH card.

    I would start with the Analog one: snd-hda-intel.index=1,0

    If it doesn’t work, try the Digital one: snd-hda-intel.index=1,1

    Again, these are purely theoretical suggestions. No guarantee that it will work. Never have to deal with such cards.

    Also, how do I change the kernel’s boot line?

    If I recall correctly, the main grub’s 2 file for various user customizations is


    It shoulld contain a line which starts with


    Parameters between double-quotes are any additional ones the user can add. There’re no such parameters in the example above. The line was usually found near the top of the file.

    Add your parameter to it


    Save the file and regenerate grub.cfg.

    Repeat, I don’t use grub 2. Search somewhere else to verify that what i’m saying is correct.

    I know I’m using grub 2, can I use Grub Customizer for that?


    And if so, does Grub Customizer regenerate grub.cfg?

    Yes, it will probably do. The best tools to work with grub is your own head and hands. Grub is too delicate thing for being permitted to be managed by other tools.

    I don’t use Grub Customizer.

    Sorry if these are stupid questions, I’m very new to this :/

    Come si dice da noi, nessuno nasce imparato 😄 . Not sure, how to say it in English. It could be a bit difficult to learn Linux initially. But more you learn it, more it rewards you, and every day becomes easier to work with.

  • Tried both, didn’t work :/ exactly the same as before, with FN+SHIFT+F7 unmuting it.

    What exactly does that key combination do? Surely finding that out would help fix this?

    Also thank you so much for all the help, it really means a lot.

sound62 audio50 no sound4 muted2 4.11 Posts 10Views 3038
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.