• Mousetweaks and Xorg high cpu usage when moving the mouse


    I don’t know when the issue started, but a few days ago noticed a high Xorg cpu usage sometimes, and after some testing the problem only appears when i move my mouse or my touchpad (keyboard doesen’t seem to upset it), today i also noticed mousetweaks also starts using a high cpu percentage along with Xorg (a bit less).

    Moving the mouse

    [afonso:~]$ top -bn1 | grep 'Xorg\|mousetweaks'
    8156 root 20 0 356.7m 66.4m 50.0 0.6 20:17.29 S - Xorg
    8295 afonso 20 0 426.2m 24.0m 33.3 0.2 8:09.99 S - mousetweaks

    When not moving the mouse

    [afonso:~]$ top -bn1 | grep 'Xorg\|mousetweaks'
    8156 root 20 0 356.6m 66.3m 5.9 0.6 20:18.31 S - Xorg
    8295 afonso 20 0 426.2m 24.0m 0.0 0.2 8:10.65 S - mousetweaks

    GNOME Shell 3.16.3
    Linux Kernel 4.2.0-rc8

  • Hi Afonso Bordado,

    dou you use the opensource or the proprietary graphics cards driver? Is your graphics card amd/intel/nvidia?

    I know that behaviour because it happened to me with amd and the free graphics driver!


  • My computer has two graphics cards, Intel HD 4400 and Nvidia 840M, usually i turn the nvida off with bbswitch and only switch it on and use it with bumblebee when playing games, so i believe at the time i was using the Intel driver.

    When using the Nvidia graphics card i use the 352.41 version of the proprietary driver

  • Killing mousetweaks seems to fix the issue and the only setting that i configured on the gnome settings (Right mouse click when long pressing on the touchscreen) is working even with no mousetweaks process, other features such as double finger scroll are working as well and don’t spawn a mousetweaks process.

    I’m assuming its unsafe to remove mousetweaks due to its tight integration with gnome, but is there any way to disable it within gnome or should i just make a post init script to kill mousetweaks after startup?

xorg29 cpu22 mousetweaks1 Posts 4Views 2232
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.