• Video driver


    Hi,

    How do I know what video driver I have currently installed?

    When I type:

    lspci | grep VGA
    

    says I have: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5730 / 6570M]

    How I install the appropriate driver for my hybrid graphics?

    Thanks.

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • Hi,

    How do I know what video driver I have currently installed?

    When I type:

    lspci | grep VGA
    

    says I have: Advanced Micro Devices, Inc. [AMD/ATI] Madison [Mobility Radeon HD 5730 / 6570M]

    How I install the appropriate driver for my hybrid graphics?

    Thanks.

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • I went to [https://wiki.archlinux.org/index.php/AMD_Catalyst][0]">[https://wiki.archlinux.org/index.php/AMD_Catalyst][1] and followed the instructions to install the catalyst driver via the unofficial repo and got this:

      
    [[email protected] ~]$ sudo pacman -Syu  
    :: Synchronizing package databases...  
    catalyst 9.4 KiB 1341K/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    catalyst.sig 287.0 B 0.00B/s 00:00 [\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#\#] 100%  
    core is up to date  
    extra is up to date  
    community is up to date  
    antergos is up to date  
    multilib is up to date  
    :: Starting full system upgrade...  
    there is nothing to do  
    [[email protected] ~]$ sudo pacman -S catalyst catalyst-utils  
    resolving dependencies...  
    looking for inter-conflicts...  
    :: catalyst-utils and mesa-libgl are in conflict (libgl). Remove mesa-libgl? [y/N] y  
    :: catalyst-utils and libcl are in conflict. Remove libcl? [y/N] y  
    error: failed to prepare transaction (could not satisfy dependencies)  
    :: ati-dri: requires mesa-libgl=9.2.2  
    :: glamor-egl: requires mesa-libgl  
    
    

    Should I uninstall ati-dri and glamor-egl first?

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/AMD_Catalyst

    Never was anything great achieved without danger. - Niccolo Machiavelli

  • I haven’t dealt with the newer hybrid graphics setups personally. Perhaps these links will guide you in the right direction.

    [https://wiki.archlinux.org/index.php/hybrid_graphics][0]">[https://wiki.archlinux.org/index.php/hybrid_graphics][1]

    If it were me I would try this first —> [https://aur.archlinux.org/packages/hybrid-video-ati-intel-systemd/][0]">[https://aur.archlinux.org/packages/hybr][2] … l-systemd/

    Regards,

    [0]: <a href=
    [1]: https://wiki.archlinux.org/index.php/hybrid_graphics
    [2]: https://aur.archlinux.org/packages/hybr

  • I haven’t dealt with ati, but my nvidia driver also complains of a conflict with mesa-libgl. I simply uninstall it.

     sudo pacman -Rdd mesa-libgl
    

    Distro hopping junkie
    Developer for [Entropy GNU/Linux[/url:22cla13f]]0

  • @“AnonKS”:3903hgrc said:

    I haven’t dealt with ati, but my nvidia driver also complains of a conflict with mesa-libgl. I simply uninstall it.

     sudo pacman -Rdd mesa-libgl
    

    See my post here: [http://forum.antergos.com/viewtopic.php?f=21&t=1280#p4620][0]">viewtopic.php?f=21&t=1280#p4620 for a script that you might find useful for switching between the two.

    [0]: <a href=

Posts 6Views 1307
Log in to reply