• [Solved] How to install grass-gis (*.tar.gz)


    Hello,

    For me Antergos and Linux are both new. I wanted to try it because I tought it would be learning full. I don’t know if I have to meantion it, but as some of you can see; English is not my own language. So I hope it is good enough that I will give it a try to get the question straight.

    One of the reasons to make the step to a linux distribution is for GRASS GIS. The programm had a few crashes in windows so that was the thing that convinced me that I had to move on to another operating system.

    I tried to instal GRASS GIS in from the AUR, but the package, as I saw, is not in the AUR. So then I had one other option I tought, by downloading the snapshot. This snapshot contains the file that end with .tar.gz . After some research I found a few things using pacman. But the first question is that there is said that I must have a /build/ directory. I can’t found that directory so does that matter?

    I tried to install it using the following code:
    sudo pacman -U $HOME/Downloads/*.tar.gz
    But this gives an error. It did found the file in the directory, but the error that is send says the package is corrupt. So can anyone help me with the installing of *.tar.gz files, because I think this is something that I will need more than only for this.

    It would be creat if anyone knows how to solve this!

  • Were you following these steps?

    https://grasswiki.osgeo.org/wiki/Compile_and_Install#Arch_Linux

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Hello,

    Yeah I also tried the steps that are described there. It was a few days ago, so I forgot about that method.

    But as you can gues, also that didn’t work for me.
    My /home/pepijn/ (the $HOME) directory contains the following folders: Desktop, Documents, Downloads, Music, Pictures, Public, Templates, Videos. So do I have to create the folder /usr/bin/ ?
    Or do I have to remove the $HOME from the command so it comes in the /usr/bin/ folder? And is it true that using this commands, there is no need for the *.tar.gz file?
    Thanks for your fast respons!

  • Well, I have found that the grass software is just updated in the new AUR. I saw it first in the AUR3, but there was a move to AUR4 or something. But now it is again available in the AUR. I tried a lot of stuff, even cole the whole AUR3 on my pc, but I think that when you need GRASS GIS on antergos you just have to install it from the AUR.

solved14 grass-gis1 install78 Posts 4Views 1840
Log in to reply