• mate-mint-menu works again


    Hi guys and gals,

    There are good news for all Mate fans out there. Our much loved mate-mint-menu turns back to work and shine in all its splendor.

    The recent Antergos’ upgrade has

    1. ported mate-mint-menu to 5.6.4-3 (which is less important)

    2. removed the offending python2 2.7.10 package (it solved the problem with the applet)

    3. replaced it with python2-no-hardening 2.7.10-1 (good to know)

    There’s no need to downgrade python2 from 2.7.10 to 2.7.9 anymore. Because the package doesn’t exist.

    If you have downgraded earlier, and was keeping it at 2.7.9 with IgnorePkg = instruction, then there’s no need to continue doing so, either. Edit the /etc/pacman.conf file and remove the ignored python2 package from it:

    1. It is possible to comment out the whole IgnorePkg= line

      #IgnorePkg = python2
      
    2. Or, it is possible to keep IgnorePkg = instruction active, and remove python2 only from it

      IgnorePkg =
      

    Add mintMenu applet back to the panel. It will work without any additional tricks now.

    Patience is a virtù.

  • So, I have ‘updates’ in the desktop notifier including “mate-mint-menu 5.6.4-3” and “python2 2.7.10-1”.

    I can safely update all now and it will all stay good?

    I didn’t do any of the IgnorePkg stuff. I was just manually un-ticking the Python update in the update tool.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    So, I have ‘updates’ in the desktop notifier including “mate-mint-menu 5.6.4-3” and “python2 2.7.10-1”.

    I use pacman (or yaourt) for upgrades in terminal. I’ve upgraded few hours ago and don’t remember exactly what was shown in pamac’s window.

    I believe it’s safe to run the transaction in pamac. But if you prefer a bit deeper look into what will happen during the upgrade, you could post back here the full output of the command (without executing it up to the end! do not confirm the transaction)

    sudo pacman -Syu
    

    We’ll take a closer look togther on what’s about to happen. Anyway, I believe both ways (in terminal or with pamac) will work well.

    I can safely update all now and it will all stay good?

    Yes. After a full upgrade in terminal (with above command) everything works very well here. No manual intervention is needed.

    I didn’t do any of the IgnorePkg stuff. I was just manually un-ticking the Python update in the update tool.

    Wow! I’m wa-a-ay more lazy than you :smile: . It was too hard for me to exclude python2 from upgrading by hand every time a package manager was running. So I’ve included it in ignored packages list.

  • @peterg4000 This is how the last upgrade was starting here

    [[email protected] ~]$ sudo pacman -Syu
    [sudo] password for just: *********
    :: Synchronizing package databases...
     core is up to date
     extra is up to date
     community is up to date
     multilib is up to date
     antergos is up to date
    :: Starting full system upgrade...
    warning: python2: ignoring package upgrade (2.7.9-1 => 2.7.10-1)     <--
    resolving dependencies...
    looking for conflicting packages...
    :: python2-no-hardening and python2 are in conflict. Remove python2? [y/N] y  <--
    

    There are two points to note here (marked with <-- ):

    1. python2 upgrade from 2.7.9 to 2.10.10 is ignored (due to IgnorePkg + … instruction)

    2. good pacman wants to replace python2 with python2-no-hardening - pacman is simply fantastic; that’s exactly what I’d like to do

    If you see the same two things on your computer (or better, the 2nd one, as you don’t use IgnorePkg), go ahead and let pacman do its excellent job.

    Again, if you wish, post your output here (without executing the command), we’ll look at it together and decide, how to proceed.

  • Hang on - Do I need the IgnorePkg or not? @just - Your first and last comments seem to contradict.

    I presumed the celebration here was that a normal update (no IgnorePkg) should work.

    But not so happy an outcome for me. My mintmenu is not working after a normal update. The previous error dialog does not pop up, but after the update mintmenu just doesn’t appear on the panel when I try to add it.

    I ran sudo pacman -Syu to get to this point, and the output is shown below.
    (I just accepted everything because I have a backup of the VM I can restore)


    :: Synchronizing package databases…
    core is up to date
    extra is up to date
    community is up to date
    multilib is up to date
    antergos 474.3 KiB 92.2K/s 00:05 [######################] 100%
    :: Starting full system upgrade…
    resolving dependencies…
    looking for conflicting packages…
    warning: removing ‘python2’ from target list because it conflicts with ‘python2-no-hardening’
    :: python2-no-hardening and python2 are in conflict. Remove python2? [y/N] y

    Packages (3) mate-mint-menu-5.6.4-3 python2-2.7.9-1 [removal] python2-no-hardening-2.7.10-1

    Total Download Size: 11.40 MiB
    Total Installed Size: 72.81 MiB
    Net Upgrade Size: 0.63 MiB

    :: Proceed with installation? [Y/n] y
    :: Retrieving packages …
    python2-no-hardening-2.7.10-1-x86_64 11.2 MiB 772K/s 00:15 [####################################] 100%
    mate-mint-menu-5.6.4-3-any 238.6 KiB 81.4K/s 00:03 [####################################] 100%
    (2/2) checking keys in keyring [####################################] 100%
    (2/2) checking package integrity [####################################] 100%
    (2/2) loading package files [####################################] 100%
    (2/2) checking for file conflicts [####################################] 100%
    (3/3) checking available disk space [####################################] 100%
    (1/1) removing python2 [####################################] 100%
    (1/2) installing python2-no-hardening [####################################] 100%
    Optional dependencies for python2-no-hardening
    tk: for IDLE
    python2-setuptools
    python2-pip
    (2/2) upgrading mate-mint-menu [####################################] 100%

    P.S. Happy for someone to tell me how to do block code sections! Surely I don’t have to add 4 spaces to every line…

    P.P.S. Sorry to keep bothering you guys. But thanks a heap for the outstanding support.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    Hang on - Do I need the IgnorePkg or not?

    No, IgnorePkg is not needed. It’s an optional only.

    @just - Your first and last comments seem to contradict.

    Don’t think so, but let’s not waste time searching for it.

    I presumed the celebration here was that a normal update (no IgnorePkg) should work.

    Yes, it does. IgnorePkg doesn’t matter in this context.

    But not so happy an outcome for me. My mintmenu is not working after a normal update. The previous error dialog does not pop up,…

    That’s exactly what the upgrade has fixed. Nothing else.

    …but after the update mintmenu just doesn’t appear on the panel when I try to add it.

    That’s another problem, unrelated to the upgrade.

    Don’t know, why you can’t add the applet. I’ve just added 4 (four) more mintMenu applets to the panel. There are 5 (five :astonished: !) mintMenus in the panel now. All 5 work:

    antergos-mate-mintmenu.png

    Please, describe with maximal precision all, even the most minimal steps that you perform to add the applet to the panel. Where you click, with what mouse button, what menu or window opens, which option you select from them, how do you exit from the dialogs, etc. Attach screenshots, if you can.

    I ran sudo pacman -Syu to get to this point, and the output is shown below.
    (I just accepted everything because I have a backup of the VM I can restore)

    Excellent.

    > ...
    > warning: removing 'python2' from target list because it conflicts with 'python2-no-hardening'
    > :: python2-no-hardening and python2 are in conflict. Remove python2? [y/N] y
    

    Good. Python2 is about to be removed and replaced by python2-no-hardening

    > Packages (3) mate-mint-menu-5.6.4-3  python2-2.7.9-1 [removal]  
    

    Good. You (correctly) have no python2 2.7.10 installed, so pacman is about to (correctly) remove 2.7.9

    ...
    python2-no-hardening-2.7.10-1
    > 
    > Total Download Size:   11.40 MiB
    > Total Installed Size:  72.81 MiB
    > Net Upgrade Size:       0.63 MiB
    > 
    > :: Proceed with installation? [Y/n] y
    > :: Retrieving packages ...
    >  python2-no-hardening-2.7.10-1-x86_64      11.2 MiB   772K/s 00:15 [####################################] 100%
    

    Good, Python2-no-hardening is installed.

    > ...
    > Optional dependencies for python2-no-hardening
    >     tk: for IDLE
    >     python2-setuptools
    >     python2-pip
    > ...
    

    Pacman suggests optional dependencies for successfully installed packages only. It confirms that python2-no-hardening is installed.

    P.S. Happy for someone to tell me how to do block code sections! Surely I don’t have to add 4 spaces to every line…

    Put three back-ticks ``` on the empty line BEFORE the code block. Put the same three back-ticks on the empty line AFTER the code block. Two lines with back-ticks enclose a code block. There’s no need to shift code lines by 4 spaces to the right.

    To summarize. Everything looks well with your upgrade. Can’t figure out why you can’t add it to the panel.

  • @peterg4000 Also, please share the output of

    $ pacman -Q python2 python2-no-hardening
    error: package 'python2' was not found
    python2-no-hardening 2.7.10-1
    $ 
    

    It must return exactly the same output as above, which means:

    1. python2 is not installed anymore
    2. python2-no-hardening is installed, and is at latest version

    It’s the correct.configuration for mate-mint-menu to work.

  • I’ve reverted to my backup and repeated the process - Exactly the same outcome.

    I right-click on the panel at bottom of screen and select ‘Add to Panel’. (I have tried the right-click at various blanks places in the panel)
    The ‘Add to Panel’ screen comes up listing a bunch of things.
    I scroll down to “mintMenu” (Subtitle: “Advanced Menu”).
    (Interestingly, it has no graphical icon like every other item. Points to something weird?)
    I click it, and then click “+ Add” button. Nothing happens. No error message. No change to panels.

    Adding anything else (Eg “Main Menu”) works fine.

    The python packages look right. Here is my transcript:

    [[email protected] ~]$ pacman -Q python2 python2-no-hardening
    error: package 'python2' was not found
    python2-no-hardening 2.7.10-1
    [[email protected] ~]$ 
    

    The only other variable I can think of is that I DID unload mintMenu from the panel earlier on when it was playing up from the python update (and the dialog popping suggested I do so).
    Remember - You talked me through how to add it back after I reverted python. But it DID work fine with Python reverted. It just goes kaboom now after a full update.

    Bit of a mystery. I thank you again for your help. Sorry for being the problem child this week. I’m sure you have better things to do. I know I do. :cry:

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    I’ve reverted to my backup and repeated the process - Exactly the same outcome.

    That’s bad.

    I right-click on the panel at bottom of screen and select ‘Add to Panel’.
    The ‘Add to Panel’ screen comes up listing a bunch of things.
    I scroll down to “mintMenu” (Subtitle: “Advanced Menu”).
    (Interestingly, it has no graphical icon like every other item. Points to something weird?)

    No, nothing weird. That’s normal. It has no icon in Add to panle window list.

    I click it, and then click “+ Add” button…

    Up to this point, everything is perfect.

    … Nothing happens. No error message. No change to panels.

    That’s a mystery, really.

    Adding anything else (Eg “Main Menu”) works fine.

    There’s nothing strange here. Only mintmenu+pythonw2 were affected.

    The python packages look right. Here is my transcript:

    [[email protected] ~]$ pacman -Q python2 python2-no-hardening
    error: package 'python2' was not found
    python2-no-hardening 2.7.10-1
    [[email protected] ~]$ 
    

    It’s perfect as well. If it was wrong, you’receive that bad initial error message in small window, blaming python2, mintmenu, and all the rest of the world…

    The only other variable I can think of is that I DID unload mintMenu from the panel earlier on when it was playing up from the python update (and the dialog popping suggested I do so).

    That’s bad. That may be the main - and only - reason for the problem. I never unload mintmenu from the panel. Unfortunately, mintmenu is not very stable, and from time to time it start to give some problem. With time, the problem gets solved (like now). But if I’ve unloaded mintmenu previously, than the only way remaining to restore it is… Don’t remember anymore, which one. The rule of thumb is simple - don’t unload it, if it’s broken. Wait until it will be solved. It will automagically return back to the panel.

    Remember - You talked me through how to add it back after I reverted python. But it DID work fine with Python reverted. It just goes kaboom now after a full update.

    Don’t follow you anymore :smile: .

    Bit of a mystery. I thank you again for your help. Sorry for being the problem child this week. I’m sure you have better things to do. I know I do. :cry:

    Dai, forza e coraggio! Don’t be upset. A problem, which makes you desperate now, will make you laughing tomorrow.

    A last (and stupid) thing. What happens if, after you have selected the mintMenu item in the “Add to panel” window, instead of clicking the +Add button you drag&drop the applet to the panel? With the left mouse button. A simple drag&drop. Can you drop the applet to the panel?

  • @just - Drag&Drop has the same result. When I release over the panel, nothing happens.
    Tried it with other items and they drop fine.

    I recall I was somewhat forced to do the Unload. The dialog gave me 2 options… One option just resulted in the dialog popping straight back up again (Maybe it was ‘restart’?), the other option was Unload.

    Bah! - I’ll kick off another fresh install as I go to bed. We’ll see if it is good then. G’nite!

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • This may be as surprising to you as it is to me, but even after a fresh (un-modded) 2015-08-18-x86_64 install of Antergos using Mate, I STILL HAVE NO WORKING MINTMENU. Same behaviour. Attempting to add to panel silently fails.

    The only things I did after the fresh install are: (Since I am running it under VirtualBox)

    $ sudo pacman -S virtualbox-guest-utils
    $ sudo systemctl enable vboxservice
    $ sudo reboot now
    

    No Mint Menu.

    I don’t recall seeing the menu even before the above commands, though kicking myself for not checking for sure. I don’t interact with the desktop before I install virtualbox-guest-utils as the mouse is chaotic and I can’t even click the panels. I get a shell via Alt-F2, and run the above commands as an Arch habit now…

    Anyhoo, this is becoming a bit of a problem now… I was fairly keen to give Mate a trial under Antergos, but this has held me up for a couple of days now.

    What can I do to help someone figure this out further, assuming someone wants to?

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • Hi just!
    Pardon the intrusion into the post, I want to know it is where I get the source of those letters are https://i.imgur.com/Qi7txQq.png as well and are very beautiful in form.
    Thank you.-

    Autodidacta en la VIDA …y en Linux, también.

  • @peterg4000 Could it be a problem related to VIrtualBox?

    Don’t know. VMs are never used here. Everything runs on bare metal.

  • @judd It’s Ubuntu Condensed 16 points. Running at 1920x1080 screen resolution.

    Good question. Thanks for it.

  • @peterg4000 :
    Did you uninstall python2 and install python2-nohardening as @just suggested in the first post?

  • @karasu - Been through that. My reading of the first post is that the whole point is it should work now without any special handling.

    Am I reading that right??? I have questioned this already in this thread.
    Note also the install media I am using: (un-modded) 2015-08-18-x86_64 - This is OK, right? Or do I need newer/modded?

    I guess what I am reporting is it doesn’t work. Not for me anyway. Not even from a fresh install as I described above.

    I can’t imagine it’s a VM thing. I DID have it working for a short while by rolling back the python version manually with help from @just. However, based on this thread I (firstly) did a normal full update. Happy turned to sad. Secondly did a full re-install from media. Still no joy.

    I am really here reporting to help you guys to help everyone else who wants to use Mate…
    If I just wanted to fix it for myself I would try rolling back python again. Actually, I probably should try that and see what it does… Will do when I have some spare time…

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @judd Just some pictures

    1. The font used is Ubuntu Condensed 16 pt
      http://img.ctrlv.in/img/15/09/02/55e66d77e248e.png

    2. For LCD monitors, the best fonts rendering may be obtained with
      http://img.ctrlv.in/img/15/09/02/55e66d9f5ec94.png

    3. I add fonts by hand, without installing any package. Probably, Ubuntu Condensed is included in the ttf-ubuntu-font-family package
      http://img.ctrlv.in/img/15/09/02/55e66dbc52fc4.png

    4. After adding new fonts by hand

    • rebuild fonts caches

      fc-cache -fv
      
    • logout and log back in to the X session, to see the effect

  • @peterg4000 said:

    …My reading of the first post is that the whole point is it should work now without any special handling.

    In fact, it worked exactly that way. No special handling was required. No manual intervention. Nothing more than a simple (daily) upgrade

    sudo pacman -Syu
    

    The only action required from the user was to accept (very good) pacman’s choices. Nothing more.

    The OP just tried to explain in details what was happening during the upgrade.

    Usually, if mintMenu breaks, somebody almost immediately notifies the forum about it. Till now, seems like the problem affects your system only.

  • OK, well, it seems I will be using Cinnamon or KDE or maybe the ‘non-Mint’ Main Menu for a while until the problem fixes itself(?). .

    I tried doing a bit of strace-ing on mate-panel but couldn’t spot anything illuminating in the trace when I clicked ‘Add’ for mintMenu. Couldn’t find any debug options for it. I think I’ll be giving up on this one for now. Woe is me. I hate leaving a problem un-fixed.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    …I hate leaving a problem un-fixed.

    Me too. It’s a pity.

    Well, so I’m about to remove from the panel 4 unneeded mintMenus :smile: , leaving only one. They are of no help.

mate-mint-menu6 python23 Posts 23Views 5980
Log in to reply