• Re-run of Cnchi after failure, causes second failure from /install busy


    My KDE install attempts are failing due to package name change kdebase-dolphin -> dolphin.

    Anyhoo, trying work-arounds I found that an attempt to re-run Cnchi results in a failure to create the partition table just after I typed in the host and user specs (for the ump-teenth time today). How annoying.

    Looking at the logs, ‘wipefs’ fails with the partition busy.
    Using fuser and ps, the offending process is “gpg-agent --homedir /install/etc/ … …”

    Simply killing that process and trying cnchi again seemed to get past the partition initialisation.

    KDE install still failing on missing packages though. Think I will give up on KDE until it stabilises…

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    …Anyhoo, trying work-arounds I found that an attempt to re-run Cnchi results in a failure…

    If Cnchi fails, then computer’s reboot is the best way to run it again.

  • I’m mostly reporting this to help improve Cnchi.

    Problems in the installer will scare people off very quickly. I’d imagine the team would be wanting to fix little glitches like this ASAP…

    In this case I didn’t want to reboot as I had modified the cnchi package list to try and get around the KDE package renaming issues. The problem extended beyond just dolphin though, so I gave up on KDE for now.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    …In this case I didn’t want to reboot as I had modified the cnchi package list…

    OK, got it. I’ve missed that part.

  • About the reboot, once Cnchi has partitioned your harddrive, kernel does not allow to do it again (without a reboot, that is).

    We’re working to do package checking BEFORE partitioning, but we do not know when this will be ready (or even possible).

    Cheers!

  • KDE install still failing on missing packages though.

    Do you have the log? That would be most helpful.

    Think I will give up on KDE until it stabilises…

    Yes, that’s a wise thought.

  • The problem extended beyond just dolphin though, so I gave up on KDE for now.

    Maybe there’s another package renaming that we’re not aware of…

  • @karasu
    Just launched a vm to check, and it’s still in there…

    @peterg4000
    Since this has been fixed on github, you fix it with the following…

    sudo pacman -S git
    sudo rm -rf /usr/share/cnchi
    git clone https://github.com/Antergos/cnchi --depth=1
    cd cnchi
    ./run
    

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

  • Thanks @Wyn. I followed your instructions and got a working KDE desktop.

    After trying most of the desktops I think I lean towards KDE. It seems fully featured and everything I look for I can find… Does seem a bit slow to boot though.

    Anyway, thanks again.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • Does seem a bit slow to boot though.

    It is (at least compared to other DE’s).

    Cheers!

cnchi109 installation205 Posts 10Views 1625
Log in to reply