• "mintMenu has quit unexpectedly" after fresh install using Mate


    Antergos newbie migrating from native Arch. Liking what I have seen so far. It’s awesome that I can try multiple desktops from one install medium, and all fairly lightweight. Still trying to figure out which desktop is for me. Linux fragmentation really is a pain, and is without a doubt holding back adoption… But let’s not start that debate here…

    To my bug:
    I am installing to 64-bit VMs under VirtualBox (with a Linux Mint host).
    After a fresh install I immediately get the error dialogue as described in the title.

    Same after “pacman -S virtualbox-guest-utils” and “systemctl enable vboxservice” and a reboot.

    Anyone want to help me fault-find? or should I just go with KDE…

    P.S. Love the website. Such a great website gives me very high hopes for Antergos. I will stay tuned…

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 mintMenu is currently a common Mate problem among many Arch-based distros. mintMenu currently works without a problem in LinuxMint-Mate itself. It doesn’t work nicely in Antergos, Manjaro, Bridge, BlueStar, the native Arch.

    The problem has no relation to VirtualBox.

    It is caused by some incompatibility between two packages:

    1. mate-mint-menu
    2. python2

    mate-mint-menu package doesn’t like the recent python2 2.7.10 . It works perfectly with the previous python2 version - 2.7.9 .

    In Antergos-Mate, it’s OK to have the the most recent 5.6.4 of mate-mint-menu package installed:

    mate-mint-menu-5.6.4-2-any.pkg.tar.xz
    

    To make it work, it’s enough to downgrade python2 from 2.7.10 to 2.7.9 . It solves the problem not only in Antergos but also in all above mentioned distros.

    Edit

    Stay with Antergos-Mate. It’s marvelous. Avoid troubles with current KDE state.

  • Thanks for that. I’ll try to downgrade python.

    Unfortunately this appears to be non-trivial in arch, but I’m sure Google knows.

    Any quick tips appreciated though…

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    …Unfortunately this appears to be non-trivial in arch…

    Can’t agree. If you’re coming from Arch, you’re probably familiar with Arch Rollback Machine (ARM) . It holds old packages for much time ago, for various archs, organized in many different ways.

    Python2, for example, is present here .

    Download python2-2.7.9-1-x86_64.pkg.tar.xz to the local disk.

    Then install downloaded package (downgrading python2 from 2.7.10 to 2.7.9) :

    sudo pacman -U <path-to-package>
    

    For example,

    $ sudo pacman -U '/1st/dnl/python2-2.7.9-1-x86_64.pkg.tar.xz'
    [sudo] password for just: *********
    loading packages...
    warning: python2-2.7.9-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) python2-2.7.9-1
    
    Total Installed Size:  70.03 MiB
    Net Upgrade Size:       0.00 MiB
    
    :: Proceed with installation? [Y/n] No, thanks, already done
    $ 
    

    Pretty easy.

  • Thanks for that help. I was a user of Arch, not much of an expert. :wink:

    I guess by ‘trivial’ I had hoped for a simple option to pacman to specify the version of packages desired.
    But anyhow, thanks, you have educated me. Not that hard. And Done.

    However, 2 issues:

    1. If I just try to manually run “mintmenu” from a shell now, it still barfs. “python --version” returns “Python 3.4.3” which is probably the problem. I presume the desktop somehow arranges mintmenu to use Python2.

    2. I clicked ‘Unload’ (from Panel) at some point when mintmenu was barfing. How the heck do I get it back into its rightful place in a Panel? Looked around and can’t figure it out. Never used Mate before so not even sure what I am looking for.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    1. I clicked ‘Unload’ (from Panel) at some point when mintmenu was barfing. How the heck do I get it back into its rightful place in a Panel?..

    After downgrading python2:

    • log out
    • log back in
    • pacman will propose to upgrade python2 to 2.7.10. Do NOT do that.
    • right click on a free space in Mate’s panel, or left-right panel’s extreems, if there’s no free space, or on top-bottom extreems if you have placed the panel vertically
    • panel’s popup menu will open
    • choose Add to Panel… option (the first one) from it
    • Add to Panel window will open
    • select mintMenu in the list
    • click +Add button, or drag&drop mintMenu item to the panel
  • Solved! Is working now.
    Thanks so much for the excellent help @just .

    I have learnt a few things today.

    [Was peterg4000 but got sick of that lame user name. And no, the photo is not actually me]

  • @peterg4000 said:

    Solved! Is working now.
    Thanks so much for the excellent help @just .

    De nada.

    I have learnt a few things today.

    :thumbsup:

    That’s the most important thing. We all constantly learning something new in Linux (except @lots.0.logs and @karasu - they know everything :laughing: ). Just never stop doing that.

mate-mint-menu6 installation192 mate42 Posts 8Views 1691
Log in to reply