• Problem with Codeblocks


    I created a codeblocks project to my pendrive, I can save/compile, but I can’t run the project.
    Why? What’s the wrong?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • I created a codeblocks project to my pendrive, I can save/compile, but I can’t run the project.
    Why? What’s the wrong?

    Don't forget to mark as [SOLVED], if your problem was solved!

  • The issue is permissions related. You need to ensure your user is allowed to read/write the files. I am not familiar with codeblocks so I am not sure if it allows you to save a copy of the entire project like a “save as” function. If you could save the project to your /home and then copy all those files to the usb drive the permissions would stick with the files. Make sense? Hopefully it helps.

    Alternatively, you could use gnome-disk-utility to setup an automatic mount for your drive and allow regular user access.

    Regards,

  • Thank you your reply
    I installed the gnome’s disk utility.
    I added the “exec” argument but, I can not edit my files now.
    I get a dialog that "Permission denied"
    I love Linux!

    Don't forget to mark as [SOLVED], if your problem was solved!

  • Remove nosuid and nodev options. It works on my usb drive without those options. Also change the mount point to something like /mnt/pendrive (create it first with “sudo mkdir /mnt/pendrive”). Then change the permissions with “sudo chown -R your_user_name /mnt/pendrive” If that doesn’t fix you will probably need to go with the other option I mentioned

    Regards,

  • @“lots.0.logs”:8irg4iip said:

    Remove nosuid and nodev options. It works on my usb drive without those options. Also change the mount point to something like /mnt/pendrive (create it first with “sudo mkdir /mnt/pendrive”). Then change the permissions with “sudo chown -R your_user_name /mnt/pendrive” If that doesn’t fix you will probably need to go with the other option I mentioned

    Regards,[/quote:8irg4iip]

    I removed nosuid and nodev options, but nothing.
    I created the /mnt/mini-stick/ folder, but when I tried to change owner I got “Operation not permited” (or something like that)

    Idiot Linux.

    Don't forget to mark as [SOLVED], if your problem was solved!

  • @“I-sty”:3igz8yx4 said:

    I created the /mnt/mini-stick/ folder, but when I tried to change owner I got “Operation not permited” (or something like that)[/quote:3igz8yx4]

    You have to change the permissions. This must be done as root (or sudo). Use the command from my previous post: [http://forum.antergos.com/posting.php?mode=reply&f=6&t=1215#pr4180][0]">posting.php?mode=reply&f=6&t=1215#pr4180

    If that command doesn’t do it then use this instead: “sudo chmod 777 /mnt/pendrive”

    Cheers!

    [0]: <a href=

Posts 7Views 812
Log in to reply