• KDE Installer not working


    It appears, at least for me, that the cnchi for kde is not working.
    I get the Can’t create package list error. The log says its unable to find kdebase-dolphin, tried multiple times, same error.
    Installing gnome gives no error for example.

  • @xsxavier Yes its not working. And it wasn’t working for me either they need to fix it

  • @xsxavier said:

    It appears, at least for me, that the cnchi for kde is not working…

    Cnchi continues to work good. But it can’t stand behind the recent transition from KDE to Plasma. Which is happening right now, these days.

    kdebase-dolphin from good old KDE4 was removed. It doesn’t exist anymore. Cnchi still tries to install it and fails:

    $ sudo pacman -Si kdebase-dolphin
    [sudo] password for just: *********
    error: package 'kdebase-dolphin' was not found
    $ 
    

    The removal of kdebase-dolphin causes many problems in old Antergos-Kde installations. Especially for Dolphin instances started with root privileges.

    Plasma has replaced it by another package. It is called simply dolphin now:

    $ sudo pacman -Si dolphin
    Repository     : extra
    Name           : dolphin
    Version        : 15.08.0-1
    Description    : File Manager
    Architecture   : x86_64
    URL            : http://kde.org/applications/system/dolphin/
    Licenses       : LGPL
    Groups         : kde-applications  kdebase
    Provides       : None
    Depends On     : baloo-widgets  knewstuff  kio-extras  ktexteditor  kactivities-frameworks
    Optional Deps  : kdebase-lib: Document templates
    Conflicts With : kdebase-dolphin<15.08
    Replaces       : kdebase-dolphin
    Download Size  : 1003.82 KiB
    Installed Size : 3230.00 KiB
    Packager       : Antonio Rojas <[email protected]>
    Build Date     : Tue 18 Aug 2015 13:46:23 MSK
    Validated By   : MD5 Sum  SHA256 Sum  Signature
    
    [$
    

    Other Antergos’ DEs install nicely because they are not affected by KDE-to-Plasma transition.

  • 0.10.26 has this fixed for sure.

    An easy way to fix it yourself is to edit the file /usr/share/cnchi/data/packages.xml

    Search for kde-dolphin and change it to dolphin.

    Cheers!

  • @karasu

    Can confirm it’s been fixed, I’ve been submitting the pulls and version bump was a day after kde fix :).

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

Posts 5Views 1093
Log in to reply