• setup virtual console failed


    I don’t run antergos all that often - my main OS is Arch from an Arch install. However, recently I’ve been getting verbose startup messages. Using “sudo journalctl -b” I found this error:

    [Aug 28 09:52:56 altair systemd[1]: Failed to start Setup Virtual Console.
    Aug 28 09:52:56 altair systemd[1]: systemd-vconsole-setup.service: Unit entered failed state.
    Aug 28 09:52:56 altair systemd[1]: systemd-vconsole-setup.service: Failed with result 'exit-code

    I’ve hunted through the Arch forums and not found a solution that works.Any ideas?

  • @toothandnail Virtual console configuration file is

    /etc/vconsole.conf
    

    It contains only one line:

    $ cat /etc/vconsole.conf
    KEYMAP=us
    $ 
    

    Sometimes the country code is not set correctly. For example, one time it was set here to the wrong value (not in Antergos, but in another Arch-based distro)

    KEYMAP=gb
    

    for the English (UK) keyboard. It was causing error messages on boot.

    The correct virtual console code for English (UK) keyboard is

    KEYMAP=uk
    

    Once set to this value, all error messages on boot are gone.

  • Thanks - that was it. Much better with a quiet boot again.

    Paul.

  • @toothandnail said:

    …Much better with a quiet boot again.

    Sure :smile: ! Thanks for marking the topic as Solved :thumbsup: .

  • @just

    When a canada is used KEYMAP=ca is always used and it ends up failing.

    I7 [email protected]/32GB Ram/3440 x 1440 + 1440p/EVGA 1080 FTW/512GB SSD/2TB HD/Antergos Base w/ Plasma

Posts 5Views 1342
Log in to reply