• Nvidia PRIME


    Hello everybody! I really like this OS, but I have some problems with drivers on Nvidia Optimus. Bumblebee does not suit me and I need to prime Nvidia. In Kubuntu prime Nvidia works perfectly. Is it possible to configure this OS?
    The xorg.conf file in Kubuntu:
    Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
    EndSection

    Section "Device"
    Identifier "intel"
    Driver "intel"
    BusID "PCI:[email protected]:2:0"
    Option “AccelMethod” "SNA"
    EndSection

    Section "Screen"
    Identifier "intel"
    Device "intel"
    EndSection

    Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:[email protected]:0:0"
    Option “ConstrainCursor” "off"
    EndSection

    Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option “AllowEmptyInitialConfiguration” "on"
    Option “IgnoreDisplayDevices” "CRT"
    EndSection

    nvidia_prime[1].jpg

    Running nvidia-xconfig or replacement xorg.conf Kubuntu file in the this OS does not help. Please help to configure Nvidia.

  • Make sure you have Intel video driver installed as well.

  • Please, write what commands I have to perform to install the necessary drivers. My laptop specifications: Lenovo Y580, Intel i7 3610qm, Nvidia Geforce GTX660M, 16GB, SSD.

  • nVidia Optimus cards need only one package to be installed: xf86-video-intel . The package provides Intel GPU video driver.

    $ sudo pacman -S xf86-video-intel
    [sudo] password for just: *********
    warning: xf86-video-intel-1:2.99.917+381+g5772556-1 is up to date -- reinstalling
    resolving dependencies...
    looking for conflicting packages...
    
    Packages (1) xf86-video-intel-1:2.99.917+381+g5772556-1
    
    Total Download Size:   0.64 MiB
    Total Installed Size:  2.08 MiB
    Net Upgrade Size:      0.00 MiB
    
    :: Proceed with installation? [Y/n] No, thanks
    $ 
    

    The rest - nouveau or nvidia drivers - is optional. nVidia Optimus doesn’t need them to work.

  • I want that my laptop always worked via the proprietary driver of a nvidia.
    After loading of system with these settings - the black screen.
    Here Xorg.0.log:
    http://rghost.net/8rtVqycxK
    xorg.conf:
    http://rghost.net/8wMxbp4ML

    Sorry, pastebin in Russia dont work 😞

  • I found that the proprietary driver does not work without the package nvidia-prime, there is a way to obtain and install this package in Antergos?
    https://launchpad.net/ubuntu/vivid/amd64/nvidia-prime/0.8.1
    Is it possible to convert the package to Antergos?

  • In Arch you need to use Bumblebee with nvidia driver, if you use noueveau, you can use prime thats built into the kernel.

  • I work in a blender, and measurements show that Nvidia-prime works better. And I do not want to enter each time primusrun. 😞

  • I found a solution to this problem! Here are step by step instructions. Suitable for laptops with Optimus technology, in particular the Lenovo Y580.

    https://wiki.archlinux.org/index.php/NVIDIA_Optimus

    1. Delete nouveau

    2. Install nvidia, nvidia-libgl, xorg-xrandr

    Tip: lspci | grep -E "VGA|3D"
    to know PCI address

    1. Edit /etc/X11/xorg.conf :

    Section "ServerLayout"
    Identifier "layout"
    Screen 0 "nvidia"
    Inactive "intel"
    EndSection

    Section "Device"
    Identifier "nvidia"
    Driver "nvidia"
    BusID "PCI:1:0:0"
    EndSection

    Section "Screen"
    Identifier "nvidia"
    Device "nvidia"
    Option “AllowEmptyInitialConfiguration” "Yes"
    EndSection

    Section "Device"
    Identifier "intel"
    Driver "modesetting"
    BusID "PCI:0:2:0"
    Option “AccelMethod” "none"
    EndSection

    Section "Screen"
    Identifier "intel"
    Device "intel"
    EndSection

    1. Next, add the following two lines to the beginning of your $ ~/.xinitrc:

    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto

    1. If you are using a display manager then you will need to create or edit a display
      setup script for your display manager instead of using ~/.xinitrc.

      !LightDM
      For the LightDM display manager:
      /etc/lightdm/display_setup.sh
      xrandr --setprovideroutputsource modesetting NVIDIA-0
      xrandr --auto
      Make the script executable:

    chmod +x /etc/lightdm/display_setup.sh

    Now configure lightdm to run the script by editing the [SeatDefaults] section in /etc/lightdm/lightdm.conf:

    /etc/lightdm/lightdm.conf
    [SeatDefaults]
    display-setup-script=/etc/lightdm/display_setup.sh
    Now reboot and your display manager should start.
    !SDDM
    For the SDDM display manager:
    /usr/share/sddm/scripts/Xsetup
    xrandr --setprovideroutputsource modesetting NVIDIA-0
    xrandr --auto
    !KDM
    For KDE’s KDM, add the xrandr lines into /usr/share/config/kdm/Xsetup

  • @Doaxan said:

    I found a solution to this problem!..

    Could you mark the topic as [Solved] , if you firmly believe that? Thank you.

  • @just said:

    Could you mark the topic as [Solved] , if you firmly believe that? Thank you.

    The google-chrome, nothing happens when you press the “Mark as Solved”, in Firefox when trying to login writes “Failed login attempt, please try again. Can not set property ‘user’ of undefined” 😧

nvidia138 nvidia optimus11 prime7 Posts 11Views 6703
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.