• Error Meaning?


    Package installation error:
    Trying to install any package results in this error:
    Error: Fails to init transaction
    Details: unable to lock database.

    A search of installation / newbie / packages lists numerous items but none that help with this specific error.
    New to Antergos / Arch but not linux. Any ideas?
    nathan33.

  • @nathan33

    unable to lock database

    Means it cannot lock the package database to prevent two applications modifying it.

    Are you using pamac (graphical) or pacman (in a terminal) ?

  • Actually, I tried both, each with the same result.
    I tried the graphical first, on several packages. Closed the GUI.
    Opened a terminal and tried again via cli, same result.
    I searched the Antergos forums again with no luck.
    I’ll probably look into the Arch forums next time I log on, or look again at the
    Packages section of this forum.

  • @nathan33 Are you getting this during installation of Antergos or while trying to install packages? If the latter, and you’re sure no package operations are in process, just manually delete the lock file -
    sudo rm /var/lib/pacman/db.lck
    also see
    https://wiki.archlinux.org/index.php/Pacman_tips

    Note also - update managers often also create this lock file. You should really only have to do the above if a package manager quits or is killed unexpectedly, if this continues happening I recommend figuring out the culprit.

  • Thank you.
    This fixed the problem.
    I was trying to install a solitaire game and then Chrome after I had already installed
    Antergos.
    Things to learn!
    Nathan

Posts 5Views 929
Log in to reply