• How to remove nouveau, Install nvidia


    01:00.0 VGA compatible controller: NVIDIA Corporation GK104 [GeForce GTX 760] (rev a1)
    Subsystem: eVga.com. Corp. Device 3769
    Kernel driver in use: nouveau

    How do i remove nouveau. And then i can install nvidia drivers

    Thank you

  • Do not remove nouveau (it’s not necessary).

    Here you have the Arch wiki guide (it will work with Antergos):
    https://wiki.archlinux.org/index.php/NVIDIA#Installing

    Ask if you have any questions!

    Cheers!

  • @karasu ok thanks. so what do i do to install nvidia. I did this before when i had KDE up and running but it crashed or something when i installed this. pacman -S nvidia nvidia-utils

    It made the screen bigger then it should have been

    Is that all i have to do or something else too

    Also did u see my KDE post How can i get it if is not working . I’m i able to get it now when i’m in cinnamon

    Thank you

  • @karasu

    I did this pacman -S nvidia nvidia-utils

    now my screen is BIG said there’s no video card driver installed so i’m not sure what happend

  • Did you install nvidia-libgl?

  • @karasu yes i did. Know it crashed with a timer something. I have to reinstall cinnamon now again

  • Did you run nvidia-xconfig, and then you rebooted your computer?
    Your graphics card should work with the nvidia driver.
    Have you checked Xorg’s log? It’s the file /var/log/Xorg.0.log, check for any line that starts with EE (means error).

  • @karasu
    Sorry i didn’t put more information then what i said.

    I installed nvidia like this. sudo pacman -S nvidia nvidia-utils nvidia-libgl then i reboot but i get a white screen with just a mouse cursor that’s it
    I will try and get to this file for you Xorg’s log? It’s the file /var/log/Xorg.0.log

    Was i supposed run this nvidia-xconfig before i rebooted! let me try that.

    Thank you

  • @karasu
    Here is the log file before. Haven’t installed nvidia yet. I do see 1 EE not sure whats that about
    http://pastebin.com/beagffJn

    will write down and copy EE for all on log file for u when i install nvidia

    Thank you

  • @karasu
    OK after i run this. sudo pacman -S nvidia nvidia-utils nvidia-libgl

    This shows up

    Optional dependencies for nvidia-utils
    gtk2: nvidia-settings [installed]
    xorg-server-devel: nvidia-xconfig
    opencl-nvidia: OpenCL support

    So do i install this xorg-server-devel: nvidia-xconfig

    for nvidia-xconfig right? Because if i try it now i get this

    [[email protected] ~]$ nvidia-xconfig

    WARNING: Unable to locate/open X configuration file.

    WARNING: Unable to parse X.Org version string.

    Package xorg-server was not found in the pkg-config search path.
    Perhaps you should add the directory containing `xorg-server.pc’
    to the PKG_CONFIG_PATH environment variable
    No package ‘xorg-server’ found

    ERROR: Unable to write to directory ‘/etc/X11’.

  • @growlinwolf

    You need to run it with root privileges:
    sudo nvidia-xconfig

  • @karasu OK.
    And i got a white screen agin but i did not run that in root inside cinnmon. So i have to install again and try

    Also i cannat get that file once i get white screen /var/log/Xorg.0.log

    since i can’t login. so is there a way to get that file or look at it in consle. with ctrl alt F3 if i get white screen

  • You can boot in multi.user target.
    In grub, press ‘e’ key and add to your kernel line:
    systemd.unit=multi-user.target
    This will make your system boot in text mode.

    Cheers!

    P.S. More info : https://wiki.archlinux.org/index.php/Systemd#Targets

  • @karasu OK so that’s normal then u just changed it for the build

Posts 14Views 11013
Log in to reply
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.