• [SOLVED] (This War of Mine) No sound


    Hi fellow gamers,

    This War of Mine 1.3.2, downloaded from GOG, running on up-to-date Antergos OS x86_64
    Start fixed according to Arch Wiki troubleshooting (but in “lib” subdir instead)
    Game starts, intro, game menu, all good but one thing: there’s no sound.

    Running from command line:

    $ ./start.sh 
    Running This War Of Mine
    ALSA lib dlmisc.c:254:(snd1_dlobj_cache_get) Cannot open shared library /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
    AL lib: alsa.c:512: Could not open playback device 'default': No such device or address
    

    Odd. lib32-alsa-lib, lib32-alsa-oss and lib32-alsa-plugins are installed. Is the library missing or corrupted ?

    $ file /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
    /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so: ELF 32-bit LSB shared object, Intel 80386, version 1 (SYSV), dynamically linked, BuildID[sha1]=51e1281522bf5aeffe64cbbe8ff2fd6b817995ae, stripped
    

    The lib is there, up and running. Permissions ?

    -rwxr-xr-x 1 root root 30420 25 mars  20:21 /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so 
    

    Uh. Why the heck can’t the game open the lib…

    $ ldd /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so
    	linux-gate.so.1 (0xf7776000)
    	libpulse.so.0 => /usr/lib32/libpulse.so.0 (0xf76cf000)
    	libasound.so.2 => /usr/lib32/libasound.so.2 (0xf75c4000)
    	libc.so.6 => /usr/lib32/libc.so.6 (0xf740a000)
    	libjson-c.so.2 => /usr/lib32/libjson-c.so.2 (0xf73fd000)
    	libpulsecommon-6.0.so => /usr/lib32/pulseaudio/libpulsecommon-6.0.so (0xf7374000)
    	libdbus-1.so.3 => /usr/lib32/libdbus-1.so.3 (0xf731e000)
    	libpthread.so.0 => /usr/lib32/libpthread.so.0 (0xf7300000)
    	libdl.so.2 => /usr/lib32/libdl.so.2 (0xf72fb000)
    	libm.so.6 => /usr/lib32/libm.so.6 (0xf72ae000)
    	librt.so.1 => /usr/lib32/librt.so.1 (0xf72a4000)
    	/usr/lib/ld-linux.so.2 (0x56556000)
    	libxcb.so.1 => /usr/lib32/libxcb.so.1 (0xf727e000)
    	libsystemd.so.0 => /usr/lib32/libsystemd.so.0 (0xf71f0000)
    	libsndfile.so.1 => /usr/lib32/libsndfile.so.1 (0xf7177000)
    	libasyncns.so.0 => /usr/lib32/libasyncns.so.0 (0xf7170000)
    	libXau.so.6 => /usr/lib32/libXau.so.6 (0xf716b000)
    	libXdmcp.so.6 => /usr/lib32/libXdmcp.so.6 (0xf7164000)
    	libresolv.so.2 => /usr/lib32/libresolv.so.2 (0xf714b000)
    	liblzma.so.5 => /usr/lib32/liblzma.so.5 (0xf711f000)
    	libgcrypt.so.20 => /usr/lib32/libgcrypt.so.20 (0xf706f000)
    	libgpg-error.so.0 => /usr/lib32/libgpg-error.so.0 (0xf7059000)
    	libcap.so.2 => /usr/lib32/libcap.so.2 (0xf7054000)
    	libgcc_s.so.1 => /usr/lib32/libgcc_s.so.1 (0xf703a000)
    	libFLAC.so.8 => /usr/lib32/libFLAC.so.8 (0xf6fb7000)
    	libvorbisenc.so.2 => /usr/lib32/libvorbisenc.so.2 (0xf6f28000)
    	libnsl.so.1 => /usr/lib32/libnsl.so.1 (0xf6f0c000)
    	libattr.so.1 => /usr/lib32/libattr.so.1 (0xf6f06000)
    	libogg.so.0 => /usr/lib32/libogg.so.0 (0xf6efe000)
    	libvorbis.so.0 => /usr/lib32/libvorbis.so.0 (0xf6ecf000)
    

    Is PulseAudio causing issues ? Doesn’t seem so, sound works fine on VLC and other software/games even x86 and WINE, Steam etc. Only that game has this issue.

    $ aplay -L
    null
        Discard all samples (playback) or generate zero samples (capture)
    pulse
        PulseAudio Sound Server
    default
        Default ALSA Output (currently PulseAudio Sound Server)
    sysdefault:CARD=PCH
        HDA Intel PCH, ALC887-VD Analog
        Default Audio Device
    front:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        Front speakers
    surround21:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        2.1 Surround output to Front and Subwoofer speakers
    surround40:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        4.0 Surround output to Front and Rear speakers
    surround41:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        4.1 Surround output to Front, Rear and Subwoofer speakers
    surround50:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        5.0 Surround output to Front, Center and Rear speakers
    surround51:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        5.1 Surround output to Front, Center, Rear and Subwoofer speakers
    surround71:CARD=PCH,DEV=0
        HDA Intel PCH, ALC887-VD Analog
        7.1 Surround output to Front, Center, Side, Rear and Woofer speakers
    hdmi:CARD=NVidia,DEV=0
        HDA NVidia, HDMI 0
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=1
        HDA NVidia, HDMI 1
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=2
        HDA NVidia, HDMI 2
        HDMI Audio Output
    hdmi:CARD=NVidia,DEV=3
        HDA NVidia, HDMI 3
        HDMI Audio Output
    

    Of course, googling didn’t show up something strictly identical, downgrading to lib32-alsa-plugins-1.0.27 neither, downgrading lib32-libpulse, libpulse and pulsaudio neither, copying libasound_module_pcm_pulse.so in the game’s “lib” directory neither.
    I randomly tried symlinks here and there, and trying some PulseAudio hijacks in ~/.config/pulse, in the end it broke more stuff than fixethe game’s sound whose developers don’t seem very eager to update it according to Ubuntu releases, nevermind ArchLinux’ pace 😢

    Do anyone know some more hacks to test out ? Forcing ALSA playback device somehow ?
    Thanks !

  • Hi,

    What’s the output of pacman -Qo /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so? Do you also have the 64 bit version of alsa-plugins installed?

  • Yes, alsa-plugins are installed both 32 and 64 bits. (1.0.29-2).
    Below, the output of the command:

    /usr/lib32/alsa-lib/libasound_module_pcm_pulse.so  {belongs to}  lib32-alsa-plugins 1.0.29-2
    
  • If you figure out something, please let me know. I have almost exact same problem, although with steam version.

  • Hi, I solved the problem thanks to arch forums https://bbs.archlinux.org/viewtopic.php?pid=1558695#p1558695

  • Confirmed fixed in the binaries from Humble Bundle, GOG and Steam !
    Conclusion: two more libs from lib32-glibc must be copied into the game’s folder: libresolv.so.2 and libresolv-2.20.so
    And then, run the game with: LD_PRELOAD=libresolv.so.2 ./This\ War\ of\ Mine
    Thanks and enjoy :)

  • @gadelat The Arch forums are stuck in the mentality of manual is always better. Glad you fixed the issue without mentioning Antergos (They would’ve binned your topic otherwise).

Posts 7Views 10526
Bloom Email Optin Plugin

Looks like your connection to Antergos Community Forum was lost, please wait while we try to reconnect.