• cnchi 0.10.6 Partitioning Problem EFI FAT


    In Advanced Installation mode I have a problem with formatting the EFI and boot partition

    Before I mount the partitions the type of the efi partition is FAT32 and the type of the boot partition is EXT2

    After mounting the partitions the type change to just the word "FAT"
    In the log I get this message

    [2015-08-20 04:01:48] [advanced] WARNING: /boot or /boot/efi need to be fat32 in UEFI systems. Forcing it.
    

    After that I click install and I get a error
    Couldn’t format partition ‘/dev/sda2’ with label ‘AntergosBoot’ as ‘fat’

    Log
    http://pastebin.com/hE6Ywd3y

    Before Mount Image
    http://img4.imagetitan.com/img.php?image=11_beforemounts.png

    After Moubnt Image
    http://img4.imagetitan.com/img.php?image=11_aftermounts.png

  • Hi,

    Do you have an existing EFI partition? If so, you should NOT format it. You need only to mount it as /boot/efi.

    Cheers!

  • Hi,
    Now I’m trying to install, eighth attempt.

    But I have a problem with partitioning, at the last edition of this work.
    I have UEFI-GPT with dual boot windows.
    Create a FAT32 partition 300-600 megabytes of boot/efi and root / as ext4 …

    If I’ll continue with the installation, an error message appears that the partition boot/efi can not be formatted.

    After several of experiment, I found that if one section I choose the FAT32 format is changed automatically and fat32 partition to ext4, or conversely.

    So if I choose root as ext4, it will overwrite the boot/efi also ext4 and install the very end crashes when setting up the bootloader.

    I’m like to install two boot/efi separate partitions for Linux and Windows, it always worked well in previous versions antergos just another distribution.

    When I reinstall linux I just format or create a new boot/efi without getting to touch the windows partition.

    I tried to create a FAT32 partition, and then only mount during installation. It fits any error message and the installation continues.
    At the end of installation, but the error message that no permissions to write to sys /…/ boot / efi partition.

  • @lots.0.logs
    I’m also having the same problem with a clean hard drive that has no partitions on it

    Here are my steps that I used to get these errors

    • I select Gummiboot

    • Create new FAT32 500mb EFI partition and mount it at /boot
      After creating the partition the type change self to ‘fat’ and not ‘fat32’ like i selected

    • Create new EXT4 with the rest of the hard dive space mount as /
      Click install

    Error
    Couldn’t format partion ‘/dev/sda1’ with label" as ‘fat’

    After clicking ok the installation continues
    Then at Configuring your new system I get this Error

    [Errno 1] Operation not permitted: ‘/install/sys/firmware/efi/efivars’

    http://pastebin.com/rZiBqAKq

  • Hey ! I got exactly the same problem, with a new hdd. I’m using Cnchi 0.10.7 !

    Hope there will be a solution posted soon !

  • Same here with Cnchi 0.10.7 . And I was so excited…

  • Same here (cnchi 0.10.7), but I tried to find where is the problem, it is in one of cnchi scripts (probably) advanced.py located in /usr/share/cnchi/cnchi/installation/. With my amateur knowledges, I have replaced all words “fat” with fat32 and it is installing without this error at the moment (kde4, gummiboot, ext4 root partition and ext4 home partition ), I will let you know if it works (sorry for my english).

    EDIT:
    Worked, but another error appeared which is few posts above (not permissions to write to /install/sys/firmware/efi/efivars).

  • Hi,

    Problem is that in fs_module only knows about fat16 and fat32.

    @iDPropheCy your solution might work, but I’ve updated fs_module.py so it also understands “fat”

    Latest Cnchi version with this change (I’ve only tested on an UEFI VM as I do not have any UEFI computer with me):
    http://repo.antergos.info/iso/testing/uefi/antergos-staging/x86_64/cnchi-0.10.19-4-any.pkg.tar.xz

  • Thanks @karasu for fixing the problem
    I just did a full installation without any problems with the new 0.10.19.4 cnchi

    If someone else also wants to test the new cnchi
    Wait for cnchi to update and then close it
    Open a terminal

    wget http://repo.antergos.info/iso/testing/uefi/antergos-staging/x86_64/cnchi-0.10.19-4-any.pkg.tar.xz
    sudo pacman -U cnchi-0.10.19-4-any.pkg.tar.xz
    sudo -E cnchi -d -v
    
  • @pyUser
    Thanks it works for me!!

  • It finally works, I can confirm, thanks @karasu

  • Works like a charm, thank you!

  • Hi,

    Thanks all for your patience ;)

    Enjoy it!

Posts 13Views 2843
Log in to reply